Vero 4k+ boot problem

I was updating my Vero4k+ from sd-card and then we had a powerfailure for the whole house.
Now when i try again it wont boot from USB or SD-card.

waiting for root filesystem device /dev/vero-nand/root
FATAR ERROR: Could not fins root filesystem device /dev/vero-nand/root

help plz!

Well… i´m having a hard time here…

After trying 3 different sd-cards with the installer on win10, win11 and osx = no luck.

After trying with different usb-sticks i manage to get to a OSMC install screen BUT with the message:
INSTALL FAILED: Could not mount bootfs

what now? plz help…

Your emmc memory is probably corrupt. Have you tried re-starting with a toothpick in the CVBS socket and kernel.img re-named to recovery.img?

If that doesn’t help, do you have a USB A-A cable? @sam_nazarko can lead you through how to recover with that.

thnxz for reply.

well, i´m been googling about that toothpick.
i used a wood toothpick in the round hole nearest to the HDMI port.
Dont know rly how to do it. Should i toothpick and then plug in the power, and release after 5sec?

would be glad if u explained where i find the kernel.img plz.

Sorry, assumed too much knowledge. When you make the USB stick, you will find three files on it which can be read on any PC. One is called kernel.img and you should rename that to recovery.img.

Poke a stick in that hole and hold it in while you apply power. I think the install screen displays while you hold it in but otherwise give it 10 seconds or so then release.

Actually, @sam_nazarko says this procedure is no longer necessary or supported, but it’s worth a try.


I renamed the file as instructed.
plugged in the black USB-port without the tootpick.
= Black screen with:
Fatal error: could not fins root filesystem device /dev/vero-nand/root

plugged in the black USB-port WITH the tootpick:
install screen:
INSTALL FAILED: Could not mount bootfs

Same with the white usb port.

I´m trying with the image from osmc with date: 2011.11-2.

Now i will try with the oldest:

Same with 2020.06-1

try both, first the the kernel.img with and without toothpick, both usb ports.
renamed kernel.img to recovery.img, with and without toothpick - both ports same result… =(

OK. Can you obtain a USB A-A cable, then?

Have a big box with different cables, but no USB A-A cable.
Seems like i have all other USB cables in the world but not this one. Seems a little unusual =)

I think you opened a support ticket about this a few days ago. Did you follow my suggestions?

No sorry but this is the first time i´m inside this forum. Never been here before this date.

hmm, i have a USB-C port on my pc motherboard. Can i connect the vero with a USB-A to USB-C that way?

Unfortunately that will not work.