Vero 4K+ can't play discs

I’ve just replaced my external DVD drive as the old one failed. The replacement drive is very new, and I am unable to watch DVDs or Blurays with my Vero. The drive is a Verbatim 43890 and works fine on my fedora desktop which is running kernel version 5.13.19.

I suspect the issue may be that the drive is simply too new, and there are no drivers for it in the osmc kernel yet, but wanted to check.

Hitting Play disc when a DVD is loaded does not do anything. However, when inserting a bluray disc a menu pops up asking whether I want to explore Videos, Music, or Photos. I can see all the titles on the disc by selecting Videos, but can not play any of them.

My debug logs are here: https://paste.osmc.tv/opoduqaxet

It seems to mention something about being unable to mount /dev/sr0 as it is already mounted. I did not experience than with the old drive, and it is not a problem on my Fedora system, but is there something perhaps in the Vero config that might be causing this?

Thank you

Are you using it with an external power supply or a powered USB Hub?

I’m using it on a powered hub, the hub has a 4 amp power supply. When trying it on the Fedora desktop I’m plugged straight into the case’s front USB ports without a problem.

Is there any more information I could provide to help diagnose this?

So that issue is with all kinds of Discs? E.g. even with an audio CD?
It might be an automount timining issue

I’ve not actually tried audio CDs, but can give that a shot later. It definitely didn’t work with either BluRays or DVDs. There does seem to be something in the logs about an error mounting.:

Oct 03 10:17:01 hathor udisks-glue[2472]: Failed to automount /dev/sr0: Error mounting: mount: /media/BEETLEJUICE_DISC4_PAL: /dev/sr0 already mounted or mount point busy.

I’ve never experienced this before, so not sure how I would try and fix it?

Thank you!

If it’s a retail Blu-ray, you need to install decryption keys

Hi Sam,

Sorry, should have mentioned that in the initial post. I have already installed encryption keys, and as DVDs are also not working suspect the issue lies elsewhere.

I’ve now tried AudioCDs and they seem to work fine, just had to insert the cd and select Play Disc and it worked. DVDs and Blurays still not playing, however; there’s no on-screen error message, just Play Disc doesn’t respond.

Check what is displayed after you inserted the disk with ls -lah /media/

Thanks for the response. I’ve just tried that with a DVD inserted, but it doesn’t show. I’ve got:

total 44K
drwxr-xr-x  3 root root 4.0K Oct 16 10:04  .
drwxr-xr-x 20 root root 4.0K Aug 13 13:59  ..
drwxrwxrwx 13 osmc osmc  32K Jan  1  1970 'MAGIC BOX'
-rw-r--r--  1 root root  232 Jul  2  2020  README

‘MAGIC BOX’ is an external HDD.

What are the logs saying grab-logs -A did OSMC tired to mount it?

Looks like the same error as before:

Oct 16 10:20:27 hathor udisks-glue[2466]: Device file /dev/sr0 inserted
Oct 16 10:20:27 hathor udisks-glue[2466]: Trying to automount /dev/sr0...
Oct 16 10:20:27 hathor udisks-glue[2466]: Failed to automount /dev/sr0: Error mounting: mount: /media/KIKIS_DELIVERY_SERVICE: /dev/sr0 already mounted or mount point busy.

Full logs here: https://paste.osmc.tv/epanogewil

What happens with
mkdir /media/test
mount /dev/sr0 /media/test

I’ve tried with a DVD, and a BluRay. The DVD will mount manually and then can be played from Kodi. The BluRay will also mount manually, but won’t play from the Kodi Menu. I could browse to the individual m2ts files, however, but playing them failed. Looks like this entry in the logs:

2021-10-16 10:40:01.522 T:3547    ERROR <general>: Open - error probing input format, /media/test/BDMV/STREAM/00000.m2ts
2021-10-16 10:40:01.522 T:3547    ERROR <general>: OpenDemuxStream - Error creating demuxe

Thank you for your help!