Vero 4K corrupt file system, unable to reinstall

My Vero 4K has been working fine since I got it a few months ago, but recently I got an error every day saying “Update Error. Please report this on the forums”. I figured I would try to reboot the Vero 4K before doing anything else, and did so using the Kodi built-in Reboot command. When the device tries to start it now displays this error message:

I figured the storage was corrupt beyond repair. Note that I have never pulled the plug or similar on the device, so I don’t know what would have caused the corruption. Anyway, I then tried to reinstall OSMC. After downloading the OSMC install tool for Windows and using it to write an image to a SD card, I plugged in the SD card and started the Vero 4K again. After the 60 seconds countdown, the installation immediately fails, saying “OSMC install failed: can’t mount root”. I have tried several times, and with two different SD cards, but the issue remains.

Help would be much appreciated.


Are you able to attach a USB keyboard?
When the message about failing to mount root appears, do you get dropped to a command line?


Yes and yes.

Okay, I think that the update may not have installed properly on your system.

When you see the message on boot about ‘Waiting for root filesystem’:

  • Insert SD card with installer
  • Run mount /dev/mmcblk1p1 /mnt
  • Run dd if=/mnt/dtb.img of=/dev/dtb bs=256k conv=sync
  • After 10 seconds, pull the plug, remove SD card. Re-power.

Power up again (without SD card)


dd if=/dev/zero of=/dev/data bs=1M count=1 conv=fsync
dd if=/dev/zero of=/dev/system bs=1M count=1 conv=fsync
dd if=/dev/zero of=/dev/cache bs=1M count=1 conv=fsync
dd if=/dev/zero of=/dev/tee bs=256k count=1 conv=fsync

Now try and re-run the installer.

No luck, the dd command does not seem to be installed.
All I get is “sh: dd: not found”

Might be /bin/busybox dd. Don’t remember if we included it in our initramfs

Do you have access to a Linux machine or know how to use netcat? That would expedite things quickly

I am pretty sure your device tree is out of sync due to a failed update and this is causing a partitioning problem


“/bin/busybox dd” just says applet not found.
I do have a Linux machine available. I haven’t used netcat a lot but I’m sure I can familiarise myself.

I’d like to fix this for you promptly.

I’ll send you a PM, but it would be great if we can do a Skype or TeamViewer session.

In the unlikely event this is a hardware problem, I’ll get you a replacement out promptly, but I’d like to try and get you up and running again first.


1 Like

Hi Sam,

I know this is old but I’m having the same issue as the OP. Switched inputs over to my Vero4K to watch something and saw a message about not being able to upload a tar file to backup, which I’d configured OSMC to do before an update. Rebooted Vero4K and got the following error in this screenshot:


You’ll see in the same screenshot I tried your suggestion to the OP but got thrown a “No such file or directory” on the first command.

My Vero4K is a few years old now - any suggestions?

The image doesn’t seem to have uploaded properly. Can you please repost it?


Do you see the OSMC installer come up when you try and reinstall?

Yes I did and it fails with unable to reinstall error. I used a brand new SD card as well as I bought one forgetting their was now internal storage in the Vero4K

Are you sure this is a vero4k? It’s only been out for about 18 months and has always had the same storage.

Yes I am. I may have overestimated how long I’ve had it. It has worked flawlessly until now.

I think you have lost whatever was on the device so trying to re-install using a toothpick down the AV socket would be worth a try if you haven’t already. See Troubleshooting tips here : Reinstalling OSMC - Vero 4K - OSMC

OK, just so I am clear on this, you’re suggesting I should follow the steps to force the system to boot from the SD card even though I’m using a brand new SD card and the system is recognising that I am trying to reinstall from the SD card as shown here:

As I understand it, the toothpick technique wipes the internal memory so that there can be no confusion about which device (SD card or emmc) the vero is booting off. If you have already tried that then I’m out of ideas.

The picture above shows that the installer is running, so I am unsure why it is unable to reinstall OSMC.

It might be worth us taking a look at the device.


The toothpick method forces a kernel to be loaded unconditionally from mass media. This is sometimes useful if the Vero 4K’s internal boot environment settings are corrupted.