Vero 4K+ crashed

After a week without use, I immediately wanted to enjoy the Vero 4K. I turned on the screen, updated an extension, and waited a few minutes to answer a phone call. Then I saw the Vero stop (on the screen, Linux messages) and nothing more: red cross lit on the front.

Here’s a log :

For your information, I’m looking at the processor temperature which is 111°c without doing anything : it’s a lot, isn’t it? Knowing that the Véro is not on another device: it is alone on a TV cabinet shelf, with nothing in a 20cm radius.

Thank you for your help… it’s starting to be unpleasant.

Can you switch to OSMC Skin for testing to see if the temperature drops?

Sure : I’ve made it. No change I can see.

Vero 4K just crashed again right now with the OSMC Skin.

I switched off/on the Vero (by unplugging power), tried to upload the log, but had no time to do it : Vero crashed again.

Twice in less than 10 minutes : it looks like Vero 4K+ is not happy to be with me ! Perhaps something else in the log than the skin ?

Thank you.

Maybe try without screensaver.

Sure. I’ll try.

Finally, when everything will be switched off, it should be ok. Perhaps could we switch off everything right now, to save time ?

Thank you.

I think that the most sensible approach is now to see how it behaves with a default Kodi configuration.

To restore the configuration to default, enter the following commands with an SSH connection.

systemctl stop mediacenter
mv ~/.kodi ~/kodi.bak
systemctl start mediacenter

If needed you can restore the old configuration:

systemctl stop mediacenter
mv ~/.kodi ~/kodi.bk2
mv ~/kodi.bak ~/.kodi
systemctl start mediacenter

If your original setup was restored as expected and you want get rid of the unneeded clean install you can delete that with the following command.

rm -r ~/kodi.bk2


Hi there.

I installed Vero 4K from blank and add things I Ould like to have, things I had in my previous Kodi system, like a screensaver or a skin, tout it crashes (always red light)

Now, without screensaver except “Dim” and with the Aura skin (not the most greedy it seems to me), the temperature is 73°c. No movie played, nothing, Judy idle, from the last 24 hours. Is 73°c a correct temperature ? I repeat there is nothing under or on the Vero.

Thank you

73C is an acceptable temperature.


Once again, the Vero 4K crashed. Just because I ran a scan to update library.

Could somebody really help me ?

NB : I already sent some logs… do you really want one once again ?

Thank you.

As you’ve reinstalled since then it could help.
That way we can also see if you are on the 4.9 kernel still.

Here you are :

Vero crashed yesterday (20 December) at about 6pm.

Thank you.

Did you check to see if the issue occurs on a fresh installation?
You’ve installed the 4.9 repository, which is still WIP


Did I miss something ?

Thank you.

I would suggest testing on a stock installation first.
You say the device crashed when scanning the library. Did it repeatedly crash, or just crash once?

If it only crashed once, I wouldn’t be particularly concerned. It could be a corrupted file that caused this.


As already said, I don’t want a perfectly working Vero I can’t use to do what I need it to do. If I can’t read 3D MVC file, I don’t need a Vero 4K +. I already forgot the skin I used from several years, forgot the screensaver… finally, if I have a very nice Vero 4K+ I don’t like to use, what for ?

“It could be a corrupted file that caused this” : it looks very strange for me that a corrupted file crashed an hardware system (red light on). An error, something we could see in the log, yes, but nothing except a red light on ? for a corrupted scanned file ?

…I just run a new library scan : the processor temperature is 107°Celsius now. I presume It will probably crashed with a good Red Cross light on.

…can’t we imagine there is an hardware problem on the Vero I received ? The absence of heat sink or something like that ?

Temperature increased to 110, and then the scan finished… probably because half of it was already made yesterday.

We know it’s not a corrupted file.

I’ll try right now to remove and scrap from scratch the tv show library (what I tried yesterday). Perhaps temperature will increase higher ?

Well, temperature increased to 116° and then Vero crashed, right light on.

I have videos if you want (110°, 113°, 115°… I missed the 116° crash). No screensaver, no special things, only a library update.

Now, what can we do please ?

Thank you.

How the /etc/apt/sources.list should looks like to install the Vero as if it was new (without loosing .kodi.bak I made) to test ?

Or, better : how can I do a “stock installation” (…without losing any backup) ?

Then, without nothing (except a media source I hope…), we’ll see if the Vero I have has a problem doing a scan only…

Thank you.

I am asking you to test with 3.14 because this is the stable release. By using an experimental build you are introducing more variables.

Before we would check for a hardware problem, we would surely rule out a software problem first.

If you believe it’s a hardware problem, then you can open a warranty case at, but I don’t think the hardware is faulty from what you have described so far.

Unfortunately you haven’t uploaded debug logs – so it’s hard to look in to the issue further.

I made what you told me to do to be able to work as promised.

I’ll do that, but want one again test your “clean installation”.

it’s done before “stocking installation” : you probably missed my message 6 before yours.

So, I asked you how to do a “stock installation” by telling me what to write in “sources.list” to do the clean installation as you asked me : could you help me ?

Thank you.