Vero 4K+ crashed

For a clean system, you need to reinstall OSMC. See Reinstalling OSMC - Vero 4K - OSMC.

Thank you very much for your help (…I’ll try to backup by myself, thank you).

Take a backup, but to ensure a clean system I wouldn’t try and restore it immediately on the new install so we can actually test on a fresh installation.

Sure. I’ll do that this evening and come back with tests results.

Thank you.


Tried this morning, but 404 on page Reinstalling OSMC - Vero 4K - OSMC.

Thank you,

Well basically it says download the installer for your OS (Windows or Mac) and then install the image on a SD Card or USB.

Boot the Vero with the USB Stick or SD Card.

Hello fzinken,

thank for your help.

Unfortunately, a new problem : OSMC installer error. Here the end of the log :
jeu. déc. 24 06:50:43 2020 Imaging failed!
jeu. déc. 24 06:50:43 2020 Messages are:
jeu. déc. 24 06:50:43 2020 stdout:
jeu. déc. 24 06:50:43 2020 stderr: 0:135: execution error: dd: /dev/rdisk4: Operation not permitted (1)

It looks like it’s a known problem : OSMC installer fails on macOS Catalina 10.15.3 - #5 by paul34949 that should have been solved but no. I’ll try using DD or another installer…


It looks like it was ok (using balenaEtcher with sudo command and image in the app content) : “Flash complete!” with “1 Successful device”.

Tried to switch off the Vero, put the microSD, switch on, and… “old” OSMC started. No fresh installation.

It could have been fun.

Can you show the content of the SD Card?
Also have you put it in the right way (Pins up) and did it click.

-rwxrwxrwx 1 raphael staff 24205 19 oct 19:05 bcm2708-rpi-b-plus.dtb
-rwxrwxrwx 1 raphael staff 23946 19 oct 19:05 bcm2708-rpi-b.dtb
-rwxrwxrwx 1 raphael staff 23723 19 oct 19:05 bcm2708-rpi-cm.dtb
-rwxrwxrwx 1 raphael staff 24407 19 oct 19:05 bcm2708-rpi-zero-w.dtb
-rwxrwxrwx 1 raphael staff 23671 19 oct 19:05 bcm2708-rpi-zero.dtb
-rwxrwxrwx 1 raphael staff 25293 19 oct 19:05 bcm2709-rpi-2-b.dtb
-rwxrwxrwx 1 raphael staff 27082 19 oct 19:05 bcm2710-rpi-3-b-plus.dtb
-rwxrwxrwx 1 raphael staff 26463 19 oct 19:05 bcm2710-rpi-3-b.dtb
-rwxrwxrwx 1 raphael staff 25261 19 oct 19:05 bcm2710-rpi-cm3.dtb
-rwxrwxrwx 1 raphael staff 40264 19 oct 19:05 bcm2711-rpi-4-b.dtb
-rwxrwxrwx 1 raphael staff 18703 19 oct 19:05 bcm2835-rpi-a-plus.dtb
-rwxrwxrwx 1 raphael staff 18587 19 oct 19:05 bcm2835-rpi-a.dtb
-rwxrwxrwx 1 raphael staff 18990 19 oct 19:05 bcm2835-rpi-b-plus.dtb
-rwxrwxrwx 1 raphael staff 18866 19 oct 19:05 bcm2835-rpi-b-rev2.dtb
-rwxrwxrwx 1 raphael staff 18733 19 oct 19:05 bcm2835-rpi-b.dtb
-rwxrwxrwx 1 raphael staff 18698 19 oct 19:05 bcm2835-rpi-cm1-io1.dtb
-rwxrwxrwx 1 raphael staff 19129 19 oct 19:05 bcm2835-rpi-zero-w.dtb
-rwxrwxrwx 1 raphael staff 18655 19 oct 19:05 bcm2835-rpi-zero.dtb
-rwxrwxrwx 1 raphael staff 19566 19 oct 19:05 bcm2836-rpi-2-b.dtb
-rwxrwxrwx 1 raphael staff 20983 19 oct 19:05 bcm2837-rpi-3-b-plus.dtb
-rwxrwxrwx 1 raphael staff 20194 19 oct 19:05 bcm2837-rpi-3-b.dtb
-rwxrwxrwx 1 raphael staff 31699 19 oct 19:05 bcm2838-rpi-4-b.dtb
-rwxrwxrwx 1 raphael staff 52296 19 oct 19:01 bootcode.bin
-rwxrwxrwx 1 raphael staff 146 19 oct 19:01 cmdline.txt
-rwxrwxrwx 1 raphael staff 51 19 oct 19:01 config.txt
-rwxrwxrwx 1 raphael staff 220872908 19 oct 18:30 filesystem.tar.xz
-rwxrwxrwx 1 raphael staff 3033 19 oct 19:01 fixup4cd.dat
-rwxrwxrwx 1 raphael staff 2643 19 oct 19:01 fixup_cd.dat
-rwxrwxrwx 1 raphael staff 18391680 19 oct 19:06 kernel.img
drwxrwxrwx 1 raphael staff 16384 19 oct 19:06 overlays
-rwxrwxrwx 1 raphael staff 763104 19 oct 19:01 start4cd.elf
-rwxrwxrwx 1 raphael staff 685508 19 oct 19:01 start_cd.elf

…yes… and the card is seen by the Vero :

  • I can see it thru Storage menu (/dev/mmcblk1p1 size 316M Used 232M…)
  • If I remove it while Vero is on, I’ve got a message saying the storage has been removed.

Looks like you burned a RPI instead of a Vero4k Image.

I think I’ve chosen "VERO 4K / 4K+ with your software, but… I probably made a mistake (I can’t rewind…).

…anyway, I’ll download by myself and try again.

Thank you for your help.


First, I wish you a merry Christmas.

Then, I cleared the Vero. Updated to the last version (…with which I’ll not be available to see MVC 3D movies). Now, I’m at the start point : not having set up my media sources, for example.

At this point, the Vero already seems too hot for me : letting it on the “App Store” screen (without doing anything) in MyOSMC menu raises the temperature to at least 95°c.

Is it normal ?

Thank you.

…well, trying to add sources (using Mounting network shares with autofs (alternative to fstab)), the Vero 4K crashed (the nice red lighting cross !). I saw “over temperature” or something like that while I run “sudo apt-get install autofs” command.

…I think, now, we should consider there is an HARDWARE problem on this Vero 4K which is :

  • With a fresh install
  • up to date
  • with 5% of the setup I had to do.

Another log (now, you’ll have everything you want I think !) :

Thank you.

That temperature seems high if the system is idling using the OSMC skin.
Can you show a photo of how the device is situated in your room?



Well… I hope you will not ask me to change my home orientation, the location where I live, the temperature in my house or the way I dress myself.

First photo will show you the place where should be the Vero. Nothing just beside, the computer that is under the shelf is always off (used for archives). On the same shelf, there is a Raspberry PI4 on the right (blue case). Just to repeat that I always had some players here : neotv5500, rasp pi 3, 3B+… without any temperature problem. You have to know the back panel of the furniture is not present to allow heat to escape.

Second photo will show you the Vero on the top of the furniture : to anticipate a 394th request, I took the Vero off the shelf and redid the test. Same result.

I opened a ticket, I gave you my order number.

I have to tell you I bought the Vero AFTER asking if it will possible to see 3D MVC, x265, 4K. I was a bit disappointed when I saw I have to use a test dev to allow me to see 3D MVC movies.

Thank you in advance for your concrete help to come.

The device’s power supply is connected directly to a socket, not any extension?

What is the other USB device that is attached? When the device overheats, are the USB peripherals overheating as well (warm to the touch)?



Rii mini i8+ keyboard dongle. Once is your remote control, the other one this Rii keyboard. Nothing else.

If you’re talking about the peripherals, of course not… If you’re taking about dongle, probably a bit warm, as everything connected because the Vero has gone to 116°c.

@sam_nazarko, could you please answer to my last message in the ticket opened ?

Thank you.

I’m catching up on emails – should be completed tonight.