Vero 4K Crashes playing UHD MKV rip of Maze Runner Death Cure

My Vero 4K (with either March or April, 2018 firmware) crashes every time I try to play back a UHD rip of Maze Runner Death Cure. The crash comes near then end of the playback of the 20th Century Fox Logo about 7 seconds into playback. I have used both makeMKV and AnyDVD HD to rip/decode my UHD disk to my MacPro hard disk drives. I have then used either MakeMKV or MKVToolnix (v 22.0.0) to package to UHD movie in an MKV container. No matter what I do the Vero 4K consistently crashes 7 seconds into playback. Trying to fast forward beyond the beginning still crashes the Vero 4K, but chapter skipping does work to get beyond the 7 second playback barrier. Once past the “crash point” the UHD move plays fine. The same MKV file streams (and the original UHD Disc for that matter) plays back on my Oppo UDP-203 player without stuttering or crashing. I have even had Amazon send me a new disc in exchange, but the problem still exists.

Why is the player crashing? What do you need from me to help figure this out?

To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

So, in summary:

  • activate the logging
  • reboot the OSMC device
  • reproduce the issue
  • upload the log set either using the Log Uploader method within the My OSMC menu in the GUI or the ssh method invoking command grab-logs -A
  • publish the provided URL from the log set upload, here

Thanks for your understanding. We hope that we can help you get up and running again shortly.

The uploaded debugging log URL is https://paste.osmc.tv/ixudevepol.

Hi I have the same issue with with this movie as Ppoulos.
Media info: http://paste.osmc.io/oboxesocel.mel
Log: http://paste.osmc.io/ohijojexox.hs
I play it back from an USB drive
The default audio is the TruHD, if i quickly change the audio to other and wait a bit and then change it back to TruHD then it play the movie (at least for 3-4 minutes)
IF i just start the movie it crashed Vero right where Ppoulos mentioned. I get the sad face and then Vero reboots. I tried it only with the April update.

Can you produce a small sample that causes this crash and upload it here? Can you confirm how you ripped the file?

Otherwise, try remuxing the file to see if it still causes problems for you.

Cheers,

Sam

I have just uploaded an ~295 MB MKV file that contains the first one minute of the main movie stream minus all of the extraneous audio tracks and subtitles. I used TSMuxer to pullout the first minute, and MKVToolNix to repackage the video in an MKV container. I then tested it again with my Vero 4K and it still crashed after ~7 seconds into playback.

I hope this helps.

Thanks, that’s exactly what we need to reproduce and investigate.
I’ll keep you posted, but it may be a week or so before we get back to you

Sam

Looks to be the exact same problem as Guardians of the Galaxy 2 and POC Dead Men Tell No Tales.

See here:

All three titles have Atmos tracks with a bitrate above 10 Mb/s.

They play fine with the other audio tracks. My Nvidia Shield exhibits the exact same problem. My new Dune Pro copes with it fine (but has a bunch of other problems lol).

I have the exact same problem with Maze Runner Death Cure.

I also have this problem with Maze Runner
Best regards

Hi @sam_nazarko ,

I can confirm the issue is present at point +7 seconds resulting in a bad face.
Skipping immediately after start by +10 seconds keeps the movie and sound running smoothly until end.
Audio stream during playback: Dolby True HD

cheers
Boris

It works fine for me as well to skip the first 10 seconds, seems to be something iffy with the encoding here - but it works on other devices.

Thanks for the feedback. I’ll need a bit of time to look in to this and see what can be done

Sam

One more thing: I started watching the movie (jumping through the buggy first 7 seconds) and sadly I had to realize that banding is still there :frowning:

The banding will be fixed if you’ve followed the instructions in the other thread.
It’s been confirmed fixed by several users.

I thought installing the new update solves it automatically.

You can either change rc.local or enable HDR autoswitching, the later may not always work, but there are improvements we are working on. If you use the former / hotfix approach, it will work every time.

This has been discussed in significant detail in the HDR thread. Please read it in detail.

I tried to enable the hdr auto switch but I get a strange result, audio is on I hear it, but no picture at all, tv even says : no signal. Could you please point me to step by step description of the fix (I’m not that technical) thx in advance

See [TESTING] 4K HDR playback with banding & flickering fixes - #226 by sam_nazarko

i apply this hotfix and now i complete lose picture on the vero 4k no signal to my tv sony 940e, and i also have the same problem with the maze movie, audio skip and vero crash with blue screen sad face on it

what can i do to get the picture back reinstall osmc is my only choice?

thanks