Vero 4k crashing scrolling through movies

Did the latest November update (after applying the hotfix) and after it was completed, scrolling through the movie list inevitably crashes the box to sad face.
Rebooting doesn’t resolve.
Turning debug mode on shows the CPU usage to be fairly pinned.
I uploaded logs via the Vero.

Running Aeon MQ8 skin (as I was previously) and not many other add-ons. Even uninstalled some.

Thoughts or suggestions?

I’m experiencing same issue (Vero 4K+ with November 2021-2 update).

Please provide logs and also indicate if you are using a Skin other than the OSMC skin.

I’m using Cosmic skin (Cosmic).
I’ll upload log file once back home.

Please also check if you can reproduce the issue with OSMC skin.

Ok. I’ll do that

I tried multiple time to reproduce the issue but no way.
I’ll try to upload the log once this is coming back

I am able to reproduce this each time i recover from the sad face or even full restart of the Vero. Logs were attached in original post

Can you reproduce it with OSMC skin?

Just switched to it for about half hour and no was not able to reproduce.

Than maybe better to open topic on the Skin Forum

Is rolling the Vero back to 18 an option? If so please point me to directions and I’ll try that. Practically unuseable now.

There is no downgrade path. If you wanted to go back to Kodi v18 you would have to grab an older image from the “download” link at the top of this forum and install it from scratch. You can backup some of your settings (sources.xml, passwords.xml, etc) but you would have to setup your Kodi system settings and your library from scratch unless you have a backup kicking around from before you updated to v19.

I’ve had the same error since the new Kodi version (18?) in August. Updated to the latest November patch. Did a clean reinstall and am using the OSMC skin. Moving through about 5 movies triggers the sad face for about a 3 seconds then returns to the main menu. Can also happen moving through the main menu, but this happens less often.

Thanks, this means it’s not the specific skin. I’ll switch back to another skin for a bit and assume I’ll see the crash again as toown did.

I would caution assuming your issue is the same as these two other people when nobody currently knows why any of you are crashing. In your case I would try disconnecting your hard drives and see if you still crash just navigating around the library. There has been the odd occasion where Kodi runs across a file it has issues with crashes. Disconnecting the drives will at least tell us that it isn’t tripping up trying to pull artwork into the cache.

If that doesn’t get you anywhere you might also try deleting texturecache13.db and the thumbnails folder in case there is corruption in your thumbnail cache. Kodi should rebuild all on its own as you navigate around.

The last thing I can think to have you try is to just start with a fresh userdata folder…

Let’s test with Kodi default settings. Enter the following commands with an SSH connection.

systemctl stop mediacenter
mv ~/.kodi ~/kodi.bak
systemctl start mediacenter

If needed you can restore:

systemctl stop mediacenter
mv ~/.kodi ~/kodi.bk2
mv ~/kodi.bak ~/.kodi
systemctl start mediacenter

If your original setup was restored as expected and you want get rid of the unneeded clean install you can delete that with the following command.

rm -r ~/kodi.bk2

Thanks for that, it gives me something to try at least.
My days of tinkering and deep dives into getting stuff to work are in the past so, hoping there’s an easy fix to this.
I have 2 ext hdd bays (Mediasonic) and 2 external Seagate drives, and all are connected to a USB3 powered hub, so no power draw on the Vero, but before I do any of the troubleshooting above it does appear that the covers have a lag when scrolling down through the list. It takes them time to show up.
So might be related, maybe the AeonMQ8 skin is too heavy in 19 vs 18 on the Vero, dunno.
I know the other offshoot of Aeon, the Madnox skin was a BEAST on resources so I never even considered putting that on the vero.

I wasn’t thinking you had a power draw issue. I figured with ten drives directly connected you probably were aware of how to properly power them.

I disconnected the power to the hub, rebooted and scrolled though Movies and the issue doesn’t occur.
I switched to another skin, Amber and 1 other, issue nor there either.
Interestingly after powering the hub back on and letting the drives get recognized, scrolling through the Movies section seems fine /better. You can still see blank cases for a couple seconds while they load, but for this first test, that’s not crashing the Vero.
When watching 4k movies I do often have to reboot the Vero so maybe I’ll try again tonight and see if the issue happens again.

I wouldn’t get too bothered by some art being a bit slow to show up. This is frequently just a byproduct of the artwork caching and minimizes over time. With your last post it makes me wonder if one of your drives is going to sleep and being slow to wakeup, or maybe a drive pausing to for internal drive maintenance long enough to be causing a problem. It might not be a terrible idea to run the drives through a full drive scan using whatever tools are provided from the manufacture.

Do note that this drive pausing I’m talking about is not necessarily from a drive going bad or something that would show up with a regular kind of check disk. Modern drives have their data stored so dense that they don’t expect everything to always come back perfect. As such the drive monitors the data when it reads it to check if an area of the disk is getting weak or other issue and it will then move data all on its own to a new section of the drive. You also have some drives now (SMR) that have to do maintenance similar to SSD’s where it has to shuffle data.