Vero 4k Device crashing

Hi all,
For some reason my vero 4k is now crashing at all times when entering anything in the menu.
As a matter of course I have completely reset to device to stock from USB and loaded into the default osmc and it’s still happening.

Switch the device on
Menu loads
Click on videos
The device shows a command prompt window and them the screen goes and stays blank
I then have to switch off the device and then try again.

I can’t wait or use anything, it just crashes from every option on the main menu.

Any thoughts?


If you are able, I’d suggest reinstalling OSMC if you’re not too worried about preserving your data.

Hi, I have already, worryingly reset it as you have suggested and it seems even just after the setup and choosing language/region it does the same thing.

What’s connected to the device?

When did this start happening?


Hi Sam,
The device was connected to my surround sound amplifier but since resetting it I’ve also tried connecting it to the HDMI directly in the back of the TV too.

For some reason it just seems to be a bit dead now which is really a shame. Whatever I do after doing a full reset it crashes to the black screen. Nothing else has changed since so it’s not like I can rule anything out

I’d be surprised if your hardware is problematic. Depending on the age of your device, you might need a new PSU.

My suggestions are to try power the device via USB and see if this helps.

Hi Sam, where can I order a spare UK power cable from? I’d like to get a spare ordered and test this!

You can grab them here;


Thanks Sam.
So, I also ordered a new vero 4k which arrived today. I’ve just tried to boot up the new vero using the supplied ac cable and hdmi cable and it won’t boot up for me. The red light is showing and nothing is happening. Just to check I plugged my old vero4k (the one we’ve been talking about) in using the new ac cable and hdmi cable and it boots up fine and seems to work fine. Is it possible the new vero4k box I received today is faulty at all? I’ve also tried booting it whilst connecting to standard hdmi port on the back of the TV as well as the receiver. Really weird!!

Hi Sam, I’ve just swapped the devices around again. So the new vero4k (delivered today) was getting very warm with its new power cable and now I’m not getting a red light either, it’s just not powering up at all

Every device is tested before dispatch and is then flashed. So the hardware would’ve been tested thoroughly. The power supplies aren’t practical to test each individually, so the issue could be there.

Let me know your order number and confirm your address is the same and I’ll get you a new PSU out.

I recommend not using the PSU causing the device to get warm for now.


I can see you ordered a new PSU.

I’ll dispatch this for you tomorrow.
Hopefully it solves your problem. I can then refund the order for you obviously.


Hi Sam,
Just an update for you.
I’ve finally got some time aside to set up a little test station for my new vero and the old one.
The new one works with all three power cables:

  • The old cable for the old vero
  • The new power cable which came with the new vero
  • The new power cable I ordered recently separately.

It seems that all three cables are working correctly or functional.

I’ve then tried all three power cables on my old vero and unfortunately it just will not boot up. I’ve used exactly the same conditions as the new vero to ensure it’s a consistent setup and nothing, no red light, just dead. I don’t know if you’ve ever had this with one of the veros before? I know hardware isn’t supposed to last forever but the original vero is about 3 years old and I would have hoped a bit of a longer life?

Let me know your thoughts on this one or potentially if you’ve got another suggestion in mind? I’m not at the point yet of opening up the device and obviously don’t want to void any warranty of any sort.

Take care!

So the old Vero went from Kodi crashing to not booting at all? Do you have anything other than the remote dongle plugged into the USB ports? If so try it without the extra devices. Otherwise if you can get your hands on a USB A-A cable you could try powering it from the USB instead of the barrel jack and see if that works.

Do you see a red light at the back of the device coming out of the optical port?


Exactly that, it has gone from one to the other, which is strange.

I’ve ordered a USB a-a cable as well to try, and also I’ll check what Sam suggested for the light on the optical port with the usual power cable.
For usb what output voltage does it need?

It should only be supplied with 5v regardless of which way you power it. If you power it via USB do not plug a power supply into the barrel jack at the same time. Also note that if this works the Vero will not have available as much current capacity as it would otherwise as the USB port is not designed to handle that. Thus it is fine by itself and for very lower power devices such as the remote dongle or a keyboard, but anything more likely would require a powered USB hub for proper function. As for what to plug the USB A-A cable into you should avoid using most cellular phone chargers as they frequently do not supply stable voltage under load. The Apple brand chargers that come with iPhones are fine, plugging into a computer to test is fine, otherwise using something that is suitable for use with a Raspberry Pi or similar SBC would be ideal.

Hi chaps, quick update for you.
The usb a-a cable arrived this morning from Amazon. I plugged in via both a usb powered and an apple charger. The optical port lights up but still no red light and no booting up. I’ve also tried both usb ports on the device (using the right one first).

Hi, just wondered if there were any further suggestions on what I could do to maybe bring some life back in to this little guy? It’s looking a bit sad and lonely on my desk at the moment and needs to boot up :slight_smile:

Sorry - was travelling.

Try the USB in the white port and connect to a PC and see if it’s detected