Vero 4k does not power up after October update

After launching October update my Vero 4k does not power up. I see shortly (~half second) the front cross lightning in red and nothing else.
I have tried with or without SD card, with a USB key instead. I have also tried with the power supply of my Vero 4K+ (yes, I have also a Vero 4k+).
Any idea ?

If the October update caused the problem, and substituting the power supply makes no difference, then it’s probably not hardware related. I think the next step has to be a reinstall of OSMC: Reinstalling OSMC - Vero 4K - OSMC

I’m also facing the same problem, boot loop since the October update.

Boot loop would be a different issue. Can you still access the device via SSH?

No acces via SSH, It is simply not booting. I have already tried to reinstall as described here: Reinstalling OSMC - Vero 4K - OSMC

I have already tried to reinstall with SD and USB.

So what happened?

Please show a screenshot of the contents of the SD card


Have you tried the toothpick instructions and renaming the file?

Yes. I did it again right now.

Make sure the HDMI cable is plugged in fully (this can be a problem sometimes),

Is the device warm to the touch?
Can you try an older image?


No, there was no access possible. I went and reinstalled via an image I put onto an USB stick via etcher.

HDMI is well plugged in.
Device is not warm.
I have unsuccessfully tried right now with OSMC_TGT_vero3_20181014.img.
There is still the same reaction: red light for half a second than nothing.

Please submit a ticket to so we can look in to this in more detail.



A post was split to a new topic: Kodi.bin repeated segmentation fault

Did you restore a Kodi backup?
Try moving ~/.kodi away. It could be a bad add-on or settings causing this issue.

Hi @sam_nazarko, I seem to have developed the same fault as @olivierauge.

So I’ve had my 4k+ since they were released and have been pretty happy with it. Over the last month or so, it has started hanging and crashing quite regularly and gotten worse over time. In the last week it has got itself stuck into boot loops - booting into Kodi, displaying a sad face, rebooting and repeating that. Eventually it settles down.

Tonight, it froze so I did the usual when it freezes and power cycled it, only for it to get stuck in its boot loop again. Except this time it just kept rebooting. I figured I probably needed to reinstall OSMC, so I prepared a USB drive using the OSMC installer, plugged that into the Vero 4k, powered it on and got “Please Stand By” for maybe half a second before output stopped and the red light went off. This is the state I’m in now.

I unplugged the USB stick but I just get 2-3s of red light with “please Stand by” then it abruptly stops. I tried with a MicroSD card to no change. I renamed kernel.img to recovery.img and did the pinhole reset, but again the same behaviour. Once I managed to get it to stay on with “please stand by” and the red light, but it seemed utterly frozen like this and didn’t move for half an hour. I pulled the power, plugged it back in and just got the same behaviour as before - red light for a few seconds, then nothing.

Can you advise on what to do next?

Hi, sorry to tell you that but even with the intensive support, I just give up. So, I have one dead unit. Hope you find a better ending. I will be looking forward to reading your progress.