Vero 4k+ doesn't boot anymore

Hi everybody,

My Vero 4k+ (4 months old) doesn’t boot anymore.
It worked fine last week but when I tried to watch a movie 4 days ago I just got a blank screen.
Unplugging the PSU didn’t help.

I don’t see any light when plugging the PSU.
I’ve tried another PSU (new), using another screen, reinstalling using an SD card and the toothpick trick, all without success.

Is there something else I can try?
Thanks for your help

What is the other PSU that you tried? Please be careful when trying another power supply as using one with the incorrect specifications could damage your device.

Do you see a red light briefly when your device is booting? This should only illuminate for 1-2 seconds.

You could try powering the device with a USB cable as a test


Hi Sam,

I’ve purchased a new PSU according to the exact specs I’ve found in the forum (5V, 2A center positive, 5.5mm OD; 2.1mm ID), tested 5.04V.

I’ve watched carefully for the red light but I’ve seen nothing in a dozen tries.

Will try the USB cable test as soon as I lay my hands on a suitable cable.

Well I couldn’t find a proper cable.

I did a test with a powered USB hub though, using the micro USB port on the hub to connect to the Vero, and still no sign of life.

Don’t know how meaningful the test is as the micro USB port is likely not powered as it’s used to connect the hub to the PC…

It would need to be powered. But it’s probably best to swap this over. You can open a support ticket.

Support ticket opened.
Thanks for your help Sam