Vero 4K + not booting (quick red flash only)

I bought a Vero 4K + about ten months ago, and I was very happy with it.
Since yesterday, it doesn’t boot anymore. When I unplug and plug the AC adapter, I sometimes have a quick red flash on the cross (at best), then nothing (no image, no network, no access).

I’ve tried several outlets and plugging it directly to the wall with no changes.
I’ve also tried reinstalling it (with two USB sticks and one microSD card, and also by following the “Troubleshooting tips”), but the TV stays black and nothing happens.

I’ve read several topics with similar issues (this one, or that one, and another one),

  • I don’t have a USB-A to USB-A cable to test it…
  • I have found a 5V-3A power supply, is it safe to test it?

Any suggestions?

The red light should disappear after 1-2 seconds to indicate a successful boot.

Have you changed TV recently?

The 3A power supply should be OK to test with, provided it meets its specifications.


Thank you for your reply!

The light doesn’t stay at all, it’s just a quick blink when I unplug and plug the power supply.

No, it’s the same setup since I installed the Vero 4K +.

I’ve tried it, it doesn’t do anything, the red light doesn’t even blink. Strictly nothing.

I left it plugged again this afternoon and I’ve just noticed it was slightly hot – nothing wrong, just that it was not dead.
I hooked it up to the TV and everything seems to work. I’m doing a new backup now (in case…), then I’ll try to reboot it.
I don’t really understand what’s happening.


  • Reboot via menu, OK with about 2 seconds full red light when rebooting.
  • If I turn it off via menu, the red light stay full until I plug it off (I can’t power it on unless I unplug and plug the power supply again – I think it’s the normal behaviour, isn’t it?)
  • If I plug it back on, no red light (sometimes just that quick flash), but for now it’s booting well again…

During 3 days I swear it didn’t boot up (with same setup, same cables, same TV).

I don’t remember if I’m supposed to see a blue light sometimes (I don’t think I’ve seen one since a long time, I thought it was due to an update).
I don’t know if the faulty red light at boot when unplugged means something.

If you are selecting Shut Down and not Suspend, yes.

Yes, that’s what I did. Thanks!

I usually shut it down after using it, then unplug everything (because I don’t use it everyday). Maybe it’s bad for the Vero 4K +?

For now, it’s working again, but when I plug it, there is no red light (except sometimes just that quick flash, but certainly not the normal 1-2 seconds light indicating a successful boot – I have that only when I reboot the Vero from the menu).

Shut Down, then unplugging is the safe way to remove power.

There is a small bug in the latest bootloader which is causing that. I plan to fix this, but it’s low on the list of priorities.

Thank you for your replies!

I’m glad that the faulty red light is not a hardware issue.

Why it didn’t boot at all is still a mystery for me, but I’ll keep an eye.

I still love the Vero and OSMC, thanks again. :slight_smile: