Vero 4K+ won’t boot

Hey folks,

Came to use my vero 4K+ today and found it wasn’t running (I leave it on 24/7 to keep the library updated)

Tried to do a hard reset and the red light flashes for an instant and then nothing. Tried different port on tv as well as different hdmi cable but still can’t get anything. The light does flash for an instant on power on so I think PSU is giving power? Any other suggestions?


You could try reinstalling OSMC
Also check the obvious like cables, TV input etc

I’ve tried different cable and different port on tv (known working port) and still nothing. Is it supposed to just flash up quickly with a red light on start up or should there be a light on for longer?

Whats the best way to reinstall OSMC if I can’t get it to post? Install image on sd and run it on the device?

-edit- ok just tried a sd card with OSMC on it and again nothing, just the instant flash of red led then nothing. Is it dead? A little disappointed as its literally 1 month past a year old :sob:

The red light should appear for 1-2 seconds to indicate the bootloader is running, then go off.

Do you have a USB cable or another 5V 2A power supply you can power the device with?

Can you show a screenshot of the SD contents so we can verify you have imaged the card correctly?

Ok wasn’t aware it could be powered by USB. Plugged a 2A usb into it and it boots no problem.

Is it ok to assume then it is a PSU issue after all? or could it still be a Vero issue?

It’s a PSU issue then. You can contact for a replacement

Make sure you plug your PSU in directly to the wall and don’t use wallgang sockets or an extension chord

Many thanks for the speedy replies and the help. I’ll email now to get a replacement.

Unfortunately I only have 2 sockets available near my tv and so need to plug multiple devices into each. Does it cause that much of an issue not being plugged directly to the wall? I have tried plugging it directly in to the wall and it still won’t power up.

If the power supply is broken now, it won’t help much

We will send a new one on Monday


Hi Sam,

I have had a very similar issue just now with my unit (bought in June 19). Switching to a 5V/2A USB power supply does the trick so I guess I can assume that the provided power supply has given up?

Is this a common issue? I guess the warranty is officially already over, right?



It’s not a common issue, but if anything is going to fail it is more likely to be an issue with the power supply than the device.

You can contact with order details