Vero 4k freezing randomly but frequent

Hi,

as much as I love the Vero 4k, since two days it has become absolutely unusable for me. Out of nothing it started to randomly freeze completely, being non reactive at all and not accessible via ssh either. Freezes are especially occuring during playback - no matter if watching LiveTV (tvheadend on separate server) or any other source, but also when idling (though not as frequent). They also seem to become more frequent, already occuring a few minutes after starting playback (could watch at least half an hour yesterday).
There are no peripherals connected, besides LAN, receiver for official remote and AVR via HDMI. As I already suspected the power supply to be faulty, I even tried to power it via USB port with same results, though I don’t know if supply was sufficient (connect to TV integrated USB port via USB3 A-A cable).

Really don’t know what else I could try. Any help is highly appreciated.

Logs:
https://paste.osmc.tv/rapadiliyu

Best regards,
Hans

The USB port on your TV is very unlikely to be able to power the Vero properly. I would suggest to try a better power supply for testing. I would also try the official power adapter in a different A/C socket. If you are plugged into a power strip and can’t reach a wall outlet, then try a different power strip.

I looked through your logs and I was not spotting anything in your configuration that would be causing these issues.

Have you tried reinstalling OSMC?
Why do you suspect that the power supply is faulty?

Hi Sam,
thanks for your fast response.

Just to be clear: you mean by deleting/moving /home/osmc/.kodi directory? Just tried that, installed nothing but TVHeadend Client and started playback --> freeze after a few minutes.

Just a guess, since I thought having read about this possibility in another thread concerning freezes on a Vero 4k.

Could I use a common smartphone charger instead? Already tried a different socket without any difference.

If you have one that is good enough, and your not powering other USB devices at the same time, then this might be suitable for testing purposes. The problem with phone/tablet chargers is that they are often not designed to provide a full five volts after you start drawing any significant amount of current. You don’t need this for charging batteries, so they often don’t spend the extra money to do so. This can complicate matters as often you can power devices up but they will be glitchy or crash as the voltage is not stable enough under load. Basically you can try it for testing, and it the crashes go away it points to a PSU issue, but if the problem remains it does not actually tell you anything.

Tried with reinstalling the entire OS from disk image. After a couple of minutes of watching LiveTV I was getting optimistic that the problem was solved, but a few minutes later the system was dead again :disappointed_relieved:. I’m totally out of ideas now.

The log in post #1 shows that you had a significant number of packages installed (I counted around 856) and that you had used the --no-install-recommends option on a number of occasions. Using this option has at least the possibility of introducing instability.

Do you mean an image file downloaded from the OSMC site or was it from something like a dd image?

The next step should be to see if a fresh “vanilla” installation, without all the extra bells and whistles, is stable . That should help to eliminate (or confirm) a hardware problem. Then add just LiveTV and see what happens.

IIRC, —no-install-recommends is an OSMC default. At least it should be.

I see that you’ve added /etc/apt/apt.conf.d/o0-osmc-no-recommends-or-suggests to the build. I can understand why you’re excluding Suggests, but am less clear about Recommends.

From the Debian Policy Manual:

Recommends

This declares a strong, but not absolute, dependency.

The Recommends field should list packages that would be found together with this one in all but unusual installations.

So is OSMC an “unusual installation”? :wink:

Downloaded a recovery image from the Download page, used dd to write it to an USB stick, plugged it into the Vero and followed the instructions.
Tried a second “vanilla” reinstallation, started it yesterday night and went to bed after booted from the USB. When I checked in the morning, the installation was finished, but the system was stuck on the language selection screen and unresponsive again.
Seems to really be a hardware issue :worried:

Did you try a new power supply as suggested?

Sam

Tried via tablet USB charger (original Lenovo) since I have no other suiteable power supply available. On a fresh install (no additional addons installed/activated), booted and left it over night --> stuck again in the morning.

Please upload logs (from a fresh system)

Whatever you need. Here are complete logs after a fresh boot:

https://paste.osmc.tv/jahopecoco

Nothing looks problematic in the logs.

When the system freezes:

  • Is the device hot to the touch?
  • Does the device show a red light?

You mentioned it doesn’t respond to SSH. Does it respond to ping?

Sam

  • It doesn’t respond to ping either
  • It is a little warm, but at an absolutely normal level in my opinion. By all means far from hot.
  • Have not noticed a red light, but I just observed that the blue light is flickering when the system is freezed (but seems not related to any input).

Thanks for your help so far.

Do you have another 5v, 2A power supply?

Finally found a proper power supply in the basement. But it did not bring any approvement --> issue persists.

Maybe check the temperature development over time to see if it peaks at one point.
There was recently some one also having overheating issue.