Vero 4k freezing randomly but frequent

Tried with reinstalling the entire OS from disk image. After a couple of minutes of watching LiveTV I was getting optimistic that the problem was solved, but a few minutes later the system was dead again :disappointed_relieved:. I’m totally out of ideas now.

The log in post #1 shows that you had a significant number of packages installed (I counted around 856) and that you had used the --no-install-recommends option on a number of occasions. Using this option has at least the possibility of introducing instability.

Do you mean an image file downloaded from the OSMC site or was it from something like a dd image?

The next step should be to see if a fresh “vanilla” installation, without all the extra bells and whistles, is stable . That should help to eliminate (or confirm) a hardware problem. Then add just LiveTV and see what happens.

IIRC, —no-install-recommends is an OSMC default. At least it should be.

I see that you’ve added /etc/apt/apt.conf.d/o0-osmc-no-recommends-or-suggests to the build. I can understand why you’re excluding Suggests, but am less clear about Recommends.

From the Debian Policy Manual:

Recommends

This declares a strong, but not absolute, dependency.

The Recommends field should list packages that would be found together with this one in all but unusual installations.

So is OSMC an “unusual installation”? :wink:

Downloaded a recovery image from the Download page, used dd to write it to an USB stick, plugged it into the Vero and followed the instructions.
Tried a second “vanilla” reinstallation, started it yesterday night and went to bed after booted from the USB. When I checked in the morning, the installation was finished, but the system was stuck on the language selection screen and unresponsive again.
Seems to really be a hardware issue :worried:

Did you try a new power supply as suggested?

Sam

Tried via tablet USB charger (original Lenovo) since I have no other suiteable power supply available. On a fresh install (no additional addons installed/activated), booted and left it over night --> stuck again in the morning.

Please upload logs (from a fresh system)

Whatever you need. Here are complete logs after a fresh boot:

https://paste.osmc.tv/jahopecoco

Nothing looks problematic in the logs.

When the system freezes:

  • Is the device hot to the touch?
  • Does the device show a red light?

You mentioned it doesn’t respond to SSH. Does it respond to ping?

Sam

  • It doesn’t respond to ping either
  • It is a little warm, but at an absolutely normal level in my opinion. By all means far from hot.
  • Have not noticed a red light, but I just observed that the blue light is flickering when the system is freezed (but seems not related to any input).

Thanks for your help so far.

Do you have another 5v, 2A power supply?

Finally found a proper power supply in the basement. But it did not bring any approvement --> issue persists.

Maybe check the temperature development over time to see if it peaks at one point.
There was recently some one also having overheating issue.

Watched temperature development by reading cat /sys/class/thermal/thermal_zone0/temp every 5 seconds. Highest value before freezing again was 60000, so 60°C. I think that should be in normal range?

Yes, up to 90°C is an expected range.
Then the culprit must be somewhere else.

Does the device respond to ping after being unresponsive?

Unfortunately, not.
Also tried to get any response with a connected USB keyboard, but that didn’t work either.

If this occurs on a completely fresh install it might be worth contacting support@osmc.tv

Will do so.
Anyway, I thank you all for your time and help so far.

Best regards, Hans