Vero 4K+ Freezing Randomly

Hi guys,

I’m not sure if it is related, but not long after updating to Kodi V19, my Vero 4K+ has started to freeze randomly. When it happens, the audio goes into a rapid repeating loop until I disconnect the power cable and plug it back in again to restart the device. While it is frozen, I can’t access the device via SSH either. I haven’t been able to grab a log yet as it happens so randomly and unpredictably. It happens at least once every 3 days though, even if the device is sitting idle. I have very few add ons installed and haven’t encountered an issue like this until now. I have a powered USB hub with 2 external drives connected to my Vero, however the freezes still happen even if I disconnect that completely.

While I am waiting to grab a log, is there anything obvious that jumps out as to what may be causing this issue or any suggestions for me to try?


Good to rule that out.

Do you need v19 right now? You could downgrade.

I don’t really need it, it’s just that the IPTV seems to perform better in V19. I’ll sacrifice that for stability though!

I’ll try downgrading later today.

Out of curiosity: how is it performing better?



Sorry, I meant that the IPTV Simple Client add on has more features and better performance in v19 than in v18, particularly with regard to the EPG.

By the way, since reverting back to v18 just over a week ago, the freezing has stopped, so fingers crossed the issue is now solved. I wonder what was causing it to happen?

This issue has started happening again after updating to the stable version 19. Whatever is happening is only happening in version 19 because it didn’t happen once after I rolled back to version 18 previously. I’ll try to get a log of the issue when it happens, but it might take a while because it seems to be random and only happens once every 2 - 3 days.

Is the device warm to the touch? Are you in a hot climate?

I live in damp, cool Ireland, so no issue with the climate here!

The device is warm from the OSMC logo to the rear of the device, but not hot.

Some logs are probably the best way to proceed then.


I was thinking the same. I’ll post them here when I manage to grab them.


Finally managed to grab a log of the problem this evening. Here is the link. (The official OSMC pastebin seems to be down, so I used the Kodi one instead.)

Thanks in advance!

Oh, exactly this happened to me as well a couple of days ago. I have a Vero4K+ that came with Kodi 19 already (and it’s probably quite up-to-date)

I’m seeing freezing when using suspend mode, the unit seems to freeze when waking from suspend. Started happening after the 19.1 upgrade

Is your device actually frozen, or can you ping / SSH in to the machine?


For my device, I can no longer SSH in to the machine when it freezes.

I have not tried any other type of connection, when it does this the screen is dimmed and no remote commands over CEC work. Going to get a new direct remote to see if that can work.

I’d just do a full shut down but CEC does not turn on the unit and my old remote/dongle does not work so I can only use CEC now.

This did start directly after the 19 upgrade.

Does anyone have any ideas what might be wrong? I think I’m going to roll back to version 18 soon if the issue can’t be fixed.

It’s not immediately obvious – but we’re working on some bug fixes and you might get improvements from that.

I’d be interested to know if downgrading resolves your issue.

Yes, it only happens in version 19. I first noticed it when I upgraded to version 19 in beta and then I rolled back to version 18 and the problem went away. I upgraded again to version 19 when it was officially released and stable, but the issue came back again. It seems to be something that has changed from version 18 to 19, rather than a hardware issue.

I’m having the same problems after upgrading to v19. What’s the easiest way to rollback to v18?