Vero 4K+ Fresh install cannot connect to SMB nor NFS nor MySQL on my NAS

Its quite annoying, that after a fresh install, my Vero 4K+ went into a loop cycle when my USB HDD dock was connected with 2 HDDs. As there was no solution for this problem, I decided, to connect the USB Dock to my QNAP NAS as an external HDD, and install the Vero to use the NAS as a Media Library (SQL Server) and all the connected hard drives as media source - opening the opportunity to add one more Vero 4K+ in the future for my setup easily.

A quick summary: Nothing works… I created a user and a new database on the SQL server, and set SQL server in MyOSMC to look for (and create) the Library on the NAS. This resulted a 5-10 minutes hang with a black screen when booting up - assuming the Vero wants to connect to the SQL database without any success. However the MyPhPAdmin shows, that 2 connections are active (Movie, and Music library?)

Then, I wanted to add the network shares where my movie files are, but Vero cannot find any SMB or NFS shares at all. These shares are visible to my Windows 10 Pro PC, including the NFS share.

While It shows my QNAP (SAMBA) in the ZeroConf Browser, but when I click on it, it says “No route to host.”

Can someone help me out why nothing wants to work with this media player now?
Thanks in advance,

Some logs should help. NFS and SMB shares aren’t browsable however - and you usually need to enter the path manually.

Can you confirm the NAS has a static IP?

Does it show a “MyVideos116” database had been created? If not did you give the appropriate user permissions as specified in Kodi’s guide?

Hi Sam,
Yes my NAS has a fixed IP, can you please guide me where can I find any logs with regards this problem, I only see the error message that Vero cannot reach the host.
I tried to manually enter the server address psw etc, with no luck. Interestingly the NFS browser pulls up my Popcorn A500 from the network as an NFS host, but not the QNAP.

To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

Depending on the used skin you have to set the settings-level to standard or higher, in summary:

  • enable debug logging at settings->system->logging

  • reboot the OSMC device twice(!)

  • reproduce the issue

  • upload the log set (all configs and logs!) either using the Log Uploader method within the My OSMC menu in the GUI or the ssh method invoking command grab-logs -A

  • publish the provided URL from the log set upload, here

Thanks for your understanding. We hope that we can help you get up and running again shortly.

OSMC skin screenshot:

Thanks for the guide. No, there’s no database created as of yet. I will go back step by step to the guide to see if any steps were missed.

Hi Guys,
OK, so I went back with a fresh install again, followed the guide and created the MySQL user with full privileges, and the problem is the same. OSBC hangs after the blue Logo screen on a black screen for 5 to 10 minutes - while there’s some communication in the background with the QNAP SQL Server - but no database or tables were created, and thats it. Still can’t reach any shares either on my NAS. So, it seems Vero cannot connect to my NAS at all. (installed its SMB client as well).
I was just about ordering another Vero to be able to use a multi room system, but I’m struggling with this since 3 days now without any success.

I followed Tom_Doyle’s settings, created the Debug Log and uploaded from My OSBC.
Please find it here:
Event Log

Can't connect to MySQL server on ''
Are you sure you allowed acces for the user kodi from all hosts?

Suggest you connect to the Vero via SSH and run mysql client to check.
sudo apt-get install mariadb-client
mysql -h -u kodi -p
Then enter your password and if you get access run show databases;

Details regarding how to access the command line interface can be found here on our Wiki: Accessing the command line - General - OSMC

Hi fzinken,
Thanks for that. I tried to connect, but it returned Can’t connect to MySQL server on … (115)
I have no idea what blocks the connection to the NAS, I created the kodi user, with % host, and gave ALL PRIVILEGES and GRANT as well. I even tried to add this user with the exact HOST IP address of my Vero, but no luck. :frowning:

Check if the port is open.
sudo apt-get install nmap
nmap -p3306

Note: Host seems down. If it is really up, but blocking our ping probes, try -Pn
Nmap done: 1 IP address (0 hosts up) scanned in 3.17 seconds

Did you try nmap -Pn -p3306

Yes, that one says:
Host is up. port: 3306/tcp state: filtered service: mysql

I’m not sure if it helps, but I also used the ping on Vero, but just stopped responding, however pinging my router on the network ping works without any problem.
So somehow my NAS is not visible for the vero, all other clients answers to the ping.

Ok good sign that the server is running and reachable.
But "Can’t connect to MYSQL ` is still a very low level error. You need to check your Server config. Can you reach the MySQL server from your other machine (via MySQL client)?

Whats the output of arp -n HWAddress (incomplete)
all other clients are fine with their MAC address.

If it can be a useful information,
My NAS connected to the router with Port Trunking - with 2 ethernet cables using IEEE 802.3ad standard. In the NAS Network settings I can see its MAC address (ethernet 1 port).

Maybe try without Trunking to see if that solves the issue

OK, I removed that trunking, and arp -n reported the MAC address without any problem. And nmap also reached the NAS now!Than
Many thanks for your help to guide me to the solution!
Now everything works just fine!