Vero 4K - HDD connected - Audio but no picture with every second file I want to play

Hello, since yesterday I have a problem that is new to me. When Im watching a TV show (MP4), that is on my HDD (WD Elements Desktop), every second episode will not shown a picture but sound. This means, the first movie or picture will be fine (video / audio works) but the second file I want to play will be audio only without a picture

Workaround. I have to press play on my Harmony Elite Remote (with X-Box Profile), then press Return, press Play again.

Is there anybody here who is able to identify this behaviour. It is strange because it is completely new to me. I have not experience this before.

Thank you in advance.


To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

Thanks for your understanding. We hope that we can help you get up and running again shortly.

Is this only with a certain TV show?

Do other files (that have played OK in the past), still play OK?


Dear Sam, thanks for your quick reply. It doesnt matter which file I want to play. Other workaround is to pull the power cable. After it, it will also play the first file but not the second (a movie or whatever). It is strange becauseI have never had this behaviour before. Maybe I have to test it with another HDD…

I think I will submit a support request as ActionA described.

Have you installed X-windows? I’ve got the same issue since I installed X-windows and installed the accelerated drivers.

Exiting kodi (insted of pulling power) and let it restart, clears it up for me. Or trying to start the same file a few times works for me.

Thanks Joakim. No I have not installed x-windows. Ive made no changes to the system and from day to another it occurs as described. Maybe I will reinstall OSMC as a fresh version. However, there is a workaround…

I believe this occurs for clips with high # of ReFrames. If so, I think there is something we can do to solve this. MediaInfo on an affected file could be useful. If you’re not sure how to do this just wait and see if it’s resolved in a future version of OSMC.

@joakim_s I have used the Exit Button of Kodi and it looks like that the Problem is gone. If temporarily or forever - we will see. Strange :slight_smile:
@sam_nazarko Thanks again for your engagement in this topic. I will try to get the Media Information.

PS. This community is amazing. I have never seen something like this before. Product Support at is best and helpful people. Sam and all the other guys. Thanks. Great!

Thanks for the kind words.

Hopefully we can get this solved soon, and even better if we can get it solved without needing further info. A member of our team (@joakim_s) is also experiencing this. So not to worry: it will be solved, and promptly.


Dont know if it helps, but here is a grab-logs -A, while running debug logsvia advancedsettings.xml
Huge log but, around 00:04 i try to open the second file and get the error


I had some files where audio would play but video would get stuck just few frames into the video. Disabling amcodec in settings -> player fixed the issue for me. ( Remember to re-enable it for usual videos)

Maybe it’s the same problem I have:

Yep. Thanks @newsy This workaround works exactly as described. It is true I also have to start every movie twice but it is more comfortable as the other workaround “Exit Kodi”. Thank you!!!