Vero 4k HDR config

My library has a mix of Blu-Ray and 4k Blu-Ray rips in iso and mkv format. My display is a JVC RS-500 projector. I was able to get a 4k Blu-Ray to play but only at 8bit. I read that the Vero 4k will do automatic resolution and color space switching.

How do I configure my Vero 4k to output 1080p 8bit Rec.709 for standard Blu-Ray and automatically switch to 4k 10 bit HDR BT.2020 when I play 4k Blu-Ray?

Currently it tries to do this automatically. The plan is to refine this with some improvements in the future (and GUI configurable options)

Some projects have problems with 10-bit IIRC, so it’s worth checking what formats your projector supports


My projector fully supports 4k HDR. I also have a Panasonic UB-900 4k Blu-Ray player that works great for playing with 4k HDR 10 bit BT.2020.

From JVC:
The DLA-RS500 accepts native 4K 60P (4:4:4) material through Full Speed 18Gbps HDMI/HDCP 2.2 compatible inputs and displays it with stunning 3840 x 2160 precision and unbeatable contrast and clarity. JVC projectors include HDR content compatibility
Dual Full Speed 18Gbps HDMI/HDCP 2.2 Compatible Inputs
Compatible with full spec native 4K signals such as 4K60p 4:4:4 4K60p 4:2:2/36bit and 4K24p 4:4:4/36bit Compatible with 4K streaming devices and UHD BD content
Compatible with DCI Color Space
sRGB, DCI and x.v. Color space

Good — I know there are some JVCs that are not as accommodating


4k HDR is the primary reason I bought the Vero 4k so how can I troubleshoot the problem?

Debug logs would help.


echo '444,10bit' > /sys/class/amhdmitx/amhdmitx0/attr

work for you?

I’ll read up on how to do that and give it a try.

Adding that command line option above worked, it now plays 10bit in HDR10. I initially tried 4:2:2 as in my experience it’s more consistent to use but it caused the picture to be green. Is using 4:2:2 a problem with the Vero?

When playing the 4k BR rip of Lucy I got a message about the network being too slow for uninterruped playback. I’m using a Synology NAS with SMB. When I transfer files from my PC I see speeds of 90-100MB/s.

Is there a way for the Vero to output the resolution of the source file? The only way I could get it to output 4k is to change the display setting to 3840x2160 which results in everything being scaled to 4k.

Just enable Adjust Refresh Rate (you’ll want this for smooth playback)

You may find some performance improvements from mounting via fstab. Are you using Wired or Wireless connection?

It should be better to leave as is – there are some limitations here (HDMI spec) which have been discussed before.

In the near future this will be configurable via Kodi.


I’m using a wired connection. So I should mount SMB using fstab or NFS?

NFS is the way to go if you can.
Mounting NFS via fstab is even better


I was able to configure NFS on my Synology NAS and setup the file shares. Is there a guide on mounting via fstab?

Is a regular NFS connection mounted via Kodi not working for you? That’s how all my Kodi clients connect to my Synology server, and the single Vero 4K I have plays UHD content without stuttering.

I do not use fstab mounting as my Kodi database is hosted on the server, and my other clients run LibreELEC. I think in this use case, fstab mounting would not work?

Haven’t tried NFS through Kodi, thought it was best to mount via fstab. I’ll try it through Kodi and see how it works.


Stick with FSTAB if you can.

See Configuring fstab based NFS share mounts.

I got NFS working with FSTAB. Unfortunately I’m still getting “Too slow for continuous playback” and lots of stuttering with Lucy. I ripped it from a retail copy of the 4k UHD Blu-Ray using makemkv. Is there a utility to test the speed of the network connection?

Simple do dd if=/mnt/<YOUR SERVER MOUNT DIRECTORY>/<YOUR TEST.FILE> of=/dev/null bs=1M count=3072

Thanks, I ran it for a couple of minutes before hitting ctrl-c, seems about right for 100Mb/s interface.

osmc@vero4k:/dev$ 1292894208 bytes (1.3 GB, 1.2 GiB) copied, 108.788 s, 11.9 MB/s

Here’s another one from a smaller file.
osmc@vero4k:/mnt/4kmovies$ dd if=/mnt/4kmovies/Exodus_UHD_HDR_Exodus_draft.mp4 of=/dev/null bs=1M count=3072
245+1 records in
245+1 records out
257805374 bytes (258 MB, 246 MiB) copied, 21.9495 s, 11.7 MB/s

I actually have pretty much the same setup as you (X5500 JVC Projector / NAS via NFS) - I see the same kind of file copy performance via NFS fstab mount but I also have an issue with Lucy UHD Remux ( and Dredd too).

They are both around 85mbps with ATMOS sound track playing. If I enable the player process info (O key) in Kodi when they are playing, I can see that the cache hits 0% when the come to a stop and Kodi complains of the source being too slow. So the new Kodi cache settings in the last release have helped a bit but still don’t seem to resolve issues on this pretty high bandwidth titles. For me at least.