Vero 4k HDR config

Speeds look OK. What I’d suggest trying next would be to try playing the movie locally instead of over the network. This will help rule out problems with the encode. Copy the movie to a USB stick would be the easiest way to do this.

Thanks for chiming in, that’s disappointing to hear. Is it possible to make the cache buffers even larger? What about a USB Gb Ethernet adapter?

Are you using this to get the correct color space?
echo ‘444,10bit’ > /sys/class/amhdmitx/amhdmitx0/attr

I will try playing Lucy from USB and report back.

Yep - for me the Vero 4k gave a much better experience with 4k HDR BT2020 material than my previous SheildTV. I have been thinking about a gigabit usb adapter (as my navigation experience is a little sluggish too).

I do use 444,10bit setting - which works well. I also tried 12bit - as it is supported by my PJ but subjectively to me quality seemed to go down.

Interesting to here how Lucy goes from USB. Seems unlikely to be an encode issue given this is a remux.

I only have issues with files that are at the higher bitrate end. I.e. 55gb remux that is for movie of around 1:30hr duration.

Cache possible could go larger, but Sam spent time optimising them in the last release. So would be interested in his thoughts. Also interested in what the next release brings for HDR improvements.

For me, at the moment, 1080p remuxes generally look better on my PK than 2160p HDR. Ultimately the lack of brightness a PJ has compared to TV limits the benefits of HDR.

1 Like

Lucy played perfectly from USB. I also played it on an Oppo 203 via NFS and it played fine. I watched the bit rate meter on the Oppo and it spiked to 105mb at one point. It looks like the 100mb ethernet on the Vero is causing the problem. I ordered a Gb lan adapter to try and see if it solves the problem.

Add the Martian to the list of 4k BR titles that have too high of a bit rate to stream uninterupted over 100mbps ethernet.

Do you have the MediaInfo for that file?
I’m sure there are some titles we need to tweak settings a bit for


1 Like

The Martian

Did you want it for Lucy too?

Bit rate                                 : 34.7 Mb/s
Width                                    : 3 840 pixels
Height                                   : 2 160 pixels
Display aspect ratio                     : 16:9
Frame rate mode                          : Constant
Frame rate                               : 23.976 (24000/1001) FPS

Doesn’t look particularly taxing on the Ethernet.
How did you calculate that the bitrate is too high?

In fstab, I would try: rsize=32768,wsize=32768,udp in options.

By the “Too slow for continuous playback” message I received and stuttering. I played back the same file on my Oppo 203 with Gb ethernet and had no problems. Maybe there’s something else going on. The Vero, Oppo, and NAS are all on the same ethernet switch.

I ordered a USB to Gb lan adapter, should be here tomorrow. Do I still need those settings?

Here’s my fstab. Where is options?

#/dev/vero-nand/root / ext4 defaults,noatime 0 0 /mnt/movies nfs noauto,x-systemd.automount 0 0 /mnt/4kmovies nfs noauto,x-systemd.automount 0 0

Your performance via fstab seems too slow.
A Gigabit adapter might mask the real issue; but if the stream has a reported bitrate of 34Mbps and you cannot play it, then something else is the problem.

The fstab with Sams suggestion would look like: /mnt/movies nfs noauto,x-systemd.automount,rsize=32768,wsize=32768,udp 0 0 /mnt/4kmovies nfs noauto,x-systemd.automount,rsize=32768,wsize=32768,udp 0 0

What else could it be? I tested my network speed twice and got 11.7 and 11.9 MB/s.

Try the suggested fstab changes and see if that helps. And just to verify you did try playing the problem files via a directly connected USB drive?

Another idea, try your dd test again, but add status=progress and see if you are getting stalling during the test. So try this:

dd if=/mnt/4kmovies/Exodus_UHD_HDR_Exodus_draft.mp4 of=/dev/null bs=1M count=3072 status=progress

And for a real good (but long running test) remove count= from the dd test.

The fstab changes did help some. I didn’t get the too slow message but there was still a couple instances of stuttering and audio dropouts with the Martian. I also tried Lucy with the new settings and still got the slow slow playback message with stuttering. Going to try 1Gb lan adapter next.

I tried the FSTAB changes too to add in the extra rsize / wsize options. My dd test speed of 11.9 didn’t change but I was now able to watch Lucy without drop outs or buffering. The player cache seems to now be able to stay at 1% full rather than hitting 0%. I’ll try some other movies i’ve had problems with (Dredd for example) but maybe, for me at least, i have a workable solution without gigabit nic.

Thanks for confirming. Gigabit adapters are largely unnecessary and usually mitigate poor network performance due to misconfiguration or other factors.

Just wanted to drop here, that I also mounted my movies via fstab as I wanted to max out the 100MBps for my 4K HDR remux files. I didn’t even try anything else like the built-in NFS client, SMB or DLNA and I also used the options Sam suggested.

However, I couldn’t get past 6-9 MB/s with drops and buffering throughout the movies. First I tried to move my Vero 4K around so it’s not behind the network switch and also tried SMB. But that didn’t help at all. But after removing the options I got a stable 11.8 MB/s, just if anyone also had those problems with these fstab options.

Edit: I mentioned a movie I had problems with. However, it also has these problems on PowerDVD with heavy artifacts. So the encode itself is probably the culprit.

I tried about a dozen 4K HDR movies now.

Results after some further tests now:

DLNA: Buffering
SMB: Buffering
fstab w/ “,rsize=32768,wsize=32768,udp” : Buffering
fstab plain: Great :slight_smile:

That’s great, I’m still having problems with mine even after the rsize/wsize options Sam recommended. Are you using the lossless Dolby TrueHD audio track with Lucy?

Yes, it played fine from USB. It’s better with the rsize/wsize options but still having some stuttering and audio dropouts with Lucy, I’m also using the TrueHD/Atmos lossless audio track.

losmc@vero4k:~$ dd if=/mnt/4kmovies/Exodus_UHD_HDR_Exodus_draft.mp4 of=/dev/null bs=1M count=3072 status=progress
252706816 bytes (253 MB, 241 MiB) copied, 21.0162 s, 12.0 MB/s
245+1 records in
245+1 records out
257805374 bytes (258 MB, 246 MiB) copied, 21.443 s, 12.0 MB/s

Yep I use the Atmos track, so pushing the max bitrate of the movie. One thing though, I don’t run any other services / apps on my Vero other than Kodi. So nothing else is using any of the bandwidth while playing a mkv.