Vero 4k issue with aac

I bought a Vero 4k and everything is good, expect the sound of some video. I watched yesterday a H264 series with AAC sound. It’s start playing, and after some minutes sound start slipping. When i disabled passtrue there is the same situason. When i stop it, and resume to play, everything go fine to a few minutes. The picture is not as smooth as my better quality videos.

Please post mediainfo and logs when the issue occurs.

Passthrough should not have any effect on this so that’s normal (pass-through is for AC3/DTS).
Have you tried playing on another device? Does it have the same issues?

Here is my log:
Here is media info:

I think this might cause the problem:

18:51:32.408 T:3249738496 ERROR: CVideoPlayerVideo::OpenStream - Invalid framerate 500, using forced 25fps and just trust timestamps

Probably caused by this:

Frame rate : 50.076 FPS

Frame rate : 46.875 FPS (1024 SPF)

which seems a weird frame-rates to me. Anybody else seen this sort of framerate before?

Before Vero, i played it with Raspberry Pi2, and everything goes well. I tried it with my laptop, and it’s work too. There’s no option to force sync audio with video?

Yes, it’s called Sync Playback to Display, but you’d lose passthrough. Can you let me know more about your setup?


Yes, how can i inform you?

How is your system set up? Do you have an AVR? How many speakers? What are your current audio settings, with screenshots, if possible?


I have a receiver, and a tv. I play the content from a raspberry pi with sftp connection. I have 5.0 speaker settings. All passthrough settings are on. I will make a screenshot in friday.

Let me know

Here are my screenshots:
And there are these rows in the logs:
Feb 08 23:25:55 osmc kernel: vout_serve: vmode set to 1080p50hz
Feb 08 23:25:55 osmc kernel: vout_serve: disable HDMI PHY as soon as possible

You can upload logs via My OSMC (we’d need to see complete logs).
You can upload screenshots directly to the forum.

We need to see the full logs to know if your audio settings are actually correct.

This is not a Kodi debug log.
It’s not clear which file you tried to play that experienced a problem.

Can you please produce a log playing just one problematic file, with debugging enabled?
Now i think problem is not with sound, because it’s continous. Now the picture looks very laggy.

4 posts were split to a new topic: Problems playing Video with AAC soundtrack