Vero 4K+ Issues and questions

I just got my Vero 4K+ a few days ago, and used it to replace an existing Elec Computer Le Potato running CoreELEC version 9.2.6.

That machine had recently replaced an Intel NUC 8 running Win 10 w/KODI 20 Nexus.

The reason for the chnage is the ability to play 3D MVC movies. Prior to this I also uses a Fire Cube Gen2. All these units could play 3D HSBS or HOU files, but I had to use the LG TV’s remote to manually switch the 3D mode. Whne I installed the Libre Computer, it could send the correct signal to the TV to enable 3D mode automatically, which is amuch more elegant and convenient solution.

But none of these units could play full resolution MVC movies, although a another Intel NUC (6th Gen) worked fine with a different TV.

So, Enter the Vero 4K+. This is supposed to be THE ONE when it comes to playing 3D formats. And it does, it plays MVC files, it also plays regular split screen 3D movies, play 4K as well as HDR, but… not without problems.

Below are the problems I have, which I didn’t have with the other units.

  • Scraping is very slow, and sometimes it hangs indefinitely, requiring a reboot to get it out of that state.
  • Scanning for new content, even if there just a few movies added, takes a very long time as well
  • 4K 3D HSBS only play as 2D. The GUI recognizes the 3D file, but it disables the 3D mode and forces 2D mode playback.
  • Selecting any share or playlist takes about 20 seconds before it shows the movies

Question: can the library be put on a MicroSD? Right now, I’ve only scraped my Movies, Anime, and TV shows, and I’m down to 5.5GB of free space. I have in excess of 5000 Audio Books and music albums, and I’m afraid that will eat up all the remaining space. Simply put, 16GB of emmc for the OS, KODI, and the scraped libraries may not be enough. How can I move the user folder to the SD card?

FWIW, all my media is on a QNAP NAS, shared using SMB. The Vero is connected via GBit Ethernet, and my internet connection is symetrical Gbit.

Some more information.

I’ve added a new TV Shows source, and when I try to scrape it, I get “Scanning for new content”, which sits there for like 10 minutes+, then I get a “Embuary Info Error - See logs for info”, then it automatically tries again, and after about 2 minutes, I get the OSMC sad face and the Vero just reboots.

I haven’t yet looked at the error, because I don’t know where it’s stored, but this is very frustrating.

To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

Depending on the used skin you have to set the settings-level to standard or higher, in summary:

  • enable debug logging at settings->system->logging

  • reboot the OSMC device twice(!)

  • reproduce the issue

  • upload the log set (all configs and logs!) either using the Log Uploader method within the My OSMC menu in the GUI or the ssh method invoking command grab-logs -A

  • publish the provided URL from the log set upload, here

Thanks for your understanding. We hope that we can help you get up and running again shortly.

OSMC skin screenshot:

You can move the storage location of thumbnails to a different path (including a network location). The size of the other userdata wouldn’t be significant.


Sorry for the late reply. Currently travelling.

We’ll need to see some logs for this

We’ve never seen 4K 3D HSBS videos. Are these commercial releases? Could you provide a sample video? We support commercial official 3D releases as FP/TB/SBS and remuxes should work soon.

Sorry for the late response as well. I’m currently out of town, so I don’t have access to my home system. When I return next Tuesday I should be able to post some more information and logs.

Regarding the 4K 3D: Those are not commercial, I ripped my own 3D BluRays into this format using DVD Fab. It simply an upscaled version of a half-SBS movie.

The idea behind it is, that if you take a 1080p frame and you scale it up to 4K, then you halve it’s width to get the half-SBS, you end up with all the original frame width and you have no resolution loss.

Since these are upscaled and encoded to 3D in one pass from the original BluRay, there should be no resolution loss, as would be if you were to take an already existing half-SBS und simply upscale it.

These play just fine with the other KODI players, and the Libre even triggers the LG TV’s 3D function, which plays it as a 4K 3D movie. The Vero though plays it in 2D. Once I start the movie, if I go to the OSD menu and click the 3D button, I see the 3D mode is on, the mode is side by side, but the “Play in 2D” is also enabled. I can’t turn off Play in 2D. I can, however, turn off 3D mode.

some additional information regarding scraping.

This morning, I thought I’d try something new. Since I was getting and Embuary Info error, I disabled this add-on, then I removed the exiting TV Shows source, just in case there was something wrong with the mapping, and I recreated it, by simply adding a new source. After adding it, I set the video type to TV shows, checked "each folder contains a single TV show, and when it asked if I wanted to update information I said NO. Once the source was there, I pressed “C” to bring up to contextual menu, and clicked “Scan for New Content”

After about a minute of nothing happening, I got the “scanning for new content”, and unlike previous times, it didn’t crash after a few minutes, it just kept on going, but it never got out of the “scanning for new content” phase. By the time I left the house (2 hours later), it was still scanning for new content, and had yet to find any shows.

This source contains 377 TV shows, in individual folders. Each folder is one show, and inside those folder are either the individual episodes, or if the show has multiple seasons there are folders for each season, and the videos are in their respective folders.

For all I know the Vero is still trying to scan for these TV shows, as I left it to do it’s thing while I’m away.

FWIW, while also very slow, all the other folders (Movies, 3D movies, 4K movies, Anime, etc) they did scan, the TV Shows folder originally scanned, but not all of it. it only found about 60 shows before it crashed, and subsequent tries yielded repeated crashes, which brought me to this latest attempt.

I’ll post an update once I get home next week.

BY comparison, I can scan the TV shows folder on my Intel NUC in about 35 minutes. On the Libre with CoreELEC it scans in about an hour and a half.

Last but not least, I use the Rapier skin on all my setups, because it give me the flexibility to have my own categories and subcategories on the main screen, while not being overly heavy on the graphics like AEON for example


Our objective regarding 3D is to support commercial releases.
I’m not sure what DVD Fab does. Maybe you could provide us with a small sample and we can see what we can do.

Re scraping: need to see logs. Would also be interesting to know if you can scrape quicker using the OSMC skin.


Hi Sam,

Sorry for the late reply, I was out of town until yesterday. I’ve uploaded the logs as requested. The URL is:

I also did a quick 2 minute sampler of a 4K 3D video. It’s about 110MB, I uploaded it here:

Some additional info regarding scraping behavior:

First of all, the issue with it not progressing beyond “Scanning for new content” was a settings issue, I had inadvertently checked the “Folder Contains a Single Show”, when I recreated the share. Once I unchecked that, it started to scrape.

I tried scraping from the OSMC skin as well as Rapier, and there doesn’t seem to be much difference. I scraped first with the default TMDB TV scraper, which ran overnight (I don’t know how long), but It only scraped about 220 shows out of 384 (I added a few new ones since last week). I then switched to the TVDB v4 scraper in the morning, and kept tabs on it. This one took 7:15 hours to scrape the TV Shows folder.

It found 368 shows. I had to add the others manually. Of the 368, 5 were incorrect (wrong show), which in itself is not that bad. The real problem was the episodes it found, or rather, it didn’t find. In general, if all the episodes were in the main show folder, they were scraped. Also if they were in a folder called “Season 1” or “S01”, they scraped fine. But if they were in other folders, like “Season 2”, “Season 3”, “Season 4”, etc, they didn’t scrape. However, manually selecting Manage, and Refresh Info, then telling it to ignore existing info and scan fresh, it would find everything correctly. So I don’t know what that was all about, but it took me all of yesterday and today to fix everything.

Also, this behavior (not finding all the seasons), was not 100% across everything. Some shows (about 10%) were properly scraped, from inside all the folders, so it seems rather random.

Anyway, I have everything scraped, but it’s really weird. something else I noticed when I was scraping individual shows manually. On some shows, refreshing the information may take a minute or less. Others can take up to 10 minutes or more, and it doesn’t really have anything to do with the number of episodes, either.

BTW, the logs were started in the middle of the last scan (the one that took 7 hours), and after a few minutes I stopped it. I don’t know if that’s enough or not. If not let me know, and I can try to do it again.

One other question. Is the LAN a true Gbit interface?

I wanted to see what my internet connection is, so I tried to run the Speed Test add-on by Dr0idGuy, and while that app runs on the Intel NUC, it won’t run on the Vero.

I tested the speed on the NUC, which is a Gbit interface, and ran it 5 times, the average speed was around 810Mbps Down and 450Mbps Up. Below is a snapshot of it.

And here are the tests on the Vero, using the Speedtest-cli application. it’s all over the place, but the download speeds don’t seem to go over 375Mbps, and the uploads are as low as 12Mbits and as high as 272Mbps.

Could this be contributing to the erratic scraping behavior? I don’t seem to have a problem playing movies from my NAS, but then again, I haven’t tried any high data-rate stuff. Most of my movies, including the 4K or the MVC stuff don’t really exceed 10-12Mbps.

Back to the LAN, is it a true Gbit that ties into a PCIe bus or is something that sits on a USB bus?

I believe @tanio99 was, at one time, having a look at getting 4K SBS or TAB videos working, but I don’t recall hearing anything about them actually being supported. HSBS, HTAB and MVC are all handled.

Considering these are basically the same as any other HSBS, only larger, you’d think that they would work automatically.

The Intel NUC with KODI 20.0 handles them normally and turns on the 3D function, and so does the CoreElec version of KODI running on a Libre Computer. The Libre doesn’t handle MVC though.

I know very little about 3-D but isn’t this remark similar to expecting a device that plays 1080p to automatically handle 4k?

Yes – but with a speedtest, you’re testing your external internet connection; not your local network connection. You could use iperf to check the internal speeds.

The LAN interface is not connected via USB

Scrapers can occasionally be slow or unreliable. It could have been an issue at the TMDB end.

That’s right. Since you’ve asked, I’d like to give you an update now :slight_smile: . When I was working on the “flip eye” support for HSBS/HTAB videos a couple of months ago I’ve also had a look at Full-SBS/TAB support. What I found out was just a nightmare. The 3D code in the kernel is just working by chance it seems. The code is in a very bad condition, duplicate code everywhere, 3D related code that influences 2D playback, dead code, or code that just isn’t doing what it should.

While I was working on the above mentioned flip eye support I was also cleaning and refactoring parts of that code to prepare it for Full-SBS/TAB support. So I’ve already implemented parts of it, but tbh, the more I think about it, the more I think throwing away all that 3D code in the kernel and rewriting it from scratch would be the better solution.

To make a long story short: Full-SBS/TAB support is still on my todo list. As soon as Kodi 20 is out I’ll look at the 2D/3D subtitle related issues (you remember :wink: ?). Then I could start working on it (if nothing more important shows up).

Yes, you’re right - at first sight. But there’s a difference: HSBS means that both parts of a frame, the left eye and the right eye view need to be stretched to get the right dimensions of e.g. 1920x1080. But in the FSBS case, no stretching is needed because the views already have the correct dimensions. Unfortunately, the current 3D implementation just stretches everything when it would get a 4k frame holding the two views. So you would get a 3840 x 2160 view as a result.

You might ask why is that stretching (or not) needed? The device (Vero) should just forward the frame as it is to the TV and stretching or not is handled by the TV and not the device.

And that’s also true, but if you want to support e.g. flip eyes, then you need to cut the frame into pieces, swap left and right views and combine them back to a frame that will finally be sent to the TV. The code that does that assumes that it gets HSBS/HTAB as input, and all the calculations that are needed to cut the frames and combine them afterwards rely on that. So for a 4K frame the wrong dimensions are used and you get garbage at the end.

Additionally, the current code relies on the dimension of the input frame and uses that as the resolution for each view. So e.g 1920x1080 means that each view will have that resolution. In case of 4k input the code assumes that each view will have a 4k resolution, but that’s not the case for Full-SBS/TAB. That’s another PITA that needs to be addressed.

So to make another long story short: I’m on it but it will take some time …

If I’m understanding you correctly, you’re thinking that this 4K video is full-SBS? It isn’t, it’s Half-SBS, just like regular 1080p HSBS, except it’s 2160p instead.

Here is a snapshot of a frame:

It looks like the forum image handler reduced the image from it’s original 3840 x 1608 to 1920 x 804 during the upload. Anyway to prevent it from doing this, so I can upload the full size image?

Alternately, I uploaded a quick 2 minute sample here:

No, not really, the Vero can already play 4K just fine, and it can play 1080p 3D movies just fine. These 3D 4K files are exactly like the 3D 1080p files, single frame, split in half with the left and right views side-by-side. The only difference is the frame size. Instead of 1920 x 1080, you get 3840 x 2160 (or whatever height the actual frame is).

KODI uses the file naming as the 3D detection method. If you don’t tell it it’s a 3D at all, it will simply play it like just any other 2D movie. Then I can use the TV 3D function to select side-by-side 3D mode and it will play it fine.

But these files are already named 3D HSBS, so KODI immediately goes into the side-by-side 3D mode, and splits the GUI, like it normally does…

It’s just that a fraction of a second later, it also selects Watch as 2D, so I end up with this. I can’t “uncheck” watch as 2D. I can only uncheck the “Enabled” button, which also unchecks Watch as 2D, then I do get the split screen, and I can use myTV’s remote to enable 3D. But of course, should I ever need the GUI, that will be all scrambled (left and right halves overlapped).

I’m not a Linux guy. Is iPerf part of the OSMC installation? I just looked at iPerf, and it appears I have to run an instance on the Vero as the client receiving the data, and another instance on the server sending the data. I can’t do that on my QNAP NAS as there is no access to the underlying OS.

In any case, is there a reason for the low speeds I’m seeing in speedtest-cli? I know I’m testing the internet conenction, but I should be getting much better results. When I test from my main desktop PC, using the web browser, I get this:

Using the ookla speed test cli, I get this:

so can there be something wrong with the LAN port of the device? Why am I getting such low transfer rates, especially on uploads, and why are they so random, one minute it’s 140Mbps, the next it’s 12, and then back up to 272, then down to 24.

1st: How does your TV do 3D? is it active shutter? or passive?
If the TV is passive, then it will have left/right views as interlaced lines, in which case, HTAB would give better results than HSBS. (since the “half” of HTAB would be the same “half” of the scanlines the TV will be displaying,), HSBS would be halving the horizontal resolution in the source, and then the TV itself would be again halving the vertical resolution for the display.

2nd: I question whether up-scaling the video makes sense. if it’s a 1080p movie, then it’s better to send it to the TV as 1080p and let the TV deal with any upscaling, since it will have hardware designed to do that.

That being said, I do have one BR that I ripped early on as “full-frame” sbs. And I can play it on my TV (which claims to be 1080p but will accept 4k input and downscale it). In my case, the mkv ended up as 3840x1080, and my TV accepts it (sees it as a 4k input) and properly displays the 3d when I set the TV to SBS mode.

I would very much doubt so.
I personally test each device before shipping, and that includes Ethernet performance in both directions.

The only way to properly test the internal network interface is to perform an iperf test. See [How To] Check Network Performance with iperf3. This covers your Windows PC.