Vero 4K+ lose video when stopping playback

Hi all - first post :slight_smile:
LG 4K OLED, connected to Yamaha RX-V4A amp via HDMI. Vero 4K+ connected to Yamaha AMP via HDMI.
Vero set to 1980x1080 resolution, even though seems to work quite well at 3840 x 2160 @ 60hz.
ARC in use, power off TV or AMP and both devices power off - but Vero stays powered on (which is what I expect/want).
eARC on the LG TV is NOT enabled.

Issue occurs when watching anything, TV/Movie, any resolution/quality - once I hit the ‘stop’ button, the screen goes blank and does not display the OSMC menu again. I still have audio, because if if I hit play again the TV/movie begins to play again and video returns.
Temp painful workaround, change the source on the Yamaha AMP to ‘anything other’ than the Vero - wait 2-3 secs, then revert back to the Vero AMP source, video output back again.

I have played with the HPD lock setting but doesn’t seem to make any impact.

Happy to provide further details/info/log files if required.
PS> Not sure if it matters but using Confluence skin.

You might shutting down the Vero and then unplug it, the TV, and the AVR from the wall for a minute or so. After that plug the TV and AVR back in for a couple minutes before plugging the Vero back in.

Hi - thanks for the reply - once powered back on, I tried a TV episode which played for a few seconds, hit stop and back to the menu - YES.
Then tried a movie, hit stop, blank screen again :weary:
Changed sources, tried the same original TV episode, blank screen.

To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

Depending on the used skin you have to set the settings-level to standard or higher, in summary:

  • enable debug logging at settings->system->logging

  • reboot the OSMC device twice(!)

  • reproduce the issue

  • upload the log set (all configs and logs!) either using the Log Uploader method within the My OSMC menu in the GUI or the ssh method invoking command grab-logs -A

  • publish the provided URL from the log set upload, here

Thanks for your understanding. We hope that we can help you get up and running again shortly.

OSMC skin screenshot:

Debug logs uploaded to - https://paste.osmc.tv/unoviqacux
After enabling, rebooted twice, tried a single TV episode - stopped, no display, switched sources on the AMP, switched back, disabled debug logs, SSH and grab-logs -A.

Is your AVR plugging into that TV’s HDMI 2/eARC input? I’ve seen some bad switching behavior when I tried using other inputs on my LG’s regardless of if eARC was enabled or not.

On an unrelated note it appears that your AVR supports HD audio formats that you don’t have enabled on your Vero. If those passthrough settings are not visible switch to expert view and they should show up.

Yes it is (it’s actually HDMI3 on that TV).
In relation to the HD audio formats, I have the Vero set to Expert view - could you please highlight the settings you are referring to?
FYI - watched a TV episode last night and didn’t hit the stop button, just let it play to the end, still no return to the TV list/menu - just blank screen.

====================== GUI Settings (abridged) =================== z9Z12KgS
Dolby Digital (AC3) capable receiver: true
DTS-HD capable receiver: false
DTS capable receiver: false
Dolby Digital Plus (E-AC3) capable receiver: false
Allow passthrough: true
TrueHD capable receiver: false

this doesn’t help my playback issue thought right ?

Nope, not at all. Like I said, “unrelated note”. Just noticed it in your logs so I figured I would mention it. I’m personally at a bit of a loss on what is going on or what else to try. Maybe see if you can figure out if the TV is switching inputs or not when this happens. If it is then it may have something to do with CEC. If not maybe search out and see if there is a soft reset option for your AVR. It might be something like holding down the power button for an extended period of time. Sometimes with modern receivers this can fix problems that somehow don’t clear by just unplugging it.

What happens if you connect HDMI to TV directly?

1 Like

Besides Sam’s suggestion: Latest/greatest firmware installed on the Yamaha AVR? Binary file has creation date of March 2023.

RX-V4A/TSR-400 Firmware Update Ver.1.62

Yamaha is pleased to offer the following firmware update to ensure the best possible performance and latest features for your AV receiver.

This firmware includes

  1. Stability improvements of MusicCast’s connection and playback.
  2. Minor bug fixes due to the update of some streaming services.
  3. Other stability improvements.

New log created/uploaded (https://paste.osmc.tv/kurocenoki)
DEbugging NOT enabled - just wanted to confirm new Audio setting, as suggested.

Apologises - it’s a Yamaha RX-V6A, not the 4A - however, yes firmware fully updated.

They look optimal now.

1 Like

Hi Sam - I will test this tonight, using the same HDMI cable and HDMI port on the TV.

1 Like

Hey Sam - works fine with the Vero plugged directly into the TV (using the same HDMI port/cable that ran from the TV to the AMP).
I have an Apple 4K TV, that I will move into that room, along with the Vero - to see if this behaves the same, connected to the Yamaha AMP.

PS> The stopping playback seems to be better now, but not 100%. When I switch the TV/AMP on, I get no video output from the Vero, audio only (I can hear the switching between menus). I need to switch the AMP to another source (TV or Spotify), wait for a few seconds, then switch back to the Vero source and video works.

See if the amp has a firmware update available.

thanks Sam - already confirmed the AMP is on the latest firmware, prior to creating this support ticket.