Vero 4k+ lost 7.1 analogue output after June update

I use the following device for 7.1 analogue output: Noblik 7.1 Sound Card Usb 2.0 Sound Card Cmi6206 Chipset

It worked perfectly, however after the June update it is titled differently in the audio settings (it now shows simply as “USB Audio Device” whereas before it showed a more descriptive name) and even if I set the channels to 7.1, both the side and rear channels are sent to the side speakers.

I have attached a log if that is of any use.

Does anyone have any advice?

CC: @grahamh - could be related to

Could you please get a commandline via ssh and post here the response to amixer -c1 contents. You may have to sudo apt-get update && sudo apt-get install alsa-utils to get amixer.

Also, turn on debug logging, repeat your attempt to play something with 7.1 channels and post logs.

amixer output here.
(the “| chmap-fixed=FL,FR,FC,LFE,SL,SR,SL,SR” line looks suspicious?)

debug log here.

Certainly does look suspicious. I can’t think why it ever worked! It must be a bug in the soundcard firmware that the previous Kodi managed to ignore. If you say the name has changed, that’s suspicious too - we’ve done nothing to change how Kodi presents USB soundcard names but maybe it’s been changed upstream. I’ll see what we can do.

If you have another linux system (PC or RPi maybe), can you run amixer contents on that for confirmation?

Testing on libreelec on a rpi4 I see the same suspicious line.
Interestingly, it refuses to play back any 7.1 content. Switching the output channels to 5.1 in the sound settings works fine, of course with the two rear channels routed to the side speakers.

At this point, I started doubting my sanity/memory but another member of my household confirms that all 7.1 channels worked perfectly on OSMC previously.

Switching to Windows and using the inbuilt channel test showed that it works as expected on that platform (correct output to all 8 speakers).

Testing on Ubuntu i get the same suspicious line. However using [speaker-test -c8 -twav] all 8 speakers played the correct output.

Any ideas how I could fix this in OSMC? Is it possible to remap the outputs or something like that?

I’m working on the assumption that something did change between March (Kodi 18.6) and June (18.7) that’s giving you this issue. I’m stuggling to find time to look at it, though. I can’t immediately think of anything you can do by way of conf files so unless you are handy with C++ coding and ALSA’s API can you bear with me for a bit? I need to see if there’s a solution to make both your card and @mbailen’s Asus card work (No 5.1 sound in Vero 4k with Xonar U5). My 7.1 USB soundcard works with all OSMC devices, all kernels and all Kodi versions, so it’s not easy and I will need you both to test solutions, probably.

I’ve pushed a fix for this. It should be in the next update.

That’s grerat news, thanks Graham. Is that the July update?

I don’t think a date for the next stable update is known yet. I don’t know if it is there yet but you would probably need to switch over staging to be able to test it.

For instructions as to how you can switch to staging, please read on:

  1. Login via the command line
  2. Edit the file /etc/apt/sources.list
  3. Add the following line: deb stretch-devel main
  4. Run the following commands to update: sudo apt-get update && sudo apt-get dist-upgrade && reboot
  5. Your system should have have received the update.

We also recommend you edit /etc/apt/sources.list again and remove the line that you added after updating. This will return you to the normal update channel.

I don’t think it’s there yet.