Vero 4K+ messes with ARC

Yep I have had this issue for months with both the Vero 4k and now the 4k+.
I have an LG SK8000 connected to a Denon AVRx2400H and the Vero 4k+ connects into the Denon AVR. I have also disabled HDMI CEC on the Vero. It seems the Vero is transmitting a rouge signal that is blocking ARC. Like other people I end up disconnecting the HDMI lead between the Vero and AVR.
I did mean to post about this issue again now that I’ve been having it with the new 4k+ but I know Sam and the team have been busy and I’ve been busy myself.

How I disable HDMI CEC? Having similar issue…

System>input>peripherals>cec adapter

Thanks!

I’ve had this problem from the get go with my Vero 4K+ as well.
I never turn my Vero off and sometimes it just wont let other devices take over ARC.
When that happens I just shut the Vero down since I’m trying to use a TV app or something else anyway.
Hope this gets resolved because it can be a little tedious sometimes, especially for my family when I’m not home.

While not an ARC specific thing. I too have had some odd issues with HDMI CEC with my Vero 4K +.

One issue is where the Vero seems to take input control, even when it’s not commanded to. I’ve not been able to pin down how or why.

The other one, which was a new one I experienced yesterday, after updating the firmware on my Yamaha RX-V3083 (aka A3070), when I went to play something on the Vero 4K, it’d play the first second or two, then something would happen to the HDMI visual signal where it’d change resolutions to something incompatible.

I’d have to switch away manually from the vero input, then back to it again, to get the menu to even come back.

It was readily reproducible at that time too.

I was a bit worried that it was related to the firmware update to my receiver, but after rebooting the Vero, it all came good again and has been working fine since.

There’s definitely something a little screwy going on.

Is it too late to capture logs given I’ve rebooted it and its been a day or so?

Edit: actually, the later issue sounds quite like this:

After a firmware upgrade it can be that HDMI assignment changed to it might be recommended to powerdown all devices at the power source and restart after 3 minutes with the TV and AVR.

1 Like

Different people with different setup have experienced the same issue.
Have you tried a different HDMI cable to connect the Vero 4K+

Yes. I did that before posting this topic. I bought two premium certified HDMI cables to replace the ones from the Vero to the AVR and from the AVR to the TV.

I just had my third ARC failure in almost a year of Vero ownership. The incidents are a bit scary, as ARC is killed completely, and recovery inolves a lot of disconnecting and hoping, just taking out the power does not always work. Anyway, back up and running now. No other device connected to my AVR ever causes this trouble.

Unfortunately it’s going to be a bit of a sod to diagnose something with such infrequency.

Do you have a log for this?

Sam

Unfortunately no log. I think I’ve figured out if I pull the power to the AVR completely and remove the Vero’s HDMI lead, the TV’s ability to see the AVR comes back. If I just unplug the Vero the ARC stays dead. Since this is such an infrequent problem I can live with it (twice with a regular Vero4K, now first time with a 4K+). Appreciate without some specifics on the circumstances leading up to the ARC crash, this will likely remain a mystery.

Hi,

I have a similar issue with my Vero 4k. It appears to interfere with the ARC (and the CEC) functionality of my TV set (Philips 55pos9002).

Set-up:

  • my Vero 4k is directly connected to one of the HDMI ARC inputs of my TV set (Philips 55pos9002). I’ve tried multiple HDMI cables with different lengths. The TV set has two HDMI ARC inputs; I tried both.
  • A Philips sound system is directly connected to another HDMI ARC input of my TV set

Behaviour:

  • Everything is working fine as long as I do not connect the Vero 4k to the HDMI ARC input of the TV set
  • However, it appears that the Vero 4k is interfering with the other components. This might not happen right away but usually pretty soon after plugging in the Vero 4k.

What do I mean with interference?

  • After connecting the Vero 4k to the TV set, the TV fails to activate the sound system, meaning that it outputs the sound through the speakers of the TV set. When trying to change the output in the settings of the TV set I receive a notification that it cannot activate the sound system
  • When switching off the TV set (since it’s a OLED, it is actually not turned off but sent into a sleep mode) the sound system is not put into sleep mode (i.e., the Vero 4k appears also to interfere with CEC since this is working flawlessly if the Vero is not connected).
  • The sound system is not activated when turning on the TV
  • What is strange is that I don’t even have to switch to the Vero 4k. The problem also occurs if I only plug-in the Vero 4k and only watch regular TV, Netflix, etc.
  • It will very often lose ARC when changing source to Vero 4k.

Problem solving

  • When the TV set is failing to activate the ARC of the sound system then it is not sufficient to power off (i.e. plug the power cords) of the TV set, the Vero 4k and the sound system and to wait for 20 seconds. The problem is still present after truing on / booting the devices
  • To be able to activate the sound system I have to plug-out the HDMI of the Vero 4k and to reboot the TV and the sound system.

I really would appreciate help. Currently, I cannot use my Vero 4k; it is just sitting next to my TV and is neither connected to a power socket or my TV, which is a bit of a waste of such a nice peace of hard/software.

Please advice on logs etc.

Best, Markus

Hi, had some CEC and ARC related issue with my setup as well, you’re welcomed to try the beta fix provided by @sam_nazarko if you’re confident enough.

ARC should only really present problems if something is turned off. If everything is on, then things should be working well.

Thanks Sam.

I’m not sure that I can follow. My problem is that when turning on the TV the TV cannot activate the sound system, meaning, that it uses it speakers and not the sound system as the output device. The other frequent problem is that when changing source e.g. from ordinary TV to Vero 4k then there is no sound at all. My guess is that this is also related to the issue that some CEC functionality does not work either, since the sound system does not go into stand by after turning off the TV.

Cheers, Markus

I’m not sure that CEC would be the culprit here but you could try the above

Thanks Sam.

I did have the time to try jaybird’s suggestion yet.

Today I turned my Vero 4k on and checked /etc/apt/sources.list on my Vero 4k and the line deb http://apt.osmc.tv stretch-devel main was already on the list.

I guess this means that I already have installed the beta fix as suggested by jaybird, right? (since I have installed all updates prompted in OSMC.)

Anything else I can try? (The current situation is that I’m not using my Vero 4k any longer due to the ARC problems. My Vero 4k is just sitting next to my TV powered off, which is a real bummer)

Best, Markus

Have you tried the Vero connected to one of the non-ARC HDMI connections? ARC is for a device that sends and receives audio. The Vero will only send and that may be confusing the TV.

Sorry, my mistake: all HDMI connections support ARC. The configuration is as follows:
• HDMI 1: ARC, MHL, Ultra HD, HDR
• HDMI 2: ARC, Ultra HD, HDR
• HDMI 3: ARC
• HDMI 4: ARC

The Vero 4k is currently connected to HDMI 2 but I also have tried HDMI 1.
FireStick 4k ==> HDMI 1
Vero 4k ==> HDMI 2
Nintendo WII ==> HDMI 3
Soundsystem ==> HDMI 4

Best, Markus