Vero 4K no blue light, restaring randomly, sometimes in restart loop

We have been on a trip for 1 month and I left Vero 4K running idle. When we came back yesterday, I could not get the picture to show. When I restart it, it lights red led for less than a second then there is no led shining and no signal on HDMI. Does the led suppose to shine blue while operating properly? I do not remember.

When I connect another device to the same cable HDMI cable, the picture is shown properly.

Any ideas what the problem might be?


This depends whether you have a Vero 4K or 4K+ model

I have Vero 4K (without plus).

Then there should be a blue LED when the device is in operation. You could try another power supply.

Tried 3 different power supplies, and still the same result.

Sorry, got it working again. I mean I got the picture back but no blue led. Strange. Well, it works again. If I get into trouble, I will post back. Thanks!

Naaah, not really. Now it is restarting on its own. It happens sometimes once in half an hour, but sometimes it is in a constant restart loop. I did the factory reset but it restarted again:

the logs:

btw, even after the reset, there is still no blue led shining.

looks a bit like it is overheating but I have managed to watch a movie for 20 min before it restarted at some point, so it is not obvious what causing the restarts.

What power supply you are using?

I have replaced the original power supply with the one that is 5V 2.4A and I also tried a couple of phone chargers.

video preview, the cable is the USB-A > round jack that I originally created when I replaced the original power supply.

I also have a A-A cable that I tried to use with the USB port as well. The very first time I connect it, the led shows red for less than a second, then a blue color led flashed shortly for 2 really short times. Then, when I disconnect it and connect again, I get again short red let but this time no short blue led. If I wait for some minutes, the red and short 2 blue flashes come back, but I never get the constant blue led as it used to be if I remember correctly with this Vero 4K.

So, as a result, I tested both the cable I used to have USB > Power and USB A-A > USB port with the same result > red led, then blank.

BTW, I tried the power supplies with RPi 3 with OSMC installed and it works OK.

If you try a USB cable in the white USB port, does it show up in Device Manager?


The cable that I have is USB-A Male > MicroUSB Female > MicroUSB Male > USB-A Male

When I connect Vero 4K white USB port to the Windows computer with this cable, there is no indication that a device was found, no sound or anything. The Device Manager does not show anything new in the list.

I can start it and SSH to it. However, there is no blue light as it used to be and I think if I put it on a long run to show a movie it will restart. I will test it tomorrow to see the behavior and if it will restart or go into the restart loop.

Any idea why the blue led is not showing anymore?

Is there anything specific I could run via SSH to test something?

Here are the logs before I did Vero 4K reset and experienced restarts, if it helps:

the one in the earlier post was after I did the reset and had a restart.


I connected it back in the morning and added IPTV playlist and while it was iterating the channels, it restarted, then after the restart, it showed the sad face, then restart, then when I was trying to upload the logs, it restarted again, and then I was able to get the log:

Then it restarted one more time without the sad face, so it is not like the full restart but more like only KODI restart. However there is still no blue led that I am used to.

btw, if I put it on standby then the red led will be on just like expected.

Ok, it has been working for 25 minutes and then it restarted again. So, the restarts happen regardless of what I am doing, watching something from NAS/Samba, or IPTV, or uploading the logs.

I am going back to RPi with OSMC for now.


Sorry for the delay in getting back to you. I have limited access to a computer at the moment and when I do it can be hard to keep track of things.

As soon as you mention IPTV, my instant suspicion will be OOM due to a large number of channels and in turn EPG.

Can you try with this add-on disabled?
How many channels in your M3U playlist?


Thanks for the reply.
I had quite a few channels on the IPTV list, somewhere around 200, I believe. It was searching for the channel icons on startup as well.
I disabled IPTV plugin and played 3 movies from NAS in a row (around 5 hours) without a glitch. I will use it for a couple if weeks and get back if I get any problems or if it goes okay.

Btw, I have got a strange blue LED behavior, it was quite bright for a couple of minutes, in the beginning; then started trembling, then faded, and then went off. Feels like a dying battery or a capacitor. What could be the cause of it?



An update. I narrowed down the IPTV playlist to 20 channels and so far the combination of IPTV and streaming from NAS worked pretty well. Besides having a strange behavior of the blue LED, it seems to be okay for now. I will post back if this changes.