Vero 4K + no longer visible on local network

That is odd. I don’t have my machine handy to test.
Can try sudo smbpasswd osmc see if that works.

This is really weird. I used sudo smbpasswd osmcand it outputted:

New SMB password:
Retype new SMB password:

So, I figured everything went ok. But, now I can’t access my Vero over Samba by using osmc as the password or by using my new password. I’ve double checked to make sure it is typed correctly too. It was working perfectly with osmc as the password. Total head scratcher.

Are you trying to access from Win 10?

Also you can try on the Vero itself with:
smbclient -L localhost -U osmc
You should be asked for your password, check if it is correct.

Sorry for the slow response, there is a limit on how often I can post because I am a new member.

It seems to be working again now after a reboot. I inputted smbclient -L localhost -U osmc followed by my password at the command and OSMC started up. I’m now able to access my files again using my wireless devices and the new password.

Thanks again for all your help, very much appreciated.

1 Like

Hi again guys, one more question if you don’t mind.

Everything is working fine again and I can access all my files on my hard drives attached to my Vero from all my devices. The only thing that is different now is that I can no longer edit files stored locally on the Vero itself from my devices . Previously I could copy files to it from Windows Explorer or any of my file management apps on my tablets/phones, but now I’m getting ‘access denied’ errors. Is there any way to give permission to modify the files/folders on the Vero for other devices?

I also get the same errors when I log into OSMC using WinSCP. I can see and access the files, but cannot modify anything in any part of the OSMC directory. I have no issues modifying any files on the external hard drives attached to the Vero however.

Thanks in advance!

You mean in your /home/osmc/ folder?
Maybe you have changed permissions?
What is the output of ls -lah /home/osmc/ or the specific directory that you are trying to write to.

Yes, the /home/osmc/ folder is the one I mean. Ideally I’d like to be able to edit any file or folder in that entire directory using Windows Explorer. At the moment when I try to copy files to any location in /home/osmc/, it says ‘you need permission to perform this action’. It’s the same result for other devices too, so not just limited to Windows.

Here is the output of ls -la /home/osmc/

total 576K
drwxr-xr-x 13 osmc osmc 4.0K Apr 10 18:07  .
drwxr-xr-x  3 root root 4.0K Jan  1  2015  ..
-rw-------  1 osmc osmc 5.9K Apr 10 19:52  .bash_history
-rw-r--r--  1 osmc osmc  220 May 15  2017  .bash_logout
-rw-r--r--  1 osmc osmc 3.5K May 15  2017  .bashrc
drwxr-xr-x  3 osmc osmc 4.0K Sep 10  2018  .cache
drwxr-xr-x  2 osmc osmc 4.0K Sep 19  2018  .dvdcss
drwx------  3 osmc osmc 4.0K Nov  1 18:41  .gnupg
drwxr-xr-x  8 osmc osmc 4.0K Sep 10  2018  .kodi
drwxr-xr-x  3 osmc osmc 4.0K Nov  1 18:58  .local
-rw-r--r--  1 osmc osmc  675 May 15  2017  .profile
drwxr-xr-x  2 osmc osmc 4.0K Aug  5  2018  Movies
drwxr-xr-x  2 osmc osmc 4.0K Aug  5  2018  Music
drwxr-xr-x  2 osmc osmc 4.0K Aug  5  2018  Pictures
drwxr-xr-x  2 osmc osmc 4.0K Aug  5  2018 'TV Shows'

Thanks again pal!

That looks ok, so you say even with WinSCP you can not write a file to /home/osmc/?

Sorry, I think I made a mistake with WinSCP because it was late last night and my brain was a bit fuzzy. I may have been accidentally trying to copy a file to somewhere else instead of /home/osmc/ without realising. That would probably explain the permission errors in WinSCP, because I just tried it again and I can move and edit files in /home/osmc/ without issue, while the root directory is write protected.

So, the only thing I can’t figure out is why I can’t do it from Windows Explorer or any of my file management apps on my phones/tablets anymore? They are giving permission errors as though /home/osmc/ is somehow write protected. I’m using samba for these by the way.

As far as I remember samba server should give the same permissions as ssh. But would need to check on my system.

Could you show the files


or upload them using paste-logcommand and present the returned urls, here? Thx.

Here is smb.conf.

There doesn’t seem to be an smb-shares.conf file in the directory though. I’m guessing that is not good!

Ok looks that our rescue effort didn’t resulted in the correct OSMC smb.conf being written.
Can you with nano /etc/samba/smb.conf enter the one I shared before (delete the current content first).

1 Like

Ok pal, the new smb.conf seems to have done the trick after a reboot. I can edit the files in /home/osmc/ from Windows Explorer and my phones/tablets again now. Top class once more. Thanks so much!

Great to hear, one of the reinstall step might have gone wrong.
But good that you are back up running fine.