Vero 4K+ non responsive at large shared drive

Hi, I installed some NFS-shared drives and files play fine finally.
But now whenever I open up the biggest shared drive, +/-3.5 TB (462 movies), the player becomes unresponsive for almost 1 minute every time.
Okay, initially I understand it has to load all the pics etc. from the database, but whatever other action is done, even pushing Stop on the remote when playing a file, it becomes unresponsive for a very long time.
Is this normal behavior? Or is there a max on the amount of movies in a folder?
By the way, I’m using the Wifi 5G connection, because LAN is not functioning.

Have you scraped all the movies into the database? If you are just using the file system it will take a long time to read each folder.

If you reboot twice, turn on debug logging, reproduce this behavior, and then upload logs and share the link this may allow us to gain some insight into what is going on.

I’ve never tried sticking hundreds of moves in a single folder and tried browsing it in file mode but I have several thousand movies in my Library and access there is instant.

Hi, every movie is in its own folder. So, 463 movies in 463 folders.

I uploaded the log files:

Thanks for your response and help!

I’m not 100% on this but I think what is going on is that when your entering that folder it is trying to gather info on some of the items and it is hitting network errors opening some files due to what I assume is either corruption or errors stemming from earlier attempts from getting this going. I think the most prudent course would, now that you have your file share sorted, start with a fresh Kodi setup so you are ensured that your not chasing your tail fixing effects of the repeated setup attempts. To effect this you can do the following…

Enter the following commands with an SSH connection to permanently delete all your current Kodi userdata and replace it with defaults.

systemctl stop mediacenter
rm -r ~/.kodi
systemctl start mediacenter

On a side note, completely unrelated to all previously discussed topics, you should enable refresh rate switching in your player settings.

Hi DarwinDesign,

It gives a connection refused error. iP address of the Osmc player is

Windows PowerShell
PS C:\Users\De_Haantjes> ssh osmc@
ssh: connect to host port 22: Connection refused
PS C:\Users\De_Haantjes>

Tried Putty as well, same error.

If you go to the App Store in the My OSMC add-on is the SSH server installed?

Yes, the SSH server is installed.

Figuring out why your box is refusing to open the ssh port is a bit outside of my wheelhouse. Normally it just works. Unless one of the other people around here are available to help you figure that out I could only suggest to just do a full reinstall. There is a download link at the top of this site where you can find an installer for your PC to make the media you will need.

That figures, nothing works out of the box with my specimen.

But thanks anyway for your help.


Please could you attached a keyboard? (Please see the “Logging in locally” section from the link provided by @darwindesign).

Then please could you provided the output of:

systemctl status sshd

Thanks Tom.

While he is there I suppose he could just delete the Kodi userdata directly without using SSH. I kind of overlooked that obvious path. :man_facepalming:

1 Like

Will try tomorrow evening, it’s late and I have a day job :smiley: Thanks for the fast response, but I never thought I needed this indepth knowledge to get a media player up and running. Spending more hours getting it to work properly than watching movies unfortunately.

Hi Tom,

I could login, then gave the command systemctl status sshd and the resonse was: Unit sshd.service could not be found

That’s all.


Please try uninstalling and reinstalling ssh, via the MyOSMC store. If that doesn’t work I would consider a reinstall of osmc and restore config from a backup.

Thanks Tom.

Hi Tom,

I started MyOsmc and the ssh server suddenly stopped for some reason. Did the procedure again and now it gave some results. I am sorry it is a picture, because I use a beamer.


Please try connecting via SSH again.

Thanks Tom.

I just did start up ssh service again. Opened the moviefolder and it took again almost a minute. Stopped the movie playing, non responsive again for almost a minute. Same problem still.
Then checked if SSH server was sill running in Myosmc and it is running.

Now what? Reinstall everything? I am not really in favor of that, becayse it takes hours to setup everything again.


Are you able to ssh before trying to open the movie folder?

If so have you tried running the commands suggested by @darwindesign?

Thanks Tom.

What exactly are you trying to preserve. I can give instructions on how to do a bit more of a surgical removal of just parts. There has been quite a bit of configuring and reconfiguring of your setup and so starting clean is the expeditious path to prevent inclusion of cruff from this process.

There also exists the option to make a backup of your current setup either with the backup function in the My OSMC add-on or by installing the “backup” add-on from Kodi’s repository. Either can selectively restore just parts of your userdata. These various files are described in the following wiki…

The main thing I think you would want to get rid of is just the video database and passwords file.