Vero 4k not booting, red cross

Hi guys,

I have had my Vero 4K since 2017, mostly without any issues (And if there was any, it was usually my own fault :wink: ) but now I am unsure if it has finally died on me or that it can still be saved somehow.

I have been running the Linux 4.9 test kernel for some time without issues, and I doubt it’s the issue here… This morning, the Vero was showing a red light, and replugging it from the power did not help there either. I have tried to do a reinstall from a USB stick and this also did not seem to have any effect either.

Are there more things I could try to see if it can be saved?

You should test with another power supply if you have one around. For testing purposes, you can also test by supplying power via the USB port if you don’t have a supply with the proper specs and the barrel connector, but this would require a USB-A to USB-A cable.

I tried it with one I had laying around, but it had a similar effect and it’s not booting up unfortunately.

So no picture at all on the screen?
May want to try the USB A-A cable method.

Nope, nothing :frowning: And I don’t have one of those cables unfortunately.

Can you show us a photo of this other power supply?

Looks like this:


Wondering if anyone else had any ideas?

Also if it really turns out to be broken, I will need to get some sort a replacement, I suppose the Vero 4K+ is now the new cool kid on the block when it comes to running Kodi on a simple device?


We can take a look at it, but there’s no guarantee we can repair it.

Send an email to so we can discuss this


Thanks! I have sent in an e-mail!