Vero 4k not updating

My current version is 2020.11-1

Noticed I’ve not had any updates recently, so tried a manual update…

Getting “Connectivity issue while checking for update”

So set to debug mode, rebooted and tried again, then uploaded the log:

I have tried wired and wirless connection, and both work fine with BBCiplayer, so no actually connection problems.

Thanks for any help


Thank you, all updated now!

Slight snag now,

The “get more skins” option is now missing from skin menu.

I use to use Bello7 but that was disabled aftre kodi 19 update, but cant get Bello8.

Can install Bello 8 with windows/kodi on my pc.

So is this general OSMC problem, or just my Vero4K not updated properly??

There were some issues with the update server earlier. This should now be solved.

The Kodi repository was almost empty, all good now after it finally managed to get updated.

Tried in my case right now and still getting exactly the same error from original post: Connectivity issue while checking for update…

In my case I am using 2020.11-1 on Pi 3.

1 Like

Did you run the hotfix?

1 Like

No, I didn’t. I read again the full thread carefully and found that info. Thanks.

Update. Hotfix fixed the update process. Thanks!

I had the same issue, and still unresolved. Occurred after not using the device for a year and connecting today.

Applied the hotfix and now no longer see the connectivity error when updating. However, my Vero 4K+ does not actually update: the “Update Available” logo remains on home screen and the My OSMC page reports 2020.11-1.

Also, network connectivity is problematic. It hangs when accessing a directory that used to work.

Can you login the Vero with SSH?


Then try

sudo apt update
sudo apt dist-upgrade

And share any output if it doesn’t update

sudo apt update - ran ok
sudo apt dist-upgrade - has been hung at 67% for over 30mins. Last three lines of output below.

Setting up mariadb-common (1:10.3.34-0+deb10u1) …
Setting up wpasupplicant (2:2.7+git20190128+0c1e29f-6+deb10u3) …

Progress: [ 67%] [######################################…]

Thats a bit odd, suggest open a second ssh session and check with top or htop what is keeping the Vero busy.

The attempt to ssh from a second terminal times out.

Ok, yeah actually the update of WPA supplicant killed your Wifi.
Doing the upgrade using screen is a bit safer.

Anyway just unplug and replug the Vero you should hopefully be back in.

The updates were successful. I clearly have network access because it was able to update. However, the system hangs when I try to access any of my folders. And even when I attempt to browse NFS.

Are your sure all packages have been upgraded? Did Kodi after the restart did a database migration (will be visible on screen for a couple of minutes).

Maybe try update again from MyOSMC and/or share some logs.