VERO 4K+ november update and Pioneer receiver no friends anymore

Did an upgrade to November update anymore, when it boots I see network connection for a short moment, then it drops. No display, no network connection, nothing. Booting without HDMI to my Pioneer receiver (SC-LX59) and it boots normally and can SSH into the device. When I connect HDMI directly to my LG, also no issues. The moment I connect the VERO to the Pioneer network drops, no display as well.

Reset the VERO, no solution. Downgraded it to [2021.08-1] image. All works fine. Upgrade to November, issue is back. Tried to get additional logging, but not much showing for what I can see.
Any suggestions on how to debug this?

Check this post

Tried this one as well without any luck.

My setup is similar: Raspberry Pi / Pioneer AVR / Sony TV. I had a black screen issue after update to 2021-11. I’m optimistic to have fixed it by setting config_hdmi_boost=4 within the /boot/config-user.txt. Don’t know if that also applies to a Vero.

This is completely different hardware and unrelated.

Can you attach it after booting and run grab-logs -A?

The moment that I attach my HDMI cable with an active connection to my receiver it just crashes.
What I have done now is power on without cable, attached the cable, let it crash, disconnect HDMI cable, disconnect power cable, reconnect power cable and then grab of the logs.
Lets hope that the logs contain what you need.

Unfortunately that won’t provide persistent logging. I’ll see if I can fix the forcing of HDMI parameters and with any luck the issue is related to your issue.

1 Like

If it could help I can downgrade the Vero again and post the log of a successful connection with the Pioneer receiver?

better if you could ssh in run dmesg -w while you plug in the HDMI cable. You might just get some messages to screen-grab.

I did this with both august and november release : Microsoft OneDrive - Access files anywhere. Create docs with free Office Online.


We are on the case.

Can you confirm if vero boots if the LG is disconnected from the Pioneer?

Looks like you are on a right track. As long as the LG Is disconnected from the Pioneer it works fine. The moment I attach the HDMI between the receiver and the LG it crashes again.

1 Like

Are you on the latest firmware ( 1-329-011-733-206? One of the devs has the SC-LX89 and has no problems.

I had the 324 version, upgraded to 329 but the same issues. Disabled CEC adapter (as the Pioneer is terrible with that anyway), but all the same issues.

Your AVR is not passing through properly the capability of the TV to play 4k50/60hz video. That’s confusing the EDID parser. Do you have the option ‘HDMI 4k/60p input setting’ enabled? If not, can you engage that and see if that helps. (page 92 of the LX89 manual)

The option for 4:2:0 was used, but also on 4:4:4 still the same issue. How does this all became with the upgrade to November?

TBH we don’t know yet. We made some changes to the video modes that are set on booting. But that shouldn’t mean a crash and our colleague’s LX89 is working fine with almost exactly the same EDID. :thinking:

1 Like