Vero 4K+/OSMC not playing my 4K HDR

Got my Vero 4K+ a couple weeks ago, and I guess I’ve only watched 1080p content so far. I just tried to fire up a 4K/HDR movie, it said ‘buffering’ (for a second as it loaded), appeared to start playing, but wasn’t showing me any video or outputting any sound. Tried a 1080p ISO, no problem, tried another random 4K/HDR file, same deal, won’t play it.

Read a couple threads here, made sure all my settings align with what is recommended, still the same thing. Tried 422 even though I’ve never had to set that with my U9-H or the NUC I was using briefly - still didn’t solve anything.

Logs -
MediaInfo -
MediaInfo for the other one doing the same thing (which I have watched successfully with a U9-H and CoreELEC via the same receiver/television/NAS/network) -

Screenshot from when the issue is occurring -

(The circled area is counting up as though the file is playing)

Not how I wanted to spend my Friday night :frowning:

As a first check I suggest to check your network speed (also as you are using WiFi do you have a 5Ghz network and are you using different SSID for 2.4 and 5 GHZ?)

osmc@osmc:~$ iperf -c -p 5050
Client connecting to, TCP port 5050
TCP window size: 85.0 KByte (default)
[  3] local port 54304 connected with port 5050
[ ID] Interval       Transfer     Bandwidth
[  3]  0.0-10.0 sec   275 MBytes   230 Mbits/sec
osmc@osmc:~$ iperf -s
Server listening on TCP port 5001
TCP window size: 85.3 KByte (default)
[  4] local port 5001 connected with port 51500
[ ID] Interval       Transfer     Bandwidth
[  4]  0.0-10.1 sec   250 MBytes   208 Mbits/sec

This is not a new setup. The Vero 4K+ is a drop-in replacement for a U9-H that was running CoreELEC, and everything worked flawlessly with that setup. I wanted frame-packed 3D though so I switched to a Vero and gave the U9-H to my son.

Is this a fresh setup, or did you restore the Kodi directory from another system (this could cause problems)

Something crashes the decoder, although it’s not clear what.

[ 75.316919] [0]H265 dec err local reset.

My recommendations would be:

  • Play the file back locally and see if this is an issue
  • If not, a small sample that reproduces the problem would be useful.

As you plan to watch 3D content, you’ll need the 4.9 build anyway, so updating to that may alleviate the issue.


Only copied my sources.xml and advancedsettings.xml (pointer to MySQL server) to save me from typing them out again.

Plays back without issue on my Windows laptop w/ MPC-HC. The other file that is causing the same issue I have watched in full on a U9-H w/ CoreELEC.

I have a 1m sample ready to upload! Just say where! :slight_smile:

I would be more than happy to try. I was poking around trying to see if I could download a nightly or beta from somewhere or build one from Git but couldn’t find anything that said “This is the 3D stuff, install this!” :smiley:

Full disclosure: I’ve got a USB DAC hooked up to this box and squeezelite running in the background 24/7. I can’t imagine that would cause any problems, but it seems worth mentioning. My output device is set to HDMI and I passthrough everything.

You can upload it to

Hrm, I uploaded it, but it didn’t give me a URL or anything.

With “locally” @sam_nazarko meant to play it without the network in between (e.g. USB Stick) on the Vero.

Steps are explained here:

After you have Kernel 4.9 installed you can do your tests but if you want to have 3D you would need to downgrade the mediacenter

We have the file. Will check it out.

Ah! Ok, copied it over to a USB drive, and just gave it a go … exact same thing … ‘Buffering’ for 1-2 seconds while it loads, then the OSMC logo dancing in the middle of the screen while the timer counts up in the background as though it is playing.

TY for the upgrade instructions, I’ll get started on that right now.

Doesn’t harm to upgrade. But might not solve your issue. So might have to wait till the team has time to analyse your sample.

Oh there wasn’t much to that at all, was there? lol

Kernel upgrade did the trick! It is playing fine now locally and from the NAS! ty both!!

I’ll do the mediacenter downgrade next, and I should be golden! :slight_smile:

<3 <3 <3

and now 3D is working! Thank you! I am a VERY happy camper now :slight_smile:

1 Like

Glad to hear. We couldn’t play the sample you sent us at all - but that may be because of how you created it.

Oh that’s interesting … it’s doing the same thing to me on 4.9 as everything was doing on 3.14. I, didn’t actually make the sample … taps his nose … very odd.

I thought you said it plays on 4.9 now?

Or do you just mean the sample is problematic?

Just the sample oddly!