Vero 4k+ - Pairing problem with my Logitech Harmony Elite

I have the problem that every time i start my Vero 4k+ the pairing to my Logitech Harmony Elite is lost - i have to sop/start the bluetooh service and start/stop the discovery - then the Harmony is back again under Paired Devices… not sure if this probem occured since the last OSMC Update - all my other devices works well with the Harmony, so this problem must be Vero related… i have no idea what i can do to solve this…


When did this start happening?
I would recommend unpairing the remote and then re-pairing it in My OSMC.

Not sure, think it comes with the last update… do an unpairing and re-pairing later this day, thanks!

It seems that re-pairing solved the issue - will test this the next few days…

@sam_nazarko… the problem occurs again… start/stop the discovery doesn´t work - i have to disable and enable Bluetooth and then start the discovery to find the Harmony again… any ideas?


Would need some logs to advise.


This happened to mine on Friday, it had been working fine for 2+ years. I too had to disable/enable bluetooth on the Vero to re-connect. I’ve not tried to see if it’s lost again on reboot, will do that today.

Yeah mine is same, I lose the bluetooth pairing on reboot. Here’s a debug log, when I enabled debugging and rebooted I did see a BT error on screen before turning off, weirdly though, the pairing seems to work when rebooting with debug on.

At the moment it works after disable and enable bluetooth yesterday so i think the problem occurs after some time again or so… i will collect the logs when the connection to my harmony is lost again…

@MikeDelta does yours lose pairing after reboot only? Mine seems to be fine as long as I don’t reboot

Yes… but not on every reboot… in the last 6 days the problem doesn´t occured again…

1 Like

Just noticed this thread, seems to be the same issue

I doubt it. The issue was fixed some time ago. Make sure you’re on the latest version.

I thought I was, March 2020-03.1. Went to manually update and there was an update, which I applied, but still showing the same version number, is that correct?

Yes as only the kernel was updated to fix this problem.
Is it now working for you?

Yeah, seemed to be fine after the install reboot, cheers :+1: