Vero 4k power supply problems


#1

Hi

I’ve been using my Vero 4k since launch and absolutely love the device. It forms the centre of my av system now and is used every day.

I’ve recently found my broadband speed dropped to a quarter of my normal speed (from 40Mbps to 10Mbps DL).

My ISP quickly reported that Openreach had monitored a REIN (electrical interference) problem in my property for the last few weeks, so the DLM is likely to have dropped my speeds over that period but we only noticed when it got down to 10Mbps.

My ISP has also been really helpful in helping me identify the source of the problem and I’m sorry to say that it appears to be the Vero 4k’s power supply.

I’ve done some investigation using an AM radio and found that I get terrible intereference if the Vero 4k’s power supply is plugged into my power socket and it gets way worse when the power supply is connected to the Vero 4k itself.

It’s taken me a couple of weeks to narrow it down to this being the source of the problem, as it’s not an exact science, but it’s the only device in the whole house that when I unplug it, I get no interference on the AM radio.

I’m guessing it’s just worn out quicker than normal or was faulty to begin with.

As per this thread: Vero 1 Power Supply problem I’ve checked the things Sam listed. i.e. I’ve tried it without my surge protector and plugged it straight into the wall. It immediately makes a loud buzzing noise on the AM radio which stops shortly after unplugging (guessing there’s some discharge involved). I also haven’t dropped the power supply. It’s just been plugged in since I got it.

Please can you advise if the warranty on the Vero 4k includes replacing the power supply and how I can get hold of a replacement?

Cheers

Simon


Serious issue: Enormous interference from Vero4K PSU
#2

Hi Simon,

I’m sorry to hear the power supply is giving you problems. That’s certainly not typical.

The warranty includes all components, with exception of the battery in the remote, as it’s a consumable.

A loose coil or damage to the PSU can produce the kind of problem you have described. If you give me your order #, I can send you a replacement in Tuesday’s post after the Bank Holiday.

Sam


#3

Thanks Sam.

My order number is: #4889

Cheers

Simon


#4

I just recieved my Vero4K, easy setup, but the power cord is very short. I had to reconfigure entire room layout to get it plugged in. Are there any extensions for this power cable or longer versions?


#5

We will get that out for you first thing Tuesday morning.

A good 5V, 2A PSU will do the job. We don’t have longer ones, but I would be happy to help you source one.


Vero 4K Power adapter specifications
Full specifications?
#6

Ok that would be fine, thx


#7

Great - thanks again Sam.

Simon


#8

Hi Sam

Just wanted to say I received my replacement power supply yesterday and all’s well. Thanks again!

Si


#9

Hi Simon,

I’m glad to hear that. Thanks for letting me know all is well, and I do apologise that you were unfortunate enough to receive a bad PSU to start with. If there’s anything we can do in the future, give us a shout.

Sam


#11

Hi,

I have been using my Vero 4k for few weeks now and it seems that the power supply is faulty.
When I was using a USB charger integrated onto a 2 gang socket, it was working ok. Unfortunately, my USB charger failed yesterday and so I needed to use the PSU provided in the box. However, I noticed that when the Vero is powered up using the power supply provided there is a constant noise coming from the analog audio output. I tested with a spare power supply I had, the Vero 4k worked ok noiselessly.
My order number is #6204.

Thanks,
PF


#12

Can you confirm if the issue is still present when the power supply is plugged directly in the wall? As per the manual we don’t recommend using wallgang sockets or extension leads. You’d be surprised how many issues they have caused.

You should only ever use the official PSU.

We can send you a new PSU after we start shipping orders again in a couple of weeks.

Sam


#13

Hi Sam,

Yes, the issue still happens when the power supply is plugged directly in the wall.
Thanks,
PF


#14

Okay – we will get a new one out for you shortly


#15

A replacement power supply has now been sent.

Apologies for the delays – we took a break from orders.

Sam


#16

I know this comment won’t help, but in the thread i created i was complaining about a possible interference coming from the PSU.
I had to buy strong & shielded HDMI cables to get rid of this issue.

(SOLVED) When Vero 4K HDMI is plugged in the Soundbar NO ARC sound when switching source to TV)


#17

Could you provide a technical explanation as to why an extension lead can cause problems. The current at 240V is minuscule!