Vero 4K Remote control going through batteries FAST

I’ve got two just under 3 year old Vero 4Ks. Everything has been going ok. It’s often a little slow loading up menus, but that’s a different issue I haven’t investigated further at this time. One is used a lot more than the other due to the room it is in.

The CR2032 battery in the remote of the one that is used more used to last a length of time that seemed perfectly fine. Long enough that I didn’t even question it.

Now though it is ridiculously short. It is maybe a week at most these days. I had thought it was because I was buying cheap batteries, however I’ve always bought cheap batteries and it used to be fine with them. So I bought some expensive ones to check, and it lasted maybe 10 days with it, if that. So something is up with the remote that is causing it to drain the batteries very quickly.

So queries are: 1) is the remote still under warranty?
2) Is there likely to be a software/firmware fix to this issue with the remote or is it hardware? Any way of identifying which it is?
3) Any ideas on what I can try to fix it?

Thanks.

Edit in: Just remembered I have a multimeter, and if I was using it correctly, the battery that apparently just died in the remote is still showing 2.8V. If I put a brand new battery in the remote works, but if I put this “used” cell in, it does not.

Have you tried re-pairing the remote?

Usually rapid battery drain is caused by congestion on 2.4Ghz bands. By re-pairing, the remote will negotiate on the best possible channel. This is not a guarantee that there will be a congestion free channel however.

It would also be good to know about your environment. Did anything change recently, like a new router or some new hardware introduced close to the device? The best way of ruling out an issue with the remote specifically would be to swap the remote and dongle with another remote and dongle in a room that isn’t experiencing issues. If the newly introduced remote and dongle then experience issues, it’s likely environmental.

If your devices are three years old, they won’t be covered by a warranty, but from the fact that they’re working, I suspect that the issue is not hardware related.

Cheers

Sam

Thanks for the tips.

I will try repairing the remote and if that doesn’t change anything, I will then try the remote from my other Vero to see what happens with it.

No hardware changes in the vicinity of the Vero box recently.

To confirm, the remote repair is as follows:

" * Remove the USB from Vero 4K / Pi

  • Hold Home and OK button for 5 seconds or so, then the blue LED will keep flashing.
  • Plug in the USB receiver and the LED should flash 3 times after 5 seconds, indicating successful pairing.
  • Power off Vero 4K / Pi for 2 minutes. Turn it back on. The remote should now work."

Yes, those are the correct instructions

Sam

Put the new battery in and re-paired last week, and the battery failed today.

So doesn’t appear to be a pairing issue.

Will try the other remote later.

Just an idea: Use rubber gloves the next time you change the battery to avoid a short circuit due to the moisture on the skin.

Ok, I’ve been using my other remote with its usb dongle now for the past 3 weeks or so and it still works. It wasn’t even a fresh battery in it.

So it would seem like there is some issue with either the usb part, the remote part, or the connection between the two.

Any ideas on what I should try next?

Is this also an OSMC remote? Are they within close proximity?
If only one remote is affected, then I’d mark both of them with something like a post-it note and pair the problematic remote with the known working dongle to see if this improves things.

Sam, yes it is my other osmc remote, from my other Vero 4k I have in another room. They aren’t really in close proximity. One is in a room on the left side of the house, the other is in a room on the right side of the house in a side extension through an old external wall. The two rooms aren’t side by side, the hallway and stairs are between the two.

Will try pairing the problematic remote with the other dongle, and depending on how that goes, also the seemingly ok remote with the maybe problematic dongle!

Will report back in a few weeks once I’ve had a chance to test the variations!

Thanks.

1 Like

Only posting as a reminder for myself that i have now paired the remote I’m having issues with, with the dongle that worked fine with the other remote. I’ll post again if it fails quickly.

Ok, with a fresh battery in the original remote then was paired with the other dongle, has just died.

So 4 days ish use.

So it does seem like it is the remote at fault as it has died so quickly with two different dongles now.

Any other suggestions or potential fixes?

Unfortunately when this occurs the issue is usually environmental and is caused by some interference. Is it possible to use only one remote in that house for a while?

Alternatively, I’m wondering if there’s some kind of a short near the battery connector in the remote.

One osmc remote, or one remote in total for all devices?

The other osmc remote was not plugged in to the other Vero during this, and the battery was out of it.

If it was interference, then why would my other remote have worked fine in the same environment, in the same circumstances with the same dongle?

I’ll see if I can see anything that could be shorting the battery, but acknowledge I probably don’t know all of what I could be looking for!

Here’s an idea: remove the battery from good and bad remote, have a look at the battery contacts on both. Do they look different?

They look the same as far as I can see. Nothing evident at all.

Unfortunately I am not sure what the issue could then be, particularly if the remote has been functioning correctly for three years or so. Usually hardware problems would present themselves quite early on during the operation of the device.

The only other thing I could possibly think of would be some kind of obstruction which is causing a button to be permanently pressed – but this would be obvious from a solid / near solid blue light on the front of the remote.

Definitely not a stuck button as other inputs work fine and no blue light on.

Oh well, being all out of ideas then, I guess this remote will be consigned to the box of spare cables and stuff I’ve got in storage that I keep “just in case”.

Sorry that I can’t provide a better answer to this query.

Sam