Vero 4k+ Remote not working (again)

I tried to use my Vero4k+ again after not using it for a while, but I cant get the Vero to respond to the Vero remote. The remote was a bit flakey in the past, (solved by moving the Vero to a different area of my AV shelf) but now it refuse to respond at all.
Things I’ve tried -

  • Rebooting
  • Changing the battery on the remote
  • Changing the USB port used by the receiver
  • Re-pairing the remote (remove receiver, hold Home and OK for 5 seconds, reattach receiver, power off for 2 minutes, restart)
  • Moving the Vero to a different location in the room.
  • Moving the Vero to a completely different room and TV

Still nothing.
Do I have a faulty receiver? The blue light on the remote flashes when I hit buttons, but the Vero doesn’t see the button presses. Using HDMI control is fine, but I would really like to use the original remote supplied with the unit.

Any ideas?

Please post some logs,



I’ll try. While HDMI control on my TV (LG OLED65B9) sometimes works, its a PITA to use to navigate the Vero. 9 times out of 10 hitting any navigation keys just brings up a banner from the TV OS. Really struggling to anything on the Vero without the remote. I’ll keep trying.

Yes, it is not showing up. I would recommend emailing with a link to this thread, your original order number, and inquire about availability of a replacement dongle.

Thanks. I’ve opened a support ticket.

1 Like

I suggests two further fast tests:

  1. You can also plug in the dongle into a Windows 10 system and check whether it’s connecting there and do some basic tests, see Pairing the Original Black OSMC RF Remote Control with a Pi/Vero2/4k/4k+. This should prove if the dongle is broken.

  2. Also helpful information: If you insert a USB stick/pendrive into each of the Vero’s USB ports, does the “new media detected” menu pops up in the mediacenter? This shows that both ports are working as expected. Of course the file system on the stick should be one of the common types like FAT, FAT32, NTFS, ext3/4 or exFAT.

Thanks for the reply Jim.

My Windows 11 PC doesn’t recognise the dongle, although I get the connect jingle followed by an immediate disconnect beep. Nothing new appears in device manager.

I can do the pairing procedure on the Vero as linked, up to the point where I get the 3 flashes to indicate successful pairing, but the Vero doesn’t respond to any key presses after that.

Both USB ports on the Vero recognise removable drives when inserted.

1 Like

Thx, this is a very helpful information for @sam_nazarko .

Emailing is all that is needed as outlined before.

Thanks Sam,

I opened a support request
Ticket no. #539532


Thanks, I’ll check this shortly.

Thanks for the reply to my support ticket, Sam.

I didn’t realise that you no longer manufactured my model of remote or receiver anymore (the latest one on the store looks identical to the one I have)
If I were to place an order for this replacement remote and receiver from your store -

would it be compatible with my original Vero4k+ from 2020?

Yes, it will be compatible if OSMC is up to date.

The remote comes with a new dongle and it can be used on any Vero or Raspberry Pi running OSMC (in addition to most other platforms with some caveats) without issue.

Pairing a current model dongle with an older model remote is what would be problematic and something we don’t support.

Thanks. I’ll place an order for a replacement remote.