Vero 4K+ Remote Stopped Working

Vero 4K+ remote stopped working all of a sudden. Tried a brand new battery and reconnecting the wireless transmitter in vain. Also I don’t see any blue light showing up on front of the unit.

Unit seems to work fine as I can see the home screen.

Unit was bought in May 2020.

Wondering if it’s the dongle.

The Vero 4k+ does not show a blue light in normal mode.

Could it be you replaced the battery with another dead one?
Also have a look at this link Pairing the Original Black OSMC RF Remote Control with a Pi/Vero2/4k/4k+.

I tried 2 brand new CR2032 3V batteries and all the steps described in that article in vain. I think remote / dongle are dead.

Logs would confirm this.

How to get the logs from Windows 10 PC?

Open the Start menu and type in “cmd” and then hit enter to open that. At the command prompt type in…

ssh osmc@192.168.x.x

replacing the 192.168.x.x with the IP address of the Vero (If you don’t know it look in the configs of your router). It will ask you for a password which will be “osmc” unless you manually changed it. Once you are logged into the terminal type in…

grab-logs -A

and hit enter. Note that command is case sensitive. After a few seconds it should return a url that you would then post in this thread.

Alternatively you could plug a USB keyboard into the Vero and use that to navigate to the My OSMC add-on and just upload logs that way.

1 Like

Tried few more brand new batteries and remote still doesn’t work. I am not sure if it’s the remote or the dongle. When I insert the dongle into my PC’s USB drive, I hear the usual pop sound.

I am very disappointed as these issues have developed in just 13 months out of the blue

I have contacted support and waiting to hear back.

I responded to your ticket a while ago – did you attempt the re-pairing instructions with a new battery in the remote?

Thanks @sam_nazarko . Just responded via email but it says message not delivered to because the address couldn’t be found. Please can you let me know the correct email address.

I have tried all the options. None of them worked I am afraid.

That is the correct email address.

What provider are you using?



I’ve tested and this address should be working.


Looks like your mailing system rejected my email address :slight_smile:
I will pm you by mail address. Please do update at your end.

|### Mail Delivery Subsystem|1:53 PM (2 minutes ago)||

| — | — | — |
|to me


Error Icon72x72

Address not found

Your message wasn’t delivered to because the address couldn’t be found, or is unable to receive mail.
The response from the remote server was:

550 5.1.1 <>: Recipient address rejected: User unknown in local recipient table

I’ll investigate this – it might be an issue with upstream provider.