Vero 4k + resolution after power off


#1

Every night i power off all my devices with a master switch. In the morning, when i put on the power again, my Vero 4k + resolution is set back to 1280x1024 (where i set 1080p in the settings menu every time).

All my other settings are saved succesfully and are still in place after the powercycle, but the resolution is not.

Is there a alternative way to force the resolution to be in 1080p after a power cycle?


#2

I hope you first shutdown the Vero4k cleanly before you “power off”?!?

This means the Vero boots before the TV and therefore can not read the TV resolution correctly.

To avoid all this you should not power off the Vero4k


#3

1280x1024 is an odd resolution.

To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

So, in summary:

  • enable debug logging at settings->system->logging
    (the settings-level in the GUI’s settings->system menu should be at least standard for this)

  • reboot the OSMC device

  • reproduce the issue

  • upload the log set either using the Log Uploader method within the My OSMC menu in the GUI or the ssh method invoking command grab-logs -A

  • publish the provided URL from the log set upload, here

Thanks for your understanding. We hope that we can help you get up and running again shortly.


#7

I don’t actually, because when i shutdown the Vero4k, the only way to get it back up is to do a power cycle. That’s not very user frienldy. Or is there another way to power it up with the remote?

That could explain the problem. So the only way really is to keep the Vero4k on and on power 24/7?


#8

The Vero4k is designed as always on device (you can put it in suspend if you prefer). But if you power it off with out a clean shutdown you are putting yourself at risk of filesystem corruption and data loss


#9

Thanks for your advice. Let’s use it as designed then, i’ll keep it on 24/7 :slight_smile:


#10

1280x1024 is indeed an odd resolution; as it’s a VESA mode.

Sam


#11

It took me a while to reply, but i still have the same issue. After rebooting or powering down, my Vero4K+ comes back up at a resolution of 1280x720p.

I enabled logging and uploaded: https://paste.osmc.tv/yoqosohoha

  • Enabled logging
  • Rebooted Vero4k+ (twice i think, the first time it came back at 1080p)

Vero4K+ -> NAD T758 v3 -> LG OLED55C7V
All quality high speed HDMI cables.

Note that playing content goed flawless, as is autoswitching to HDR and colors. It’s just that the resolution of my GUI is set back to 1280x720p everytime.

I hope you can find the issue in the logs.


#12

The fallback resolution is 720p.
Are you booting Vero before your TV / receiver is turned on?

This should be resolved in the next update.

Cheers


#13

No, i tried all combinations but it even happens when everything is turned on, and i reboot from within the OSMC menu (all deviced stay turned on).

I’ll wait for the next update :slight_smile:


#14

You may have a corner case here:

====================== Display Cap =================== g0gjk991
480p60hz
576p50hz
720p60hz
1080i60hz
1080p60hz
720p50hz
1080i50hz
1080p30hz
1080p50hz
1080p25hz
1080p24hz
2160p30hz
2160p25hz
2160p24hz
smpte24hz
smpte25hz
smpte30hz
smpte50hz
smpte60hz
smpte50hz420
smpte60hz420
2160p50hz
2160p60hz
2160p50hz420
2160p60hz420

Your TV / receiver is advertising support for a variety of modes; but it doesn’t advertise a preferred mode (which is usually indicated by an asterisk).


#15

4k screens don’t advertise a native mode in the same way.


#16

Mine does…


#17

Native or preferred? My disp_cap is the same as the user’s.


#18

Should have an asterisk by a mode.


#21

My receiver only does untouched passthrough (no settings there), and the TV of course just listens to the resolution a device is outputting. Is there no way to set a force resolution in a settings.xml file?


#22

Next update should resolve it
You can indeed override the EDID but this shouldn’t be necessary