Vero 4k+ RF Remote dead

The remote that came with my Vero 4K + stopped working a while ago. I replaced the battery (the old one had not leaked and was still good), but this didn’t change anything. I can still use my Vero 4K+ via HDMI-CDC with the remote of my LG TV. But I’d very much like the original remote to work, even though I figured out how to do things not possible with the LG remote using a USB mouse (right-click, for example).

This is what I tried:

  • Battery is brand new
  • blue light on the remote comes on when any button is pressed
  • with USB receiver unplugged, when I press Home and OK simultaneously, blue light comes on after a few second and stays on. I tried this many times, behavior always the same, which is different from which is described in other threads
  • when I then re-plug the USB receiver in either USB slot, nothing happens

Is there anything else I can try?



Try posting some logs so we can see if the USB receiver is recognised


So this is a boot with the USB receiver plugged in.

The dongle is indeed detected:

Register - new hid device registered on usb->/sys/devices/c9000000.dwc3/ OSMC RF Remote (2017:1688)

When a blue light comes on when a button is pressed is it a quick flash or does it stay for a while?
Have you tried the remote on another device?


When I press a button on the remote and immediately release it, the blue light comes on and stays a tiny bit longer than the button is pressed, but only for a fraction of a second (maybe 1/4 second).

I haven’t tried on another device yet, mainly because the only devices I have are iMacs. I just plugged it into my 2017 iMac and the Keyboard Setup Assistant came on telling me that “Your OSMC Remote Controller device cannot be identified and will not be usable until it is identified”.

Does that tell us anything regarding the operability of the RF receiver?



That means the remote is communicating with the receiver.

No – you should be able to scroll a web page up / down using the arrow keys as you would on a keyboard. For macOS, there are additional steps to make the remote work fully.

Thanks again.

Is it correct that if I plug the receiver in a Windows PC (e.g. Windows 10), I should be able to determine if the remote and receiver are working?

Something else I just noticed:

When I go to Settings - System - Input - Peripherals

it shows 2 entries:

OSMC RF Remote
Version: unknown

CEC Adapter
Version: libCEC 4.0.4 firmware v5

For the Remote, Don‘t use the custom keymap is off, keymap is „osmc“

Yes, that’s right.

This is fine, and expected.


I don’t have any extra insight here regarding your OSMC remote but you don’t need to use a mouse to add functions to an LG remote controlling Kodi via CEC. You can use the Keymap Editor add-on to remap buttons to different functions. Specifically the << and >> buttons on your remote are likely a good place to map “context menu” and “info” to. If your remote has the red, green, yellow, and blue buttons these will likely be forwarded via CEC as well and thus available to repurpose.

Thanks for that, I just changed the blue button on the LG remote which now brings up the context menu (hint: Keymap Editor - Edit - Global - Navigation - Context Menu).

But I still would like to find out why the RF Remote stopped working. I guess I‘ll have to find a PC, haven‘t seen any in years.

As @sam_nazarko even on the Mac the cursor keys should work for testing the functionality of the remote.

For more information about getting it to work on macOS see OSMC Remote Control + macOS + Kodi issue. But this was tested with what is now quite an old version of macOS and the security model has changed a bit, so this program may not be applicable anymore.