Vero 4K+ RF remote drains battery very quickly

Hi, I have a Vero 4K+ for an year and it worked nice until the end of 2019. Then the remote stopped working and I changed the battery. After a couple of weeks the battery was under 2.7 Volts and I replaced it again. Then again. Last time I changed the battery was February 1 and today I measured under 2.7 V. I buy the coin cells from different places - electronics shop, a supermarket, even from a watchmaker, who claims to sell good batteries. I am not sure if the remote is working normally or the batteries I have bought are not so strong. I have an IR PC remote with a 3V CR2032 battery and it has been working for 5 years without changing the battery.
The Vero is used 2-3 times a day for an hour maximum playtime, and usually I don’t need to press a lot of keys.

Have you tried re-pairing the remote?

Yes, last time when changed the battery I re-paired the remote using the instructions here. Night time the Vero is powered off completely. But this is from day 1 I’ve got it :slight_smile:

Can you leave the Vero on and re-pair and see if this improves things?

Sam

OK new battery installed. Re-paired. Will stay permanently on, wifi disabled, lan connected (although I never let it on since the first day I’ve got it) . Countdown begins :slight_smile:

Update:
The remote doesn’t work again - the battery voltage is under 2.7 V. This time I used a different vendor for cr2032 battery. The Vero was not turned off, network cable connected, wifi disabled. Again the battery worked for a month.

P.S.
It’s not an April Fools’ Day joke

The device must be near some large 2.4Ghz interference. Could it be near a wireless keyboard / mouse receiver or router?

I thought about this too. But it seems not. No wireless keyboards/mouse/bluetooth devices nearby. The router is in the next room, behind a brick wall, maybe 5 meters away from the Vero and the remote control. Near the router there is a wireles connected RPi 3B+, for a small project. The only new device near the Vero is a combo DVB receiver, but it has only lan connection, no wifi module. I can’t remember the brand of the stocked battery which worked for a long time.

Second (and probably last) update.
The problem hasn’t gone. Last time I ever reflashed the Vero 4K+ using toothpick to bring up the bootloader. Used Energizer 2032 button cell. Again the remote worked nice about a month or so. I give up; I’m not satisfied at all; the warranty is finished and will use 3rd party remote control.

P.S.
Maybe another issue:
I’m pretty sure that when obtained the Vero4K+ when it was booting the red led was lit about a second. Now when the device is powered the led is dark. The led turns on when the device is powered off.

The warranty may be finished but as a gesture of good will we can ship you a new remote. I’ve no idea if this will solve your problem, because it may be environmental

Regarding the LED not coming up on boot, that’s a bug in the latest bootloader, but it’s low priority for me to fix presently.

Sam

I can test the other remote and if it fails after a month or two, I will return it. I can send the old one too, if you need to examine it.
I can’t find any strong 2.4 GHz radio pollution around. The router is running openwrt with reduced RF power and there are at least 5 meters, a brick wall and a lcd TV between the router and the Vero. It’s the same router I’ve had for maybe 8 years. There are not any USB3 devices nearby - I know they make problems with 2.4GHz. Does the remote do band hopping when frequency is too occupied? Or maybe I have bad luck with the batteries. Does it matter in which slot I have to plug the remote’s receiver?

Please send an email to support@osmc.tv with order details and address and I’ll ship it out.

Shouldn’t matter at all

Sam

Did you guys ever find out if this was a faulty remote?

I am having the same issue except the battery seems to be completely drained after only a week or two. This has been happening since I first bought the Vero about a year ago.

I got mine Spring 2019 and the battery was dead when it arrived. I bought a new one and it worked. I was away for work for much of the summer, and was getting ready to move. When I tried to use it again, the battery was dead. I put another new battery in, and it worked.

Soon after, I packed it all up and moved mid August 2019. Could not find it at the new house. Finally found it 12 September 2020. Set it up and battery was dead. Picked up new batteries and put one in. I was already pretty sure this remote was draining batteries excessively.

Things got crazy, and I didn’t use it for a month. Went to use it this evening (13 October 2020) and it was dead again. Messed with it a bit, no go. Put another new battery in (this is getting expensive) and it worked immediately.

This is ridiculous. I took the battery out when I was done. Not having it ruin another battery.

The customer didn’t return his remote, but we shipped a replacement regardless as a gesture of good will.

I can understand your frustration. I’m not pleased with fake batteries that customers are getting from some markets or returns where the remote has ‘died’, but the remote simply had a battery that was flat. That’s why in 2020 we updated our remote to give a low battery warning to improve things here.

The other day, I had a customer who wanted to return his remote because the battery had "failed "after 2 years of use.

With a good CR-2032, you should get 6 months of usage in relatively noisy 2.4Ghz environments.

If you moved location – you should re-pair the remote by holding Home and OK so that the remote is optimised for the new environment.

You will lose significant battery life if you disconnect the device for a period of time, as the remote will constantly try and hunt for the dongle. We improved this a bit in the latest model, but it’s still a trade-off between requiring a user to re-pair frequently and the remote keeping its connection.

Have you re-paired the remote?
Have you tried moving the Vero to avoid 2.4Ghz interference?

Sam

I did re-pair in September when I set it up with a new battery.

Last night, it seemed to work fine as soon as I put in another new battery. Do I need to re-pair anyway?

Is there an IR remote that doesn’t have to deal with this nonsense?

The Vero has an IR sensor built in and the My OSMC has a section to enable config for some of the most popular. Any universal or programmable remote should support several or more of those listed. If you are using a display with CEC enabled that should work as well. You will probably find the above methods to be a bit less responsive than the RF and they will probably not have long-press.