Vero 4K RMA requested

I received my Vero 4k before Christmas but I have never been able to get it working.
I was in contact with Sam at the time but now emails go unanswered.

I’m no engineer and this thing has only ever been a source of frustration. Can I return it for a refund?
Thanks, Kirk

I can’t see how any emails would’ve been neglected. Can you let me know your ticket number?

I’m 2-3 days behind on some tickets; but nothing as drastic as before Christmas.

Can you please let me know what problem you’re experiencing?



I’ve checked this.

You sent an email to my personal address (a bit slower to look at those messages) stating you have a problem. But you haven’t told me what the problem is. You say you have uploaded a log but you haven’t provided a URL, so I can’t access it for security reasons.

I think we need a bit more info and we can then help you out.

Your last message was on 28th January.
Previous messages were replied to expediently. I admit that I’ve been slow with personal emails lately, and do apologise. In future, ping for a prompt reply.



1 Like

The problem is not seeing any shared files. And understanding the error message. We had a number of emails and I was following your instructions to send a log, which I thought had worked and you acknowledged. Then nothing, but I figured it was Xmas and I’d wait to hear from you.
If you’re still ok getting me going with it, I’m happy to keep trying. Is the log I sent no good?
What can i do to get the info you need to you ?

Graham I received your message in my email so came here as it said visit topic to respond but your msg is not here. I’d reply to the email but the from address is ‘’ suggesting I don’t do that. Anyway I’d like a walk through what one does after first switch-on. I haven’t turned it on since Nov and from memory I either got permission denied when trying to find the Target files, or asked for password. There is no password to give it. May have been some other things too, but they didn’t change/fix those 2 issues. Yes I read some of those links… they didn’t help all that much as bit too advanced/jargon to wade through.

Someone pointed out you had already apparently opened a thread on this Cannot connect to SMB shares

So I removed my post.

You cannot access Windows shares without a password, these days. You must supply the username and password for the owner of the folders you want to share (ie your own login on the Windows machine).

Confusingly, it’s more difficult to share a ‘Public’ folder on Windows than to share one of your own folders. I don’t recommend you try.

Hi Kirk,

I wonder if you’d been replying to the noreply email which meant some messages weren’t getting through.

This guide is fantastic and should help: File sharing with a NAS, media server, windows share or other device


That was a thread started some time ago and I never seen any replies.

Sam, reading that link (which I’ve seen before) is hard going. For me it’s way too complicated.
I have a wireless connection set up and working between PCs. That is, a laptop (wireless) can see my (Windows) shared folders, as can 3 other wired PCs. There are no Password(s) and I prefer it that way.

The next paragraph starts “If you have NAS”… What is a NAS ?

SMB - is more familiar as the rasp pi used it and I’m guessing it may be the protocol that allows Windows to communicate with a device. Later it says it’s not recommended for hi def.

There’s also references to NFS, UPnP and on it goes, getting worse and worse, I am not an engineer and cannot make informed decisions about these as the article expects

Anyway I turned on Vero now to outline what i see and try but nothing shows up on the TV screen. The HDMI cable is connected and correct input selected on the TV. As i connect power to Vero a red + lights up for about 3 seconds then goes out with no further indication it is on. If the remote should wake it up, no button does anything. Is it possible its battery has gone flat ?

Further to above - apologies - I was being too gentle, the HDMi cable needed pushing in by another thou… so now there is output. A message said the library was empty and to choose Add Files option.

Selecting that showed my list of PCs. So good so far. But choosing one of them appears to lock everything up. But after waiting several minutes it move onto wanting a Username and Password.

What do i put there ??

I told you - the name and password of a user on the Windows machine you are trying to access. If you really don’t use passwords, you can try just your login name but that would be very unusual (and unsafe, security-wise)

No password is how its been for years, with no problems. Further to no Password there’s no login we type in, unless you mean the name showing above “Welcome” (Win 10). I can try that and get right back with an answer. The 2-3 minute delay is normal ?

Microsoft make some changes several months ago for security reasons to disable the password-less access.

You could create a new Windows user called OSMC with a password and give it access to the shares. You would then use user osmc with the password you created.

1 Like

Using the name and “OK” sort of goes around in a loop. I suppose it’s demanding a password. I’m a bit reluctant to add Users as that may impact the existing system. Would it need this new user on any/all PC sharing files ? How often do you need to enter these details - every time you use it or select a file ?
When you say password-less access is disabled, is this only with OSMC ? I am able to share with other devices ok.

Which devices?


Any PC on the lan, including the laptop and XP machines plus an android box (called M8S or similar) and the Raspberry Pi.

If connecting to an XP machine, I think you can just set SMB version to 1 in Settings -> Services.

I quite like the ability to share files in XP but can forego that if neccessary. I tried to back out of where I was (User/Pass input screen) to navigate to Settings-Services to see what SMB version was selected but got a blank screen, or maybe this 5 min wait again. This seems to seems to happen a lot and sort of mucks you up trying to do anything. Is that a known issue, or just something weird here ?

It was this delay, eventually i got to Settings/Services and Maximum Protocol Version was on SMBv1. I then tried browsing to the XP machine as a test (have to wait several minutes twice) but could not remove the username present from the previous logon attempt (to Win 10 machine.)

Press the three lined button to remove the source.
Then you can re-add it.

I received another email about this issue and have replied; but also will put my advice here as it may help others, and there’s more eyes here.

The simplest solution going forward is:

  • Reinstall OSMC so you start fresh: Reinstalling OSMC - Vero 4K - OSMC
  • Immediately go to Settings -> Services and set SMB to version 1
  • Add a user account on your PC or use an account which has a password
  • Enter those credentials when selecting the share in OSMC