Vero 4K+ several issues (SMB, DLNA, and audio)

I got a second hand Vero 4K+ to replace the internal player on my 2017 LG OLED. This was for the following reasons:

  • Since switching to a processor with ARC instead of stereo SPDIF (was using a stereo amplifier) some audio tracks wont play
  • To run Spotify connect so I don’t need to have my tv on for music (I can turn off the screen though).
  • The TV only has a 100mbit port and very high bitrate 4K content shows some artifacts which I think it because of the network speed.

But I run into the following issues:

  • Going to the menu while playing forces a refresh rate change (set on always switch) results in a massive pop in my speakers. I would like the menu to be 60hz and playback at whatever the file is (like my TV’s internal DLNA player does), but this doesn’t seem to be possible?

  • The Vero doesn’t always see my Serviio DLNA server running on my NAS (fixed ip). I had it working once, but the next day I’m not able to access it through the Vero. Serviio sees the Vero though. DLNA works flawlessly on my TV, phone and tablet.

  • Vero can’t access my SMB network drives. I don’t know why it can’t access them, they work flawlessly on my PC, tablet and laptop. Where can I enter a password?

  • Raspotify doesn’t output sound over HDMI (didn’t test the other ports).

All in all the experience is very disappointing and makes me just want to sell it and get a Shield or something (maybe even an Apple TV even though that has that 24hz issue). What are the steps I will have to run through to get this fixed? I started out with a completely fresh install with the latest image, the person who owned it before me was nice enough to flash it to completely reset it.

Settings->Player->Videos->Adjust display refresh rate-> On start/stop should fix that

Start here, and be prepared to experiment with different versions of SMB.

I’m not familiar with Raspotify - are you using a plug-in or a separate app?

I used this guide for Raspotify

Yes, I was paging through that. It’s not clear whether the instructions in the OP are still valid. Maybe @zilexa can advise.

Its running and Spotify connect works. But there is no sound. So the installation seems to be okay, but the audio routing seems to be broken.

I got the Vero because I didn’t want to deal with random Chinese boxes that might have issues, but I regret that now. It cannot even do DLNA streaming.

I’m sure there’s someone in here can sort you out with DLNA (I don’t use it).

Which ALSA device are you trying to use with spotify? I suspect you need to use hw:0,0.

Make sure you have Settings->Audio->Keep audio device alive OFF, and bear in mind it takes a couple of seconds after outputting a sound from Kodi (media or a GUI tick) for Kodi to release the HDMI audio device before another app like spotify can grab it.

DLNA works just fine - and a number of users use it. What happens when you try and add a source?

I had to set the Vero to share libraries, which makes no sense since its not acting like a server. This seems to be a bug in the software, that causes just enabling UPnP support not to do anything.

I have no GUI sounds and keep audio device alive off. I’m trying to use HDMI to my surround processor, how do I set raspotify to hw:0,0 (which is, I presume, forcing HDMI output)?


So I set the following I guess?
OPTIONS="–device hw:0,0"

Edit: the above doesn’t work. How can I see playback devices?

Edit2:ok, had to install alsa-utils and this is what I see:
card 0: AMLM8AUDIO [AML-M8AUDIO], device 0: I2S.39 T9015-audio-hifi-0
Subdevices: 1/1
Subdevice #0: subdevice #0
card 0: AMLM8AUDIO [AML-M8AUDIO], device 1: SPDIF.40 dit-hifi-1
Subdevices: 1/1
Subdevice #0: subdevice #0
card 0: AMLM8AUDIO [AML-M8AUDIO], device 2: PCM.41 pcm2bt-pcm-2
Subdevices: 1/1
Subdevice #0: subdevice #0

So device 0 seems to be the choice? 1 is spdif and 2 bluetooth (I’m guessing). But it doesn’t work with either OPTIONS="–device hw:0" or OPTIONS="–device hw:0,0" Or 0,1 or 1,0. play -L (capital letter) confirms dev 0 is HDMI. So what is happening?

hw:0 ought to work. If you type
speaker-test -Dhw:0 -t wav -c2 -l 2
what do you hear and see on the console?

Works for me without sharing the vero’s library.

osmc@osmc:~$ speaker-test -Dhw:0 -t wav -c2 -l 2

speaker-test 1.1.3

Playback device is hw:0
Stream parameters are 48000Hz, S16_LE, 2 channels
WAV file(s)
Rate set to 48000Hz (requested 48000Hz)
Buffer size range from 32 to 131072
Period size range from 16 to 16384
Using max buffer size 131072
Periods = 4
was set period_size = 16384
was set buffer_size = 131072
0 - Front Left
1 - Front Right
Time per period = 0.428271
0 - Front Left
1 - Front Right
Time per period = 3.062798

And I’m hearing the audio…

I got around testing the adjust refresh rate, it still pops on my speakers and subwoofer when switching back after stopping playback. I’m giving up, I’m going to a Shield or Apple TV (I’ll just use the internal player on my tv for 24hz sources then).

Sorry to hear that. I can’t recall anyone else having those pops (I certainly can’t reproduce them). If you did want to stick with it, let us have a full debug log so we can check all your settings.

To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

Depending on the used skin you have to set the settings-level to standard or higher, in summary:

  • enable debug logging at settings->system->logging

  • reboot the OSMC device twice(!)

  • reproduce the issue

  • upload the log set (all configs and logs!) either using the Log Uploader method within the My OSMC menu in the GUI or the ssh method invoking command grab-logs -A

  • publish the provided URL from the log set upload, here

Thanks for your understanding. We hope that we can help you get up and running again shortly.

OSMC skin screenshot:

After following the first couple of steps (logging, double reboot) I lost access to my Serviio DLNA server again (while the options I’ve set are still the same in the menu)…so lets fix that first:

https://paste.osmc.tv/iqilokacib

Disabling and enabling it again fixes it, but that shouldn’t be necessary. Just to reiterate: it works fine on my PC, laptop (work laptop with very strict networking restrictions!), phone with the latest Android version, tablet with Android 9 (I think). This is the only device that doesn’t work properly with Serviio.

Edit:
https://paste.osmc.tv/rofekehemo

Here I start a movie and press stop. That triggers a pop in my subwoofer that you can easily hear and you can also easily see the excursion. Probably also happens to my fronts, but I had my power amplifiers off during the test.

It may not be causing the audio pops, but you have the GUI set to 2160. You will get the best experience if you set the GUI to 1080p as the Kodi upscaler is inferior to your TVs. We’ve seen other strange problems with the GUI set to 2160. So it’s worth trying setting it to 1080. Since you have Adjust Refresh rate set, your 4K content will still play in 4K.

Indeed. If you go into MyOSMC->Networking and enable ‘Wait for network’ it should work better. Or have you already turned that on?

Seems to work, it held after a reboot. Now I hope we can fix the popping.

Did you try as I suggested and switch the GUI to 1080P?

1 Like

It might be a tough one. Some receivers/TVs are more tolerant of mode changes than others. Can we narrow it down:

  • Do you get pops if you connect the vero direct to the TV?
  • does it happen when stopping any media, just music, just video or any other particular circumstances?

Can you decribe your setup in more detail? How do you get the LFE channel if the other amplifiers are off?