Vero 4k, skip forward: no audio; skip back: start of video

#1

When skipping forward, the video skips forward, and the audio is lost.
Skipping backward, no matter whether 1 keypress or 17, the video goes back to the start.
This is both for videos streamed via NFS from a NAS, and locally stored videos.
Logfile for NFS streamed video: https://paste.osmc.tv/aciwigaqec

I was in the middle of a movie when that happens. Kodi will also not ask me where to restart the video (from beginning or from last position). How do I get to the last position without re-watching the video?

#2

This is a known issue in Kodi v18.

This is because Kodi now seeks for a keyframe backwards instead of forwards, as it used to. The idea is to stop sudden jumps when resuming video.

I need to think of a good solution to this. You should get audio after a few seconds, which is usually the amount of time between key frames.

#3

Oh, then I was too impatient maybe. I haven’t given ‘waiting’ a try so far. :wink:

#4

Can you try waiting a few seconds next time? If it works – I’m on the right track regarding fixing the problem

Cheers

Sam

#5

Today, I rewound the video a little. After hitting play again, the video starts, but without audio.
After a while, the video froze up instead of adding the audio again. Waiting longer didn’t help.
I pressed “skip back” once, but the video was reset to the beginning.
The only feasible option was to stop the video.
Since I was in minute 29, I now have to re-watch 29 minutes, because neither skip nor fast foward will work?

#6

Is this a single video that behaves this way or all videos? If single, we should have a look at the mediainfo on the file, if all, you should test network throughput with iperf3 and report your results.

#7

It is all videos. Since it also concerns locally stored movies, my wild guess is that testing network throughput with iperf3 and reporting my results is of minor importance at the time being.

#8

Sorry, missed that.

#9

I will have a solution for this tomorrow

Cheers

Sam

#10

That sounds wonderful :smiley: Thank you very much for your swift response.

#11

Hopefully the issue is now addressed

I’d appreciate it if you could test this and provide feedback before we potentially release this as an update to other users. To test this update:

  1. Login via the command line
  2. Edit the file /etc/apt/sources.list
  3. Add the following line: deb http://apt.osmc.tv stretch-devel main
  4. Run the following commands to update: sudo apt-get update && sudo apt-get dist-upgrade && reboot
  5. Your system should have have received the update.

Please see if the issue is resolved.

I also recommend you edit /etc/apt/sources.list again and remove the line that you added after updating. This will return you to the normal update channel.

#12

Hey Sam,

I am outright impressed, excited and grateful – that fix works so good! Skipping forward, backward, even fast forward/backward, and the audio will kick in instantly again, no matter whether it’s a locally stored video or from my NAS.
So, thank you very, very much! :smiley:

1 Like
#13

Thanks for testing Jan.

#14

Sorry to say this, but now Kodi will freeze up with a sad face and restart when idling in the menus (default skin).
https://paste.osmc.tv/ikesuhukuq

Edit: aha, I believe this can be caused by the Library Auto Update plugin. It was trying to update the library whenever Kodi crashed. I disabled it, now Kodi has not crashed in a while.
However, Kodi will crash also on a manual update. I will gather further evidence and open up a new thread if needed.

#15

The Library Watchdog plugin can be problematic.

#16

can you make an official update for this Problem Sam ?

#17

It will be included as a stable update soon.

#18

Skipping works really great with this version, BUT something is broken with deinterlacing of live tv channels. The picture of every interlaced channel is extremely wobbly = a very fast upwards and downwards motion of the picture. It is hard to explain, it looks as if someone is shaking the tv up and down very fast.
This problem does not appear with 720p-channels

#19

I’m aware of this. It’ll be fixed in a few hours.

1 Like
#20

This is now fixed – just waiting for Jenkins to build.

Sam