Vero 4K+ stops working

Today I watched tv on Vero 4K+. I’ve been doing so for a year already. Suddenly black screen. I unplugged it and plugged it in back. It booted to the menu and I could move there. Before I had chance to choose a tv channel and play it, it went to blue screen. I re-plugged it in. It booted to the menu and after 3 seconds, it went to green screen. It happens all the time now. Gray, black screen.
When it freezes I can’t connect to it. SSH freezes as well, so I have several seconds to use command line.
I tried to remove all usb devices from it (remote control, tv dongle), hdmi cable and jack, so there was only network and power connected - it behaved the same.
What can I do?

A photo might make it clearer what you mean by blue screen.

I have turned it on to make a photo of the screen and it worked much longer now - at least 5 minutes. But then it went to the black screen. I can’t reproduce the blue screen right now. If I succeed, I’ll upload it.
I think it depends on the temperature. It was turned off some time before I turned it on and it lasted longer. When I disconnected the remote control usb dongle, the metal part of the usb was hot, so I think it somehow overheats, but I’m not sure - I don’t know if it wasn’t like that before. If I turn it on immediately after it freezeed, it stays in the black screen, or the menu is shown for second for example. The fact is, the longer I leave it turned off, the longer it lasts turned on.

black screen means - tv monitor has still signal, but the whole screen is black, like a black video, ssh freezes, no sound
once I’ve seen gray, green screen or blue screen (no logo), but now it has just the black screen

You could try leave it on for a few minutes without the USB receiver, if you suspect that’s the issue.

Temperature should be visible under Settings -> System Info and it would be interesting to know how hot the device is getting.

If the device overheats, the front LED should turn red.

I turned it on now. There was 63°F or 68°F (don’t remember) in Settings->System Info->Hardware.
After 20-30s (I don’t know exactly) I got a new red screen of death or it might be more purplish red.
I unplugged the power cable, waited for 3s and plugged it again. Black screen no boot.
Unplugged it, waited 5s and plugged it again. Black screen no boot.
So unplugged it again, waited 20s and plugged it again. It booted, I could move in the menu, so went to Settings->System Info->Hardware. There was 127°F displayed and after 5-10s I got gray screen of death.
The front led was off all the time.

rsod
gsod

I removed the remote control usb dongle, turned Vero4K+ on, and started tv channel via Kodi web interface. It worked really long - several minutes I watched the tv.
I connected there by ssh and checked the temperature:

$ cat /sys/class/thermal/thermal_zone0/temp
77000

Then I continued to watch. I thought it’s resolved, but then I got an idea to switch the channel by Kore (from mobile phone). I went back to the menu, moved 3 items down and got the gray screen of death again :slightly_frowning_face:

I turned it on again and connected to it and ran sudo systemctl stop mediacenter.
Kodi existed and it displayed the standard console messages with green OKs.
I was waiting for what is going to happen…after 10 minutes the console text disappeared and ssh disconnected. See the image:

I left it several minutes in that state and the Vero 4K+ box was quite warm. I unplugged the remote control usb and checked its metal part - it was very hot. I think it wasn’t the remote control but the device was hot inside. It seemed to me quite much as Kodi wasn’t running. Still not sure, maybe it’s standard for Vero 4K+. Who knows. What can I do with it?

Can you (I understand it doesn’t stay up for long) upload some logs via My OSMC?

Thanks

Sam

Logs: https://paste.osmc.tv/aqifucuhur

The blue screen which happened after grabbing the logs:

How did you grabbed the logs, via MyOSMC or via command line grab-logs?
Also after what event did you grabbed your logs, just directly after you started it?

There is a pointer in kodi.old.log and your kodi.log to a Tvheadend connection issue. Maybe try to disable TVheadend client for testing purpose.

2020-09-08 02:40:42.318 T:3840926432   ERROR: AddOnLog: Tvheadend HTSP Client: pvr.hts - unable to connect to 127.0.0.1:9982
2020-09-14 20:08:58.647 T:3668460256   ERROR: Previous line repeats 4 times.
2020-09-08 02:40:41.784 T:3837780704   ERROR: AddOnLog: Tvheadend HTSP Client: pvr.hts - unable to connect to 127.0.0.1:9982
2020-09-11 00:13:28.953 T:3961062112   ERROR: Previous line repeats 4 times.

I started Vero 4K+, waited for the screen showing the menu, then I tried to connect to ssh. When connected I grabbed the logs by
grab-logs -A -C
copied uploadlog.txt to pc. Vero 4K+ went to blue screen. I turned it off, checked uploadlog.txt for sensitive info, turned Vero 4K+, connected to ssh, copied the file there and sent it by:
paste-log /boot/uploadlog.txt.
The logs are grabbed before the freeze since after I lose the ssh connection.

The error with Tvheadend is there, because it takes some time to initialize the stuff. First the notification pops up in the right top corner saying: “Tvheadend HTSP Client - Server does not respond properly” and later “Tvheadend HTSP Client - Connection established”. It has been happening from the beginning. It’s not an issue I would say.

image

image

As far as I understand there is a time window after reboot where you are able to login via ssh and type in some commands.

Unfortunately we need also kernel messages from previous boots which are disabled by default with OSMC. To activate and provide such information, please, try the steps below. In any case try to execute the commands in 11.a/b/c afterwards to prevent filling your root file system.

  1. login via SSH to the OSMC device, user osmc, password osmc
  2. cd /var/log
  3. sudo mkdir journal
  4. (from now, kernel messages are written to new directories for every boot)
  5. sudo shutdown -r now
  6. now wait for the issue/event which is the problem of this topic
  7. once it happens again and you are forced to reboot the OSMC device or it rebooted automatically, you’ve to identify the right kernel message log:
    7.a) login via SSH and invoke
    sudo journalctl --list-boots --no-pager
    7.b) the lines start with an index id like 0, -1, -2, etc. and contain the date and time when log was started
  8. upload the appropriate kernel log using
    sudo journalctl -k -b <identified index> --no-pager|paste-log
    (replace <identified index> with the real index id, see above)
  9. also, upload the appropriate full log using
    sudo journalctl -b <identified index> --no-pager|paste-log
    (replace <identified index> with the real index id, see above)
  10. provide the returned URLs here
  11. don’t forget to remove the created journal directory otherwise your system’s root file system gets filled
    11.a) login via SSH
    11.b )cd /var/log
    11.c) sudo rm -R -f journal && sudo reboot

Sorry for the delay. I had lot of work.
Today evening I continued and also measured time:

turned on
00:06?.24 blue logo
00:13.82 menu
03:22.14 gray screen
turned off

turned on
00:?.? blue logo
00:?.? menu
+00:20.35 blue screen
turned off

turned on
00:11.42 blue logo
00:20.64 menu
01:02.90 green screen
turned off

turned on
00:11.28 blue logo
00:28.64 dark gray screen
turned off

turned on
00:11.35 blue logo
00:20.78 menu
00:54.77 gray screen
turned off

I listed all logs:

$ sudo journalctl --list-boots --no-pager
-4 4be499a354f64b9baff2a1e0b8dc4e24 Thu 2016-11-03 18:16:42 CET—Thu 2020-09-24 00:05:35 CEST
-3 36988235cc9e402d8269224340883b76 Thu 2020-09-24 00:08:09 CEST—Thu 2020-09-24 00:08:21 CEST
-2 a2bca950a72f463791bc48dc2e00c964 Thu 2020-09-24 00:10:25 CEST—Thu 2020-09-24 00:10:55 CEST
-1 b6268fb4d3364b0bb5aa1974cf7cf09f Thu 2020-09-24 00:16:29 CEST—Thu 2020-09-24 00:16:56 CEST
 0 8b941f85ecb34e5882d3de6a53817511 Thu 2020-09-24 00:18:42 CEST—Thu 2020-09-24 00:19:16 CEST

then saved them
$ sudo journalctl -k -b 0 --no-pager > log_k_0
$ sudo journalctl -b 0 --no-pager > log_f_0
$ sudo journalctl -k -b -1 --no-pager > log_k_1
$ sudo journalctl -b -1 --no-pager > log_f_1
$ sudo journalctl -k -b -2 --no-pager > log_k_2
$ sudo journalctl -b -2 --no-pager > log_f_2
$ sudo journalctl -k -b -3 --no-pager > log_k_3
$ sudo journalctl -b -3 --no-pager > log_f_3
$ sudo journalctl -k -b -4 --no-pager > log_k_4
$ sudo journalctl -b -4 --no-pager > log_f_4

I sanitized all the logs.

turned on (hdmi cable disconnected)
cannot see anything on screen since I disconnected the cable, but I'm connected to ssh
18:36:00 OK ssh still active  
28:25:15 freezed, it was probably earlier
28:25:27 turned off  

turned on (hdmi cable disconnected)
03:40:00 uploaded first log
03:44:26 ssh freezed
turned off  

turned on (hdmi cable disconnected)
00:53:00 uploaded second log
00:59?:00 uploaded remaining logs
05:22:20 ssh found freezed (probably earlier)
turned off

Here are the logs:

$ cat log_k_0|paste-log
https://paste.osmc.tv/adegosemuq
$ cat log_k_1|paste-log
https://paste.osmc.tv/qenosenaco
$ cat log_k_2|paste-log
https://paste.osmc.tv/isuquzapom
$ cat log_k_3|paste-log
https://paste.osmc.tv/pirewafaki
$ cat log_k_4|paste-log
https://paste.osmc.tv/apoqeliqur
$ cat log_f_0|paste-log
https://paste.osmc.tv/vihonugajo
$ cat log_f_1|paste-log
https://paste.osmc.tv/dimunabesa
$ cat log_f_2|paste-log
https://paste.osmc.tv/bipahatuxo
$ cat log_f_3|paste-log
https://paste.osmc.tv/omaducoxoy
$ cat log_f_4|paste-log
https://paste.osmc.tv/amacagujog

It’s interesting that when I disconnected the hdmi cable from the Vero 4K+, it ran longer (28 minutes), but the next runs without the cable took only 3 and 5 minutes. I still think it can be caused by temperature, but don’t have any arguments, it’s strange. Let me know if you find something in the logs.

I cannot see any obvious in these logs; without any other ideas I suggest to re-install the Vero from scratch; if the behaviour persists, it might be a defective Vero HW.

I tried to re-install OSMC. First time I didn’t pay much attention to the whole process and when it ended up with the black screen I thought it was installed but after I unplugged it and plugged it in again to run it, it froze at a gray screen in the first seconds. I tried to re-install it again and it froze during the installation (at the progress bar).

I changed the power adapter for a different one since I thought it could be defective and it could be a good test.

Third time, I successfully installed it and tried to change the language in the settings. During that it got stuck and a blank blue screen appeared.

I also found the micro-sd card quite hot when I unplugged it.
I think it’s a hardware problem.

What can I do next? Do you have any test verifying it’s a hw problem? Could it overheat? I just had it next to the monitor in a room with regular temperature and I didn’t touch it for a year. Is it possible to repair it?

The temperature should be visible under System Info page, and would let you verify it is overheating.

Turned on, there was 91°F, after a minute 97°F, after 2 minutes 99°F => blue screen

I don’t think the device is overheating then. That’s actually quite cool.

Can you update via USB?

You’re running a “DVB-T2/C USB-Stick” which seems not to be on a separate powered USB hub. Is this correct?