Vero 4k stuck with red light on front of device, wont power on

Good afternoon

My Vero 4k wont power on beyond the red light on the front of the device. I am using the original AC powered into the wall so no issue there.

Any ideas of anything I can try?


Hi. Has it ever worked?

Yes it seemed to work ok for a while. Now it is stuck on red light and i havent changed anything my end

Update: Left it for an hour, tried again and now it boots up ok.

Let’s keep an eye on it. If it happens again do let us know.

Make sure the base of the device isn’t on top of other electronics or it may overheat


Mee too with this problem : is it supposed to power on pressing any remote key?
I’ve tried all but no success, always red light.
The only way to power on is to unpulg-replug the ac line…
The device and psu temperature are fine (fresh surface when you touch it).

The Vero is designed as an always on device. Once turned off, the only way to turn it on again is to pull the power. Pressing a remote key will do nothing.

Hi, I just received my brand new Vero 4K. I’m very happy with it, but it seems to have a similar problem as OP. When I boot it up, it works fine. Then I leave it for a while and when I come back the light has turned red and it won’t turn on until I re-insert the AC. Is there some sort of sleep/shutdown timer I don’t know about?

There is no shutdown timer; it’s designed as an always-on device. The red LED means that it’s been shut down.

If you’ve added anything to the system, eg Kodi add-ons, I’d suggest that you uninstall them for now and see if the problem persists.

Maybe some HDMI-CEC device send turn off signal to Vero when you turn it off?
My Vero 4K works days until I turn it off or reboot myself.

It looks like a poweroff signal is sent through CEC, or directly to Vero (does it have an IR receiver built in?). This happens when I press the power button on my TV remote.

In /usr/share/kodi/system/keymaps/remote.xml, this line is set:


After removing that line, upon pressing the power button on my remote, the Vero doesn’t turn off anymore.


Yes, I know that doesn’t really add up. I probably turned off the TV every time I left it, so that explains why the Vero got powered down as well.

We need to noop this key on Vero 4K possibly.

This is now resolved in:


Hey. Rather than start a new thread, I thought I’d post in here as I’ve just started having the same issue. Vero4K has been used without issue for a good 4 months now, but today I have the red light on the front and I can’t find anyway of booting it.

I’ve left it for an hour, as per the previous poster, but it still won’t boot.

Any advice welcome.


Do you have another power supply (must be 5V, 2A) that you can try?
Have you tried reinstalling OSMC using the toothpick method? See Reinstalling OSMC - Vero 4K - OSMC


Sam, I’ll have to look for an alternative power supply to test, and come back to advise if its worked.

Hi Sam.

I’ve not got another 5V 2A power supply that I can find. But have tried different sockets in the house, and also tried to reinstall OSMC via the toothpick method (inc renaming to recovery.img). The unit has been unresponsive to both attempts.

What do you recommend?


Ping and we can go over some steps and (likely) swap this over for you.