Vero 4K+ stutter/buffer issues (source: NAS)


One week ago I received the Vero 4K+. After I installed the device everything was working great and smoothly. However, the second day I experienced buffer / stuttering issues while playing movies (especially UHD video’s (they were completely unwatchable), but also with 1080p and even DVD files).

I am using a Synology DS214+ (NFS shares) as the source. Before the Vero 4K+ I’ve used different mediaplayers with this setup (Shield / HiMedia Q10 Pro / Raspberry Pi’s), but never had stuttering/buffering issues before.

I did some testing the last couple of days and the strange thing is, the problem is not always there. Sometimes/days everything works smooth. When it’s not working, it seems nothing helps (restart Vero, restart NAS, etc). But suddenly it could be possible everything is working again (or sometimes I have to wait for the next day(s)).

-When I use a USB stick everythings works smoothly;
-I changed the cache settings in advancedsettings.xml after searched this forum for same problems, didn’t help unfortunately.

I really hope someone could help me out because except this problem, it’s a wonderful device :slight_smile:

Please can you post a debug log when this happens again?


Thanks for the fast reply. Here’s the log:

(I did a test with Earth One Amazing Day movie)

Quite a few underruns there.
Do you have multiple drives in your NAS?

If so: can you eliminate possibility of a problematic HDD by moving it to a different share?


I have two drives, but using a RAID-1 setup.

What are ‘underruns’ exactly? (I am not that technical :-))

OSMC is requesting data via the network but it’s arriving too slowly.

You could try streaming from an SMB share on your PC if that helps.

Seems I don’t get the sharing in Windows 10 Home enabled (never done it before).

Created a homegroup;
Enabled SMB sharing;
When I right click on the folder I want to share and select > ‘Give acces to’ > Homegroup (view and edit), it seems nothing happens.

Hi @DukeJohn,

I’m using a Synology DS214se with a Vero 4k and installed iperf3 on the NAS and the OSMC device for network bandwith tests.

  1. Synology: Follow

  2. Vero: sudo apt-get install iperf3

Start iperf3 in server mode on the Syno and in client mode on the Vero. Try also -R parm to check the other direction as well.

@sam_nazarko I tried it multiple times now, but don’t seem to get the SMB share working between my PC and the Vero device.

@JimKnopf Thanks for the suggestion! I will look into it on a later time (it’s looks/sounds really abracadabra to me ;-))

I have replaced my NAS some time ago with one that is more powerful. From the specs of your device, it has a 800Mhz CPU and 256MBytes of RAM. This means that there is barely buffer available in RAM for when the disks do serve another host or some maintenance is being done by the OS.
Note that my old NAS was a QNAP SS837 which had a Dual Core 1.6Ghz Atom CPU and 2GB Ram.
Well - when serving 2 hosts at the same time full HD content, it was still ok. As soon as something else came to play, both stream receivers started to stutter.
Reason I replaced mine with a more powerful alternative.

My advice, check out the NAS device (if you can log in) if something else is happening on it (Log in using ssh and check what’s going on).

I have a Synology DS418j (64-bit dual core 1.4GHz with 1GB of RAM) with 2 drives currently in it. It has proved more than powerful enough to serve all resolutions of media to my Vero using Windows shares. Your DS214+ appears to only have a 32-bit CPU.

Have you checked your Synology’s web interface? Are there any health issues for the drives? How busy is the Synology’s CPU showing on the dashboard? How many devices are accessing the Synology on your network?

I have to enter the IP address of my Synology to open the shared drives in Windows. A couple of major updates ago, MS increased the security settings on Windows 10 and it now refuses to list my Synology. It also won’t mount any network drive that doesn’t need a login with a password. I had to create a user on the Synology, give it a password and access to the drives so Windows could use a password to log in.

Have you enabled network discovery on your Windows 10 device? If not follow steps 1-8 here:-

Also you don’t need to create a Homegroup to share folders (imho Homegroups are a pain that MS should kill off), you just need to right click on the folder you want to share, select properties then sharing then share and select your permissions.
Over the years I have found Kodi is a bit flakey when setting it up to see SMB shares, if you have any further problems after you’ve set up your shares give a shout and I’ll write up my almost foolproof way of getting Kodi talking to Windows SMB shares

@DukeJohn, are you running anything else on the 214+ ? A 214+ is more than capable of streaming 4K files without breaking sweat. I run a 214+ for hosting part of my blu-ray TV library, I connect via Kodi-mounted NFS over a fully wired network and it’s rock solid even with multiple clients. I just dropped a 4K title onto the 214 that I know has a tricky chapter skip for old Vero’s without fstab mounting/a gigabit adapter, and playback on the chapter skip was faultless. But my 214+ does next to nothing apart from serve files. There is a bigger brother that handles more demanding tasks, but even that is quite low-spec (416play) and server-side problems have never been an issue, and it gets hit quite hard sometimes.

A 214+ streaming a 4K mkv file. Not exactly struggling.

Thanks for all the reply’s and suggestions!

@Smurphy, you have the wrong specs for my NAS. It’s a Dual Core 1.33GHz with DDR3 1GB. Anyhow, the these specs are definitely not the problem. I have played a lot of UHD movies with my previous setup (same NAS + Nvidia Shield) without any problems.

@Papfox, Vero is the only device that’s using the NAS. When I play a UHD movie the CPU use is between 1-15% and I around 50% of the RAM is available. Like I said in my reply to @Smurphy, the specs are definitely not the problem (watched many movies with previous media players and same NAS). The Vero is not only having problems with 4K content, but also 1080p and even DVD files.

In addition to the information above, the problem is not always there. At some moments, everything is working smoothly.

@Buckeye, Thanks, I will give the SMB share another try when I have the time for it (hopefully later today or tomorrow).

@ac16161, Thanks for confirming the specs of my NAS are not the issue. I am only using the NAS for Sonarr, Radarr, NZBGet and hosting my movies/series. Nothing more. When I am playing a 4K file on the Vero, the CPU use is between 1-15% and there is about 50% free RAM.

@sam_nazarko and @Buckeye

I did it, SMB share is working now (first enabled SMB1 on Vero, but still could not find the share when browsing. After that I manually added the SMS share (smb://user:password@SERVER/sharename/folder), and that did the job.

Unfortunately I came across another problem: I only have one laptop and using 5Ghz WiFi. I tested it with the wireless connection, but the (4K) movie was unwatchable. So I connected a UTP-cable, but came to the conclusion my network adapter is only 100Mbit. So again, when I played the 4K movie it was still unwatchable. However, I also tested it with a 1080p movie and that one was running smoothly.

So overall:
-It seems my NAS it not the problem (enough free CPU and RAM while playing UHD movie and same NAS model is working flawless for other user on this forum)
-I did some testing with SMB from my PC, but cannot play 4K because my network adapter is limited to 100Mbit
-Playing from USB stick is smoothly.

Do we have other options?

I notice that your log file shows that you were using Kodi’s libnfs to connect to your NAS, when it is likely that using an fstab-base NFS would have given better performance.

As others have already mentioned, the Synology should provide ample throughput; it’s the network configuration that needs some work.

Thanks for the suggestion. I just setup an fstab-base NFS share. I am playing an UHD movie as we speak and while I first thought the problem was solved, after a couple of minutes the movie just stuttered again… :frowning: (and now, even the entire screen is stuck…)

So, describe the network infrastructure between the Vero and the Synology … and try to bring the iperf3 tool to work on Synology and Vero, so you can measure the available bandwidth between both.

Don’t hesitate to ask here if you’re getting stuck with the iperf3 installation and usage, there will be help.