Vero 4K to Vero V - OSMC v18.6

I have a Vero 4k running OSMC v18.6. (I’ve never been able to upgrade it since I bought it used in 2019 - have tried using hotfix and command line method without success.)

I only ever use Vero in ‘File Mode’ as a simple media player which allows me to browse my folders and files as set up on an ext hard drive. (I like to add customised artwork poster.jpg/fanart.jpg with movie information nfo brought in using tinymediamanager.)

I use the minimalist OSMC interface and I have all my settings backed up on an ext HDD via MyOSMC backup

My question: I’d like to switch to Vero V. Can I use this backup to transfer over to Vero V or is it too old?



This version would be too old.

We’re happy to help you update to the latest version of OSMC however.

Have you tried running the following via the command line:

sudo apt-get update --allow-releaseinfo-change

and then checking for updates via My OSMC → Updates → Manual Controls.


Even without being able to get a backup from a current version there is still a way to transfer the library.

Hi Sam

Bit of a novice I’m afraid

So - I’ve accessed via ssh (terminal i’m on Mac) …

put in

sudo apt-get update


sudo apt-get dist-upgrade

with result:

“Reading package lists… Done
Building dependency tree
Reading state information… Done
Calculating upgrade… Done
The following packages will be upgraded:”

with the result: about 30 lines of upgrades
and hundreds of lines of Err with this at end

“unable to fetch some archives, maybe run apt-get update or try with --fix-missing?”

Went through various terminal commands (after doing HotFix) but still no update from Kodi 18.7 - dark screen comes up saying ‘error’.

Are there any other options apart from a reinstall?

What does your /etc/apt/sources.list look like?
It might not be valid hence why updates are failing.

Sorry - pretty much a novice at this. Where do I find

Using this command

sudo nano /etc/apt/sources.list

this is what comes up

deb Index of /debian stretch main contrib non-free

deb Index of /debian stretch-updates main contrib non-free

deb stretch/updates main contrib non-free

deb stretch main

Stretch will be too old to upgrade. You will need to reinstall.

Would doing an edit in nano and replacing stretch with buster help?

I don’t recommend jumping like that, but if you want to try it you certainly can. It’s not something we can support directly.

The current supported version is Bullseye.
The Debian repository URLs changed for security updates however.

tried with buster … this is what came up

Debian GNU/Linux comes with ABSOLUTELY NO WARRANTY, to the extent
permitted by applicable law.
Last login: Thu Nov 9 16:52:31 2023 from
osmc@kodi:~$ sudo apt-get update --allow-releaseinfo-change
E: Command line option --allow-releaseinfo-change is not understood in combination with the other options
osmc@kodi:~$ sudo apt-get update
Get:1 buster/updates InRelease [34.8 kB]
Get:2 Index of /debian buster InRelease [122 kB]
Get:3 Index of /debian buster-updates InRelease [56.6 kB]
Get:5 buster/updates/main armhf Packages [563 kB]
Get:6 buster/updates/main arm64 Packages [559 kB]
Get:7 buster/updates/main Translation-en [307 kB]
Get:8 buster/updates/non-free armhf Packages [9,664 B]
Get:9 buster/updates/non-free arm64 Packages [5,204 B]
Get:10 buster/updates/non-free Translation-en [24.5 kB]
Get:11 Index of /debian buster/main arm64 Packages [7,737 kB]
Get:12 Index of /debian buster/main armhf Packages [7,706 kB]
Get:13 Index of /debian buster/main Translation-en [5,969 kB]
Get:14 Index of /debian buster/contrib arm64 Packages [38.4 kB]
Get:15 Index of /debian buster/contrib armhf Packages [40.1 kB]
Get:16 Index of /debian buster/contrib Translation-en [44.2 kB]
Get:17 Index of /debian buster/non-free arm64 Packages [53.9 kB]
Get:18 Index of /debian buster/non-free armhf Packages [62.1 kB]
Get:19 Index of /debian buster/non-free Translation-en [88.9 kB]
Get:20 Index of /debian buster-updates/main armhf Packages [8,784 B]
Get:21 Index of /debian buster-updates/main arm64 Packages [8,780 B]
Get:22 Index of /debian buster-updates/main Translation-en [6,915 B]
Reading package lists… Done
E: The method driver /usr/lib/apt/methods/https could not be found.
N: Is the package apt-transport-https installed?
osmc@kodi:~$ sudp apt-get dist-upgrade
-bash: sudp: command not found
osmc@kodi:~$ sudo apt-get update && sudo apt-get dist-upgrade --fix-missing
Hit:1 Index of /debian buster InRelease
Hit:2 Index of /debian buster-updates InRelease
Hit:3 buster/updates InRelease
Reading package lists… Done
E: The method driver /usr/lib/apt/methods/https could not be found.
N: Is the package apt-transport-https installed?

You could now try a dist-upgrade.

Which command would I use for that?

sudo apt-get dist-upgrade

Is there any danger of bricking or otherwise damaging my Vero unit doing this? (I have a backup)

No, worst case you have to make install media and start over. IMO your heading down the wrong path though. As I posted two days ago you can use a old backup on a newer install with a little more effort. My recommend would be to just use your current backup and restore that to your Vero V, Then ssh and run the commands I supplied in the other thread to get the library to upgrade, and then check everything to make sure your tickety-boo. The most you have to loose if somehow that goes sideways is needing to delete the .kodi folder to get back to defaults. At this point if everything is all good and you still want to use your Vero 4K I would do a clean install on it and then restore userdata on it from a backup you make on the newly configured Vero V.

OK that sounds best. Many thanks.