Vero 4K+ turns TV back on when in Suspend mode

Not related to April Update as it was happening b4 that - I was hoping April CEC update would fix hence had not reported it b4.

Issue is that if Vero is in Suspend mode (Red light) and I am watching somenthing else, when the TV is switched off, the Vero wakes up and switches the TV on.

If the Vero is ‘on’ then all good - goes into suspend mode, TV stays switched off.

I’ve tried playing with the CEC settings but no luck.


1 Like

Enable debugging and upload logs after this happens (best reboot before to have clean logs.

1 Like

I have the exact same issue on my 4k+ on the latest release (never tried older release).

I’ll try to create some log files soon. Here some more info:

  • I reinstalled the latest April update on my Vero 4k+ via the installer
  • I installed only some basic addons (osmc skin addons, subtitle providers)
  • My setup:
    LG OLED 55C7V
    Denon X1400H (connected to tv via arc)
    Apple TV 4K (connected to receiver)
    Vero 4K+ (connected to receiver)


  • Vero 4K+ wakes up from suspend mode when watching tv or using the apple tv
  • Vero 4K+ wakes up when switching from watching tv to apple tv (turn on apple tv). Most of the time the Vero pops up and I have to select Apple tv again on the input select of the tv/receiver
  • Vero 4K+ seems (not sure) not always to go to suspend after period of time, i have set this in kodi under power settings. Could be related to the issue above since I just notice from time to time that the red light is not on anymore when I check it.


1 Like

The same thing has happened to me for a long time. I went through the December update and it happens to me with this new one. Thank God that the vero is put on the screen in black after a while if it is not used. Otherwise, I would have burned my OLED panel.

I think we need to have some timelines when it happens so that we can link it to the log files.
Also maybe it makes sense to wait for the fix that avoids the suspend mode not working due to repeat key press. So my suggestion is we pick this up after the new version released in the coming days.

I have the same problem.

I’ve had the same or similar problems since buying the 4k+ last year. I just use a remote control power socket to make sure the thing is off now.

This should be fixed in the next update which will be ready in a few days.

Edit: just re-read this. We expect to turn on the TV when the device is woken up; but could make this configurable in the future.


I don’t mind the tv turning on when the Vero wakes up. Same thing does my Apple TV too.
My main issue is that it wakes up all of a sudden when watching tv and switches to the Vero.

I’ll wait until next update and try again… :slight_smile:

It shouldn’t be doing that.
Let’s wait for the next update.

Mine does this too. And I spend a lot of time away from home, so when I walk in after 2 days away my tv is turned on :man_facepalming:

Mine too. I’ve decided to turn down CEC commands and let VERO suspend itself after 20 minutes. Hoping to see this fixed soon!

On request I waited until the new release. As suspected the issue is still existing in the May update.

I turned on logging, rebooted my Vero 4K+ and put it in suspend mode. Switched to tv mode on my television and started watching tv.

See timeline and logs below:
23:18 reboot
23:20 suspend
23:50 automatic startup from suspend while watching tv

This is caused by the Gismeteo weather add-on, which is asking to wake the device.


Thank you Sam. I completely uninstalled the weather add-ons since I’m not using them (anymore) anyway.

I’ll monitor the system and let you know the outcome!

I’m sorry to say but the issue is still there.

21:18 reboot
21:19 suspend
21:49 automatic startup from suspend while watching tv

Does it happen with addons disabled / on a fresh install of osmc?

I have not tested this exactly.

I did notice it immediately when I freshly installed April update but I have not disabled addons.

Is there an easy way to disable and afterwards enable all addons ?

You can do this under Settings -> Addons

Sadly, I am still seeing the same issue. I’ve taken to powering off the Vero everyday. Not ideal.

Am not running many addons and certainly not the above weather one.