Vero 4K+ Update Issue


Is there a problem with the update server for the Vero 4k+ at the moment?
I keep getting the connectivity issue message everytime I try and check for updates through MyOSMC.
I’m on the May 2023 update. Everything else seems to be working fine.


There are no issues that I can see here.
Are other internet based services working as expected?

To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

Depending on the used skin you have to set the settings-level to standard or higher, in summary:

  • enable debug logging at settings->system->logging

  • reboot the OSMC device twice(!)

  • reproduce the issue

  • upload the log set (all configs and logs!) either using the Log Uploader method within the My OSMC menu in the GUI or the ssh method invoking command grab-logs -A

  • publish the provided URL from the log set upload, here

Thanks for your understanding. We hope that we can help you get up and running again shortly.

OSMC skin screenshot:

Hi Sam,

Thanks for the quick reply.
Sorry for not getting back to you about this sooner but its been a busy couple of weeks.
I was finally able to sit down and have a look at the issue I was having again today and noticed the new update for OSMC with Kodi v20.
I tried a command line update to the new release and got errors similar to what was shown in this thread: Update Connectivity Issue

So I tried the commands suggested there and its done the trick. Shiny new update to v20 and the My OSMC updates are working again.
Looking forward to what the new model you’re bringing out soon will have to offer.


Glad to hear things are working as expected now.