Vero 4K+ very dim image

Hi,

After happily using a Vero 4K+ some time now I decided to try and compare it with my AC Ryan Playon! HD 2 and MED600X3D. I’ve come to the conlusion that the other media players show a lot brighter image and have much more color depth. I’ve used a Philips 1080p TV for testing with 1080p (so no HDR) sources. HDMI settings were the same (also tried using the same port) and have tried both with and without limited color range. I have also tried enabling 4:2:2 color since the Philips TV uses a LG display. Also changed frame rate even though that has nothing to do with color.

The source isn’t the problem, I’ve tried multiple files and then compared the same file on both the Vero and other players.

I’ve also tried changing some settings like contrast and brightness. It gets brighter of course but then it also gets more white, which obviously isn’t the intention.

I can’t see anything weird in the log but if you need it I’ll upload it.

The TV supports 4:2:2, RGB and YbPbPr (and maybe even more). When I use a Onkyo TX-NR676E with passtrough and another type of TV and compare it there I also get the same results. I don’t have a HDR capable screen to test it with but that shouldn’t be the problem since I have tested all devices with the same non-HDR files on a non-HDR screen.

Thanks in advance!

Btw, thanks Sam for the remote control reaction speed update! It doesn’t lag anymore when pressing rapidly.

Edit: I’ve uploaded the complete config and logs: https://paste.osmc.tv/dumahefuso

Logs would be useful so we can see your config.

To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

Depending on the used skin you have to set the settings-level to standard or higher, in summary:

  • enable debug logging at settings->system->logging

  • reboot the OSMC device twice(!)

  • reproduce the issue

  • upload the log set either using the Log Uploader method within the My OSMC menu in the GUI or the ssh method invoking command grab-logs -A

  • publish the provided URL from the log set upload, here

Thanks for your understanding. We hope that we can help you get up and running again shortly.

OSMC skin screenshot:

It would also help to know what kind of files you are playing (some MediaInfo would be useful).

We removed the repeat filter, so the remote will react more promptly now.

I’ve uploaded the configs and the full log.

I’ll upload the MediaInfo today.

You need to provide us with the link given

Sorry, didn’t include link in the comment. I edited the post and put the link there.

Here is it again: https://paste.osmc.tv/dumahefuso

This may help, the vero with my JVC projector showed some issues with video, I currently have the following and it seems to maintain the correct video balance for brightness and contrast.

Set RGB on Vero and auto on projector. Previously Vero was on default.

Set full range on both Vero and projector. Previously projector was on auto but this stopped working after last update.

I used video patterns to set correct contrast and brightness. Once done the image is as good as old windows 7 with MPC player.

I switched from a Mede8er to the Vero, can’t say I noticed the slightest bit of difference.

How about the mediainfo?

Also:

The settings we recommend are as follows…

Settings>System>Display>Whitelist> (empty) *
Settings>Player>Videos>Adjust display refresh rate> On start/stop

Some televisions may also need, or benefit from, the following being set…

System>Display>Force 4:2:2 colour subsampling> (enable)

Does this affect Harmony BT remotes positively, too? I haven’t applied the March update yet…

May not be relevant, but what’s all this about?

2020-04-11 01:15:24.189 T:3792679648   DEBUG: CAddonSettings[service.vpn.manager]: failed to find definition for setting label1008. Creating a setting on-the-fly...
2020-04-11 01:15:24.189 T:3792679648   DEBUG: CSettingsManager: requested setting (label101) was not found.
2020-04-11 01:15:24.189 T:3792679648   DEBUG: CAddonSettings[service.vpn.manager]: failed to find definition for setting label101. Creating a setting on-the-fly...
2020-04-11 01:15:24.189 T:3792679648   DEBUG: CSettingsManager: requested setting (label1013) was not found.
2020-04-11 01:15:24.189 T:3792679648   DEBUG: CAddonSettings[service.vpn.manager]: failed to find definition for setting label1013. Creating a setting on-the-fly...
2020-04-11 01:15:24.189 T:3792679648   DEBUG: CSettingsManager: requested setting (label1045) was not found.

No – only the OSMC remotes are affected.

Ah ok. I don’t think it’s necessarily a Vero issue but both my Elites repeat at times and it’s mega annoying on both my 4K+.

Some of the Harmony users might be able to assist.
I seem to recall some setting in the app on PC that allowed this to be adjusted?

https://support.myharmony.com/en-us/adjusting-a-devices-command-repeats

Yep already messed with that ages ago. Pretty sure it’s just BT being BT as it just does it every x number of presses.

Sorry for the late response, I’ve been very busy the last couple of days.

Since I cannot upload TXT files I’ve created some links for the MediaInfo.
http://txt.do/1lter
http://txt.do/1ltek
http://txt.do/1lte4
http://txt.do/1lteq
http://txt.do/1ltem

I’ve set my TV to PC mode now so I also set the Vero to full range color. There is a very small diference and even after tweaking some options in the tv itself for that input I still get a result that’s far away from the Mede8er.

That’s a VPN manager which automatically connects to a specific country depending on the addon that was opened. It’s not relevant yeah, already had the problems before using that addon.

I didn’t either before. You should really compare them next to each other. You will notice a big difference. Especially since you can set all video settings in the Mede8er like hue, saturation and contrast, you can’t set these within Kodi. This should really become an option. As said I’ve tweaked some TV settings that I normally change in the device (hue, saturation and contrast) and I still don’t get even close to the Mede8er. It’s if there is some gray layer on top of the HDMI signal from the Vero 4K+/Kodi. The Mede8er doesn’t have this. I have 2 Vero’s and they have the same problem. So it probably isn’t a factory fault.

If the Vero had an analog video signal I would say, increase the video voltage from 1V to 1.2V but of course that’s different with a digital signal.

You can set brightness and contrast per video. Does that help?

I wonder if you are comparing like with like, I get the impression you may be comparing an image after adjustment (mede8or) against an untweaked (or less tweaked) image in the Vero.

Might be worth setting both images to default then comparing. If this shows little difference then it is the image adjustments that are the change, I suggest you use the TV adjustment to bring the images to where you want them.

You may already know this, so apologies if you do, but a good image starts with the right brightness, contrast and gamma. If these are set right then you are something like 75% there.

For 1080p, if available choose 6500k as the starting point on your TV, gamma between 2.2 and 2.4 then set brightness and contrast so that blacker than black and whiter than white are correct.

Here is a good source, including calibration patterns. https://www.avsforum.com/forum/139-display-calibration/948496-avs-hd-709-blu-ray-mp4-calibration.html#/topics/948496?page=1

I know, apart from the fact that I then will need to set it per video, it doesn’t really affect the color depth at the end.