Vero 4k, wifi not working

I’ve been meaning to post about this before now, wifi isn’t working on my 4k anymore and hasn’t been for a while.

There is no longer any listing for wifi under My OSMC networking, only wired and bluetooth, also ifconfig only lists eth0 and lo.

When booting, there’s a delay with a message about waiting for kernel modules to load, and dmesg suggests it failed to load the driver, posted here -

It WAS working when I got the vero, I can’t say exactly when it stopped but it was definitely before I did the recent July update.

(I hadn’t been relying on wifi because of the no hidden SSID support, but now that that seems solved I’d like to get this sorted)

So, what should I try next, re-installing from a fresh image? Anything else?

Thank you.

Did this happen recently after an update?


No, it’s been like this for a while, a few months at least and probably as far back as the april update, if not longer.

It’s possible it first happened right after an update, and I just didn’t notice because I wasn’t making use of wireless at the time anyway, but presumably if an update was the cause of this you would have seen many more similar reports?

I was considering re-installing a rather older image, close to the original software version that was installed on the device when I got it, to rule out updates being the cause, but I’d imagine a fresh re-install of the most recent version should be tried first?

edit: having said that, I did take look at the dmesg output sometime prior to the recent July update, and I didn’t see anything of note whereas the dmesg log I posted from after the update seems to have quite a bit of relevant output.

Maybe you were unlucky and the chip has failed. You can contact for a replacement under warranty.